LyX should recommend epstopdf for EPS support

Bug #238580 reported by Jakob Unterwurzacher on 2008-06-09
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lyx (Debian)
New
Undecided
Unassigned
lyx (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: lyx

I'm writing a scientific thesis with LyX on Windows and Ubuntu.
I started on Windows, included a bunch of EPS graphics - worked well.
Back on Ubuntu, no PDF could be rendered, because there was no EPS-to-PDF-converter,. And i thought "What the hell, EPS is _the_ vector graphics format".
Lots of users are hit by this - EPS support is a must-have in a GUI LaTeX front-end like LyX.

Solution: Install epstopdf (It's in package texlive-extra-utils).
LyX should depend on epstopdf or at least recommend it.

Note: ps2pdf is not a solution because
  a) it will merciless crop away parts of your graphic lying outside where ps2pdf thinks the page ends
  b) if you made your graphics smaller so it isn't cropped, you will get white space around your graphics. ps2pdf won't fit the pdf to your graphic.

epstopdf just does what's expected.

Ralph Janke (txwikinger) wrote :

Thanks for raising this issue and helping to make Ubuntu better.

Package should according to policy only depend on other packages if they are require for installation and configuration, or if a significant amount of functionality is provided.

However, I would suggest, that this packages is added to the recommends list.

Thanks

Changed in lyx:
assignee: nobody → txwikinger
importance: Undecided → Wishlist
status: New → Incomplete
wvengen (wvengen) wrote :

Yes, please! And we'd have to make sure that there is a proper converter rule defined:
  EPS -> PDF (eps2pdf): epstopdf $$i --outfile=$$o

Jakob Unterwurzacher (jakobunt) wrote :

Side note: The windows installer for LyX installs epstopdf (right, not eps2pdf or something else) by default along with the miktex LaTeX distribution.
It also sets the required converter rule automaticall (it's equivalent to what wvengen said, but LyX-win just does it like this):
EPS -> PDF (eps2pdf): epstopdf --outfile=$$o $$i

Ralph Janke (txwikinger) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in lyx:
status: Incomplete → Triaged
assignee: txwikinger → nobody
Dara Adib (daradib) on 2008-08-29
Changed in lyx:
importance: Wishlist → Low
csur (csur) wrote :

I am using Lyx 1.5.5 in Ubuntu (Linux 2.6.24-22-generic #1 SMP Mon Nov 24 18:32:42 UTC 2008 i686 GNU/Linux).

I am finding the problem using "epstopdf" even after I have added the required comments in Preferences/Converter.
Here is the screenshot of the converter declaration.

Then when I click to convert the documents to PDF (the screenshot attached in the next post)

Anybody has a solution to it ?

csur (csur) wrote :

The next screenshot

csur (csur) wrote :

The third screenshot when I used "--compress" in the converter.

I am having the same problem with this option too.

csur (csur) wrote :

Hey !!!
I just fixed it.

Here is the thing I did after a lot of googling !!!

1. open .lyx directory under your home.
2. Oen the file preferences (in any editor)
3. Modify / Add these few lines : (in converters section - virtually anywhere )

#
# CONVERTERS SECTION ##########################
#

\converter "eps" "pdf2" "epstopdf --compress $$i --outfile=$$o" ""
\converter "eps" "pdf" "epstopdf --compress $$i --outfile=$$o" ""

Now its working, I can see the proper rendering of EPS files to PDF output !!
Cheers.

Dara Adib (daradib) on 2008-12-23
Changed in lyx:
status: Triaged → Confirmed
thsths (thomas-steffen+ubuntu) wrote :

I have just been bitten by this bug, and I think it deserves more attention. I would argue that this should be fixed, and installing lyx should pull in epstopdf automatically (require it).

The reason is simple: EPS is the standard format for including graphics, PDF is the standard output format for LyX (using pdflatex as a backend), and I guess we all agree that including graphics is an important function of LyX. Without epstopdf, it just does not work correctly, so much so that it is essentially useless. In my book, that ticks all the boxes for being a requirement.

I also have to say that even after installing it, I had to fiddle with LyX for a while to get it right. A simple reconfigure did not do the job for some reason (even after I deleted an old manual conversion entry). All the more reason to get it right from the beginning.

@thsths:
Probably reporting it to upstream (Debian) would help getting this into Ubuntu.

thsths (thomas-steffen+ubuntu) wrote :

> Probably reporting it to upstream (Debian) would help getting this into Ubuntu.

I checked Debian sid / unstable, and lyx does pull in epstopdf. So I think this bug does not apply to Debian. This is why:

[code]
$ aptitude why texlive-extra-utils
i lyx Recommends texlive-latex-recommended
i A texlive-latex-recommended Recommends prosper (>= 1.00.4+cvs.2006.10.22-1)
i A prosper Depends texlive-pstricks
i A texlive-pstricks Recommends texlive-extra-utils
[/code]

Now in Ubuntu jaunty, the texlive-latex-recommended does not depend on prosper, and I think therefore texlive-pstricks is not pulled in. Ok, arguable lyx should depend on texlive-extra-utils directly, but there is no reason to change it in Debian.

Of course there is another bug involved here: why does ps2pdf not work properly? And should it?

thsths (thomas-steffen+ubuntu) wrote :

I had more trouble with eps images in the pdflatex backend, and that is despite using epstopdf. So I think there is more to this bug than meets the eye. It is probably an upstream issue with LyX 1.6.

freespace (s-launchpad) wrote :

In addition to installing epstopdf, you need to run Tools->Reconfigure, then restart.

You will now have an entry for EPS->PDF(ps2pdf) under Tools->Preferences->File Handling->Converts. The Converter should be something like:

epstopdf --outfile=$$o $$i

Now create a new converter definition by changing PDF (ps2pdf) to PDF (pdflatex) and click Add. It should make a new entry, EPS->PDF(pdflatex) with the same converter definition.

Now exports using pdflatex should preserve EPS as vector graphics.

This is on jaunty using Lyx 1.6.2.

Cheers,
Steve

freespace (s-launchpad) wrote :

One more thing, if the above doesn't seem to fix your problems in preview, disable cache in Tools->Preferences.

Erich E. Hoover (ehoover) wrote :

How is this not fixed yet? I just got a new computer and I was frustrated by my graphics winding up with poor quality until I realized that epstopdf wasn't loaded. I have no idea what LyX was using by default, but high quality graphics is an important reason to use LyX and LaTeX!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers