Can't install anything with gdebi

Bug #393381 reported by David Prieto
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gdebi
Fix Released
Undecided
Unassigned
gdebi (Ubuntu)
Undecided
Michael Vogt

Bug Description

Binary package hint: gdebi

I'm using gdebi on karmic and I can't install any deb package using it. Launching it from the terminal gives:

david@david-laptop:~$ bash -c "LANG=en_GB gdebi-gtk"

(process:6644): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
/usr/lib/python2.6/dist-packages/GDebi/GDebi.py:304: GtkWarning: gtk_tree_sortable_set_sort_column_id: assertion `GTK_IS_TREE_SORTABLE (sortable)' failed
  if fs.run() == gtk.RESPONSE_OK:
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:264: DeprecationWarning: Accessed deprecated property Package.installedDependencies, please see the Version class for alternatives.
  for dep_or in pkg.installedDependencies:
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:73: DeprecationWarning: Accessed deprecated property Package.installedVersion, please see the Version class for alternatives.
  instver = inst.installedVersion

(process:6644): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:264: DeprecationWarning: Accessed deprecated property Package.installedDependencies, please see the Version class for alternatives.
  for dep_or in pkg.installedDependencies:
/usr/lib/python2.6/dist-packages/GDebi/DebPackage.py:73: DeprecationWarning: Accessed deprecated property Package.installedVersion, please see the Version class for alternatives.
  instver = inst.installedVersion

As for the error message, this is what the GUI says:

dpkg: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor.

ProblemType: Bug
Architecture: i386
Date: Mon Jun 29 10:01:30 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: gdebi 0.4.9
PackageArchitecture: all
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
SourcePackage: gdebi
Uname: Linux 2.6.30-8-generic i686

Revision history for this message
David Prieto (frandavid100-gmail) wrote :
Revision history for this message
Michael Vogt (mvo) wrote :

There was a bug in python-vte for some days that caused this problem. Could you please check if you still have this error? We fixed the problem since.

Changed in gdebi (Ubuntu):
status: New → Incomplete
Revision history for this message
David Prieto (frandavid100-gmail) wrote :

I no longer have the error, thanks a lot.

Revision history for this message
Michael Vogt (mvo) wrote :

Thanks, I close the bug then :)

Changed in gdebi (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: Incomplete → Fix Released
Changed in gdebi:
status: New → Fix Released
Changed in gdebi (Ubuntu):
status: Fix Released → Confirmed
Changed in gdebi:
status: Fix Released → Confirmed
Changed in gdebi (Ubuntu):
status: Confirmed → Fix Released
Changed in gdebi:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers