dbus crashes when networking service is restarted

Bug #1102507 reported by frizzle21 on 2013-01-21
This bug affects 24 people
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)

Bug Description

on ubuntu 13.04 32 bit , dbus crashes when i do "sudo service networking restart".
unfortunately, this stops unity as well.
the computer keyboard became unresponsive and i had to create a folder on the desktop via the mouse context menu, open nautilus through that folder, find compiz in /usr/share/applications and restart unity by doubleclicking compiz.

( i think Unity should be in there, not "compiz" )

this brought back the window decoration and the keyboard, but the overall experience was still extremely slow. And the internet didn't come back on, even after i started networking again manually, and made sure that network-manager is also running, obviously because nm-applet had crashed along with dbus.

Starting nm-applet failed with the error message telling me that dbus is unreachable.
After a "sudo service dbus status" showed me that dbus had also crashed, i found my way back to a working system quite soon.

So how to reproduce this bug:
1. /etc/init.d/networking stop

Problems you will encounter immediately:
compiz crashed
dbus crashed
unity gone (window management, window decoration, keyboard navigation/typing/capture/focus)
nm-applet crashed unrecoverable

description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dbus (Ubuntu):
status: New → Confirmed
Junior (tradunskih) wrote :

Confirmed, this bugs countinue for me using ubuntu 12.04, 12.10 and yesterday with ubuntu 13.04...

This bug fixed if used kubuntu 12.04 with installed unity.

Confirmed on Ubuntu 13.04 64 bits. And at this moment I can't recover the unity shell (even after rebooting the computer :s ).

Heidi Howard (hh360) wrote :

I've had the same bug on Ubuntu 13.04 64 bit, I worked around it by using:
$ sudo service network-manager restart
instead of
$ sudo service networking restart

kuldeep kamboj (kuldeepk1979) wrote :

I have crash too but on Gnome3 on Ubuntu 13.04. After crash top bar of gnome disappears and keyboard shortcuts look like not working. Yes in my case keyboard works and I am able to restart computer by typing reboot in console.

wmwmwm (index-html) wrote :

This bug still exists in ubuntu 13.10 both 32 and 64 bit versions.

What's the status of this issue? It is by far the most disturbing bug in Ubuntu.

Steps: /etc/init.d/networking restart
Result: The GUI crashes, need to reboot
Desired result: New network settings are loaded, user can proceed as normal.

Dave Stadnick (dstadnick) wrote :

After configuring a static IP, running service "network-manager restart" does not appear to perform the desired task in the 64 bit server edition of 13.10. I just did a restart. Not a big deal since no one could have accessed the server using the newly assigned DHCP address anyway.

Siva (siva89r) wrote :

$sudo service network-manager restart

for the same issue
this worked for me . in 64bit Ubuntu 13.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers