FTBFS in Impish on s390x

Bug #1931243 reported by Christian Ehrhardt 
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Frank Heimes
Ubuntu on IBM z Systems
Undecided
Skipper Bug Screeners
gdisk (Debian)
New
Unknown
gdisk (Ubuntu)
Status tracked in Impish
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned

Bug Description

The bug here is mostly for tracking and the update-excuse tag.
I've reported it to Debian already at:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=989589

And at upstream:
https://sourceforge.net/p/gptfdisk/mailman/gptfdisk-general/thread/CAATJJ0LdpVeVGMMaYUe995%3DZFtuJu6tW5VjQ%3DONbpwci_fezZw%40mail.gmail.com/#msg37298406

See update details there.

tags: added: update-excuse
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

As it turns out gdisk/sgdisk have since the dawn of time written labels byte-swapped on s390x.
We'll continue to help in the upstream discussion and once a solution is available consider backporting (or not as it might wreak more havoc than not).

Affected are all releases since Xenial and also nonUbuntu like Fedora34 where I confirmed the same.

Changed in gdisk (Ubuntu Xenial):
status: New → Incomplete
Changed in gdisk (Ubuntu Bionic):
status: New → Incomplete
Changed in gdisk (Ubuntu Impish):
status: New → In Progress
Changed in gdisk (Ubuntu Hirsute):
status: New → Incomplete
tags: added: server-next
Changed in gdisk (Ubuntu Groovy):
status: New → Incomplete
Changed in gdisk (Ubuntu Focal):
status: New → Incomplete
Frank Heimes (fheimes)
tags: added: s390x
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :
Revision history for this message
Rod Smith (rodsmith) wrote :

I'm the author of GPT fdisk, and I intend to release a version 1.0.8 with this fix within a day or two. The only major change since 1.0.7 is the MR linked by Christian above. If patching earlier versions of GPT fdisk, then the following commit should be included, too:

https://sourceforge.net/p/gptfdisk/code/ci/86dd5fea351a5a55bea26b7622eb85ebd6075a60/

This commit fixes a matching problem on reading data. If both are uncorrected, then it looks like it's working, but the partition name is written in the wrong byte order on big-endian systems; and if one fix is applied without the other, then a partition name written by GPT fdisk will appear garbled when read back by GPT fdisk, and there may be compatibility problems with other programs.

This affects only big-endian systems.

Changed in gdisk (Debian):
status: Unknown → New
Revision history for this message
Rod Smith (rodsmith) wrote :

I've now released GPT fdisk version 1.0.8, which incorporates this bug fix, as well as a new feature in gdisk and sgdisk that enables correcting partition names that have already been corrupted by the bug.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Thank you Rod, trying to pick this up for Impish in a few days.

Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: New → In Progress
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

This got inot Debian experimental and synced from there

 gdisk | 1.0.8-1 | impish | source, amd64, arm64, armhf, i386, ppc64el, riscv64, s390x

Changed in gdisk (Ubuntu Impish):
status: In Progress → Fix Released
Changed in gdisk (Ubuntu Xenial):
status: Incomplete → Invalid
Changed in gdisk (Ubuntu Focal):
status: Incomplete → Invalid
Changed in gdisk (Ubuntu Hirsute):
status: Incomplete → Invalid
Changed in gdisk (Ubuntu Groovy):
status: Incomplete → Invalid
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

This was always wrong and old editions just "stay that wrong" without further disturbing things there. The new code does it right and now also has the feature to convert old broken disks.

So @fheimes this might be worth a release note entry?

Frank Heimes (fheimes)
Changed in ubuntu-release-notes:
assignee: nobody → Frank Heimes (fheimes)
Changed in gdisk (Ubuntu Bionic):
status: Incomplete → Invalid
Revision history for this message
Frank Heimes (fheimes) wrote :

I've added the following entry to the release notes:
"
gdisk/sgdisk has an issue and writes labels byte-swapped on big endian architectures.
This is non critical and on s390x mainly affects virtio SCSI disk partition labels.
Since this was always wrong, old releases just stay that way, but starting with 1.0.8 in Impish this is solved and even allows to fix/convert old broken labels.
"

Changed in ubuntu-release-notes:
status: New → Fix Released
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.