[Ubuntu] Patches on top of binutils 2.32

Bug #1824097 reported by bugproxy on 2019-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
High
Canonical Foundations Team
binutils (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]

 * Instructions change in z13 abi

[Test Case]

 * Testsuite adjusted, and should pass.

[Regression Potential]

 * Without these patches assembly/dissambly of code that uses renamed instructions will fail (z13+ abi)

[Other Info]

 * Original request.

Following patches have to be applied to binutils 2.32

- S/390: arch13: Adjust to recent changes
commit e49edb49713e435b8441bb5a9bd0c10d9df84e2f

- S/390: arch13: Add instruction descriptions
commit d98eed0923af29043ce18da43d2a242191d44ceb

- Revert "Add support to GNU ld to separate got related plt entries"
commit 9db2b33d363e2047df53f89ad34e7d1104299d12

bugproxy (bugproxy) on 2019-04-10
tags: added: architecture-s39064 bugnameltc-176833 severity-high targetmilestone-inin1804
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → binutils-s390x-cross (Ubuntu)
tags: added: disco
Changed in ubuntu-z-systems:
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Frank Heimes (frank-heimes) wrote :

Since disco is the only Ubuntu release with binutils in version 2.32, this applies to disco only.
And because disco is very close to release it's highly likely that this will come as an update after release/GA.

------- Comment From <email address hidden> 2019-04-10 07:25 EDT-------
important - Two instructions changed last minute. Assembler code using these instructions can not be assembled/disassembled correctly.
- S/390: arch13: Adjust to recent changes
commit e49edb49713e435b8441bb5a9bd0c10d9df84e2f

minor - Adds only doc strings
- S/390: arch13: Add instruction descriptions
commit d98eed0923af29043ce18da43d2a242191d44ceb

critical: Linking 32 bit code with partial relro results in broken binaries without this patch
- Revert "Add support to GNU ld to separate got related plt entries"
commit 9db2b33d363e2047df53f89ad34e7d1104299d12

no longer affects: binutils-s390x-cross (Ubuntu)
Changed in ubuntu-z-systems:
status: New → Triaged
Dimitri John Ledkov (xnox) wrote :

These patches are for 2.32, yet the target seems to be set targetmilestone-inin1804 -> are these needed to be backported to every release back to bionic? If yes, do you have patches for 2.31 and 2.30? Or is this for disco only?

description: updated
Dimitri John Ledkov (xnox) wrote :

All of the three mentioned patches are already in Disco / 2.32 as shipped by Ubuntu. As we regularly apply stable branch updates. You can check that this code is in the branch-updates.diff.

Is everything done here for Disco? Are you asking to backport this to some other series?

Changed in binutils (Ubuntu):
status: New → Fix Released
Changed in ubuntu-z-systems:
status: Triaged → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2019-04-10 10:21 EDT-------
Changed target milestone to 19.4 . thx for checking this....

tags: added: targetmilestone-inin1904
removed: targetmilestone-inin1804
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2019-04-10 13:00 EDT-------
(In reply to comment #10)
> All of the three mentioned patches are already in Disco / 2.32 as shipped by
> Ubuntu. As we regularly apply stable branch updates. You can check that this
> code is in the branch-updates.diff.
>
> Is everything done here for Disco? Are you asking to backport this to some
> other series?

Yes. These patches are required only ontop of 2.32 and will not fit onto older branches.

------- Comment From <email address hidden> 2019-04-10 13:02 EDT-------
(In reply to comment #12)
> (In reply to comment #10)
> > All of the three mentioned patches are already in Disco / 2.32 as shipped by
> > Ubuntu. As we regularly apply stable branch updates. You can check that this
> > code is in the branch-updates.diff.
> >
> > Is everything done here for Disco? Are you asking to backport this to some
> > other series?
>
> Yes. These patches are required only ontop of 2.32 and will not fit onto
> older branches.

Erm sorry that was misleading.

> Is everything done here for Disco?
Yes, everything done for Disco then.

> Are you asking to backport this to some other series?
No, only 2.32 needs patching.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2019-04-11 09:02 EDT-------
IBM bugzilla status -< closed, patches are already in 2.32 package. Many thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers