VM devices rdr, pun and prt are not activated after restart

Bug #1794308 reported by Frank Heimes on 2018-09-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Medium
Canonical Foundations Team
s390-tools
Fix Released
Unknown
s390-tools (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

 * Cannot configure race-free generic-ccw devices to be onlined on boot.

[Test Case]

# on a z/VM

$ sudo chzdev -d 0.0.000c 0.0.000d 0.0.000e
$ sudo chzdev -e 0.0.000c 0.0.000d 0.0.000e
$ sudo update-initramfs -u
$ sudo reboot
$ lszdev

Expectations is for generic-ccw c-d-e devices to be "yes yes" meaning online and persistent online.
Previously after a reboot they would be "no yes" meaning offline yet persistent configured online.

[Regression Potential]

 * generic-ccw rules need to be `upgraded` / `regenerated` which is not done in maintainer scripts in this upload for now.

[Other Info]

 * fix contributed upstream at

https://github.com/ibm-s390-tools/s390-tools/pull/45/files

 * original bug report

Linux s390x as VM guest can use the VM-specific reader (0.0.000c), puncher (0.0.000d) and printer devices (0.0.000e).

They can be enabled as usual with chzdev like:
lszdev | grep '000c\|000d\|000e'
generic-ccw 0.0.000c no no
generic-ccw 0.0.000d no no
generic-ccw 0.0.000e no no
sudo chzdev -e 000c 000d 000e
Generic CCW device 0.0.000c configured
Generic CCW device 0.0.000d configured
Generic CCW device 0.0.000e configured
lszdev | grep '000c\|000d\|000e'
generic-ccw 0.0.000c yes yes vmrdr-0.0.000c
generic-ccw 0.0.000d yes yes vmpun-0.0.000d
generic-ccw 0.0.000e yes yes vmprt-0.0.000e

Aa a result of that activation udev rules are generated:
ls -la /etc/udev/rules.d/41-generic-ccw-0.0.000{c,d,e}.rules
-rw-r--r-- 1 root root 238 Sep 21 06:24 41-generic-ccw-0.0.000c.rules
-rw-r--r-- 1 root root 238 Sep 21 06:24 41-generic-ccw-0.0.000d.rules
-rw-r--r-- 1 root root 238 Sep 25 10:15 41-generic-ccw-0.0.000e.rules
cat /etc/udev/rules.d/41-generic-ccw-0.0.000{c,d,e}.rules
# Generated by chzdev
ACTION=="add", SUBSYSTEM=="ccw", KERNEL=="0.0.000c", GOTO="cfg_generic_ccw_0.0.0
00c"
GOTO="end_generic_ccw_0.0.000c"

LABEL="cfg_generic_ccw_0.0.000c"
ATTR{[ccw/0.0.000c]online}="1"

LABEL="end_generic_ccw_0.0.000c"
# Generated by chzdev
ACTION=="add", SUBSYSTEM=="ccw", KERNEL=="0.0.000d", GOTO="cfg_generic_ccw_0.0.0
00d"
GOTO="end_generic_ccw_0.0.000d"

LABEL="cfg_generic_ccw_0.0.000d"
ATTR{[ccw/0.0.000d]online}="1"

LABEL="end_generic_ccw_0.0.000d"
# Generated by chzdev
ACTION=="add", SUBSYSTEM=="ccw", KERNEL=="0.0.000e", GOTO="cfg_generic_ccw_0.0.0
00e"
GOTO="end_generic_ccw_0.0.000e"

LABEL="cfg_generic_ccw_0.0.000e"
ATTR{[ccw/0.0.000e]online}="1"

LABEL="end_generic_ccw_0.0.000e"

Once this is done it's expected that this configuration is persistent and that these three devices are automatically activated after a reboot, which is not the case:

lszdev | grep '000c\|000d\|000e'
generic-ccw 0.0.000c no yes
generic-ccw 0.0.000d no yes
generic-ccw 0.0.000e no yes

A 'sudo udevadm trigger' doesn't help to activate them again.

Another 'sudo chzdev -e 000c 000d 000e' helps, but again for the current session only.

[
The cio_ignore list is empty, hence this can't be the reason:
cio_ignore -l
Ignored devices:
=================
$
]

Changed in ubuntu-z-systems:
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntu-z-systems:
assignee: nobody → Canonical Foundations Team (canonical-foundations)
tags: added: id-5baa55c367a0cd020990ac52
tags: added: id-5baa4a4ce2d7537ba20fd8c5
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-tools - 2.6.0-0ubuntu7

---------------
s390-tools (2.6.0-0ubuntu7) cosmic; urgency=medium

  * zdev: Trigger generic_ccw devices on any kernel module loads. LP:
    #1794308

 -- Dimitri John Ledkov <email address hidden> Tue, 16 Oct 2018 10:23:35 +0100

Changed in s390-tools (Ubuntu):
status: New → Fix Released
Changed in ubuntu-z-systems:
status: Triaged → Fix Released
Changed in s390-tools (Ubuntu Xenial):
status: New → Fix Committed
status: Fix Committed → In Progress
Changed in s390-tools (Ubuntu Bionic):
status: New → In Progress

Hello Frank, or anyone else affected,

Accepted s390-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/s390-tools/1.34.0-0ubuntu8.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in s390-tools (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in s390-tools (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Frank, or anyone else affected,

Accepted s390-tools into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/s390-tools/2.3.0-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Frank Heimes (frank-heimes) wrote :

Successfully verified on bionic - adjusting tags accordingly.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Frank Heimes (frank-heimes) wrote :

Successfully verified on xenial - adjusting tags accordingly.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for s390-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-tools - 2.3.0-0ubuntu3.1

---------------
s390-tools (2.3.0-0ubuntu3.1) bionic; urgency=medium

  * zdev: Adjust zdev modprobe path to be compatible with split-usr
    systems. (LP: #1777600)
  * zdev: Trigger generic_ccw devices on any kernel module loads. (LP:
    #1794308)

 -- Dimitri John Ledkov <email address hidden> Mon, 22 Oct 2018 12:37:39 +0100

Changed in s390-tools (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-tools - 1.34.0-0ubuntu8.8

---------------
s390-tools (1.34.0-0ubuntu8.8) xenial; urgency=medium

  * zdev: Adjust zdev modprobe path to be compatible with split-usr
    systems. (LP: #1777600)
  * zdev: Trigger generic_ccw devices on any kernel module loads. (LP:
    #1794308)

 -- Dimitri John Ledkov <email address hidden> Mon, 22 Oct 2018 12:51:12 +0100

Changed in s390-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in s390-tools:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.