ziomon: Packaging needs to handle blktrace dependency

Bug #1616593 reported by John George on 2016-08-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Low
Canonical Foundations Team
s390-tools (Ubuntu)
Low
Unassigned

Bug Description

$ lsb_release -rd
Description: Ubuntu 16.04 LTS
Release: 16.04

$ apt-cache policy s390-tools
s390-tools:
  Installed: 1.34.0-0ubuntu8.1
  Candidate: 1.34.0-0ubuntu8.1

Packaging needs to handle the installation of dependencies.

The unexpected output is shown here:
    ubuntu@s5lp1-gen01:~$ ziomon --version
    ziomon: Could not find blktrace. Please make sure that the blktrace package is installed and matches the level in the documentation.

Frank Heimes (fheimes) on 2016-09-01
tags: added: s390x
Frank Heimes (fheimes) on 2016-09-16
Changed in s390-tools (Ubuntu):
assignee: nobody → Frank Heimes (frank-heimes)
assignee: Frank Heimes (frank-heimes) → nobody
tags: added: packaging
Changed in s390-tools (Ubuntu):
importance: Undecided → Low
Frank Heimes (fheimes) on 2017-12-18
Changed in ubuntu-z-systems:
importance: Undecided → Low
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Frank Heimes (fheimes) on 2018-01-31
Changed in ubuntu-z-systems:
status: New → Triaged
Dimitri John Ledkov (xnox) wrote :

It is a suggests, we can split this tool into a separate package.

but i guess the real bug here, is that these extra utils should not be required to display help and/or version.

we have patched other ibm utils packages to suggest installing optional components.

John George (jog) wrote :

The issue still exists in 18.10.

bugproxy (bugproxy) on 2019-05-06
tags: added: architecture-s39064 bugnameltc-177421 severity-high targetmilestone-inin1910

------- Comment From <email address hidden> 2019-07-24 06:30 EDT-------
https://github.com/ibm-s390-tools/s390-tools/#build-and-runtime-requirements-for-specific-tools states the package requirements. Don't remember how it's currently packaged, but if you fear too many dependencies in case of one package containing all our tools, then, yes, a subpackage for ziomon would be an option.

It's not worth the effort modifying the behavior of the --version (or --help) option due to high regression risk and real users rely on the tool working.

bugproxy (bugproxy) on 2020-03-17
tags: added: targetmilestone-inin2004
removed: targetmilestone-inin1910
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-03-17 11:31 EDT-------
IBM Bugzilla status-> closed, Fix Released with focal

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers