Docker refuses start

Bug #1908539 reported by KD Puvvadi
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu WSL Integration
Medium
Patrick Wu

Bug Description

Installed Docker and tried checking the version. got the error cannot connect to the docker demon. same tried with reguler ubuntu with WSl, freshly installed docker trying running it and works perfectly but not on the preview.

Revision history for this message
KD Puvvadi (kdpuvvadi) wrote :
KD Puvvadi (kdpuvvadi)
information type: Public → Public Security
Revision history for this message
Joe Ferguson (svpernova09) wrote :

Unable to confirm on

```
halo@Rage:~$ sudo docker version
[sudo] password for halo:
Client: Docker Engine - Community
 Cloud integration: 1.0.7
 Version: 20.10.2
 API version: 1.41
 Go version: go1.13.15
 Git commit: 2291f61
 Built: Mon Dec 28 16:17:34 2020
 OS/Arch: linux/amd64
 Context: default
 Experimental: true

Server: Docker Engine - Community
 Engine:
  Version: 20.10.2
  API version: 1.41 (minimum version 1.12)
  Go version: go1.13.15
  Git commit: 8891c58
  Built: Mon Dec 28 16:15:28 2020
  OS/Arch: linux/amd64
  Experimental: false
 containerd:
  Version: 1.4.3
  GitCommit: 269548fa27e0089a8b8278fc4fc781d7f65a939b
 runc:
  Version: 1.0.0-rc92
  GitCommit: ff819c7e9184c13b7c2607fe6c30ae19403a7aff
 docker-init:
  Version: 0.19.0
  GitCommit: de40ad0
```

```
halo@Rage:~$ wslsys
WSL Version: 2
Locale: en_US
Release Install Date: Wed Jan 27 13:37:55 CST 2021
Branch: vb_release
Build: 19042
Full Build: 19041.1.amd64fre.vb_release.191206-1406
Display Scaling: 1.25
Windows Theme: dark
Windows Uptime: 0d 20h 6m
WSL Uptime: 0d 0h 14m
WSL Release: Ubuntu 20.10
WSL Kernel: Linux 5.4.72-microsoft-standard-WSL2
Packages Count: 623
```

Patrick Wu (callmepk)
information type: Public Security → Public
Revision history for this message
Patrick Wu (callmepk) wrote :

Hi,

You can solve the issue by running the command `sudo update-alternatives --config iptables`, select `iptables-legacy`, and start your deamon by `sudo service docker start`.

Revision history for this message
Patrick Wu (callmepk) wrote :

Some further investigation founds that it is related to WSL2 Kernel issue, as starting from Ubuntu 20.10 uses `nftables` that requires Linux Kernel 5.8 while Microsoft uses 5.4 for now. I will close here and forward the bug report to `microsoft/WSL` repository.

Patrick Wu (callmepk)
Changed in ubuntu-wsl-integration:
status: New → In Progress
importance: Undecided → Medium
Revision history for this message
Patrick Wu (callmepk) wrote :

A workaround is published via `ubuntuwsl`. The fix can be applied using `sudo ubuntuwsl tricks gh6044`.

Changed in ubuntu-wsl-integration:
status: In Progress → Fix Released
assignee: nobody → Patrick Wu (callmepk)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers