Ubuntu Website Product

getubuntu download not proposing .torrent

Reported by john smith on 2007-04-04
14
Affects Status Importance Assigned to Milestone
Ubuntu Website
Medium
Matthew Nuzum

Bug Description

http://www.ubuntu.com/getubuntu/download dont propose to download via bitorrent directly.
i think it would be nice to have the option offered in the front page.

Personnaly i just though that bittorrent was no more a possibility until i found out that there is still a way. http://www.ubuntu.com/getubuntu/download links to http://www.ubuntu.com/getubuntu/downloadmirrors but without mentionning the fact that it is bittorrent, then grep for torrent, and you arrive on a list which offer only 6.10 torrent. how to get the 7.04 torrent is left in exercice to the reader :)

Matthew Nuzum (newz) wrote :

This is deliberate. For now we prefer to keep bittorrent low key.

Changed in ubuntu-website:
assignee: nobody → newz
status: Unconfirmed → Rejected
David Symons (bimberi) wrote :

Why?

Currently (just after Feisty's release) it would be advantageous to hilight the bittorrent links as both the iso and repository mirrors are very slow.

Matthew East (mdke) wrote :

I agree. In fact, I'm not even convinced that there is a deliberate policy to keep bittorrent low key - as noted on other bugs, the release notes explicitly mention the torrents.

I'm going to reopen the bug until we have a definitive statement from one of the Ubuntu drivers about this.

Changed in ubuntu-website:
importance: Undecided → Medium
status: Rejected → Confirmed

I think it's a wonderful way for users to easily give back to Ubuntu. If nothing else, users that don't seed will generally still be donating a little bit of bandwidth. This could greatly help during release dates, which I'm sure would be crazy for their networks.

I only think of a couple reasons why they wouldn't encourage the use of the .torrent. Maybe it's because of some idealism, but it's (mostly) open source, right? Maybe it's for security, but it has checksumming, right?

Maybe one of those reasons is why they have the strange jigdo files. Maybe they should encourage the use of that?

Besides, Fedora has a very prominent link on their page, and I love donating idle bandwidth to seeding their huge DVD iso.

Agreed. It's kind of silly how much you have to look to find the BitTorrent downloads of the latest releases. If anything, Canonical should be pushing BitTorrent as a means of distribution.

Colin Watson (cjwatson) wrote :

I'm not sure what the point of keeping BitTorrent low-key is. In practice so many people use it anyway, and everyone seems to want it. I don't remember hearing a reason why BitTorrent would be bad; in fact I could have sworn we used to promote it as the best way to download Ubuntu CDs.

Matthew, could you elaborate on your comment, please?

Matthew Nuzum (newz) wrote :

There are two reasons not to make this too prominent:

 #1 I have been asked by the sysadmins not to emphasize this because it increases their workload dramatically during their busiest time (release day) due to challenges with the tracker. I'm not real sure how bt works or what the tracker is for but this is their decision

 #2 BT is harder to use than a big green button that says "download" because users have to install software which can vary greatly from computer to computer. Ubuntu strives to be accessible to the masses and everyone understands, "your download will begin shortly."

That said, the new download page that will launch tomorrow lists "other download options" which includes a link directly to a section on the other options page which explains bt and has links directly to the torrents.

Even if #1 is solved #2 requires user education and I don't think the download page is the place to do that. But I think you'll be happy that the new download page makes it easier to find for those who want BT. Plus it gives a unique url that others can use when telling people about BT.

James Troup (elmo) wrote :

There's (from my POV, IMO) several reasons why bittorrent should
certainly not be the default and probably low key.

(1) The bittorrent server story is _terrible_. Every server we've
    looked at is completely unreliable (we run our current one in a
    while loop it crashes so often!) and doesn't scale well (sic).

(2) bittorrent, on the client side, still fails ungracefully in a lot
    of situations (NAT, networks with egress restrictions, asymmetric
    links). This can lead to a bad user experience (much worse than a
    'slow' download of an ISO, IMO).

(3) bittorrent fundamentally changes the proposition for the user and
    that needs to be well explained. It's gone from "I'm downloading
    this file" to "I'm downloading this file and using my up bandwidth
    to share what I've got with others (including after I finished
    downloading)". This also has implications for people in varying
    situations, e.g.

     (1) people on asymmetric links which degrade when their up
         bandwidth is maxed out
     (2) people on corporate networks who's sysadmins don't appreciate
         their up bandwidth being used in this way
     (3) people in countries with metered bandwidth, esp. where you
         pay more for international traffic

Don't get me wrong, bittorrent works great for a lot of people and I'm
happy we continue to support people who choose to use it (as it helps
the load in my DC!) but I don't think it's yet ready to be 'default'
or 'prominent' for millions of new/casual users.

Neal McBurnett (nealmcb) wrote :

Thanks for the clarifications, James and Matthew, and I'm glad to hear of the progress in making the links more direct. I agree that education needs to be done and it should be an informed choice by the user.

The benefits of that education accrue not just to us, but to all those sharing files that are big, and helping folks do it well helps promote the underlying philosophy of Ubuntu.

What bt server are we using, and how does it fail? Can you point to bug reports on the server problems?

Matthew Nuzum (newz) wrote :

We still don't want to make this feature too prominent, however we have now included a list of additional options which includes BT on the download page.

Changed in ubuntu-website:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers