Comment 118 for bug 585940

The maverick website update brings a drop-down box that has two options:
32-bit (recommended)
64-bit

As we can see, 32-bit is still being recommended above, but nothing about the 64-bit version is being mentioned. Hence, I think this is fixed now.