Comment 11 for bug 585940

64bit seems to have more flash/compatibility issues then 32bit, but if you are at least a power user you should be able to Google up a quick terminal remedy. I would recommend 32bit Ubuntu to all other basic users to avoid issues.