old http://www.no-name-yet.com/patches/ URLs broken

Bug #273921 reported by Colin Watson on 2008-09-24
6
Affects Status Importance Assigned to Milestone
ubuntu-community
Medium
Ubuntu Technical Board
ubuntu-website-content
Low
Steve Edwards

Bug Description

Some Debian bug reports (some of which are probably even still open, given the general nature of things) refer to patches we wrote and published under http://www.no-name-yet.com/patches/... URLs. These are still available as http://people.ubuntu.com/patches/..., but the old URLs don't redirect here but give a "page not found" message instead (e.g. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=262102 which links to http://www.no-name-yet.com/patches/read-edid.262102.diff). It would be lovely if we could just fix those redirects.

Jonathan Davies (jpds) on 2010-01-09
Changed in canonical-website:
status: New → Confirmed
Matthew Nuzum (newz) on 2010-07-28
affects: canonical-website → ubuntu-website-content
Gerry Carr (gerry-carr) on 2011-01-18
Changed in ubuntu-website-content:
importance: Undecided → Low
assignee: nobody → Richard Lee (Canonical) (rhlee)
Richard Henry Lee (rhlee) wrote :

Clarify with Colin.

Richard Henry Lee (rhlee) wrote :

Colin,

I don't quite understand the http://www.no-name-yet.com/patches/.. and the http://people.ubuntu.com/patches/... links. It would be great if you could elaborate on them.

Changed in ubuntu-website-content:
status: Confirmed → In Progress
Richard Henry Lee (rhlee) wrote :

The www.no-name-yet.com urls used to redirect or serve relevant content.

This domain is now unserved. IS?

Colin Watson (cjwatson) wrote :

(I talked with Richard over IRC and I think we've cleared up the
historical confusion here.)

The other question is where the content has gone. The people.ubuntu.com
URL I gave in my original report no longer works, and I can't find the
relevant files anywhere on lillypilly (the system hosting
people.canonical.com). Perhaps IS has moved them elsewhere?

Changed in ubuntu-website-content:
assignee: Richard Henry Lee (rhlee) → Andrew Glen-Young (aglenyoung)
assignee: Andrew Glen-Young (aglenyoung) → The Canonical Sysadmins (canonical-sysadmins)
Andrew Glen-Young (aglenyoung) wrote :

We previously believed the domain to be unused and had recently begun transferring the domain elsewhere. However the patches are still safe and I have transferred them to the current people.ubuntu.com machine (not to be confused with people.canonical.com).

Once the DNS is sorted out, the patches should again become publicly available.

Sorry to be the bearer of bad news.

The domain no-name-yet.com was returned to its rightful owner. We can't restore this functionality because we no longer own the domain..

I imagine this leaves us with updating the URLs in the debian bugs, via a great big s/www.no-name-yet.com/people.ubuntu.com/g?

Let us know how IS can assist.

 -Charlie

Colin Watson (cjwatson) wrote :

I'm not sure Canonical ever owned the domain directly, but it's not as if it's owned by a hostile third party:

  owner-name: Matt Zimmerman

I'll ask Matt to comment on this bug.

Matt Zimmerman (mdz) wrote :

What I suggest is that we attach a copy of the relevant patch to each bug in the Debian BTS which is still open. Many Debian developers have expressed a preference for receiving a copy of the patch rather than a link anyway, and this avoids any need to host the patches separately.

These patches are now several years old, and many of them are probably obsolete anyway. Depending on how many still have a bug open, it might be worth doing a quick manual check to see if there are in fact any valid patches remaining.

Colin Watson (cjwatson) wrote :

Could IS inform us of the URL where we can find what used to be on http://www.no-name-yet.com/patches/?

Matt Zimmerman (mdz) wrote :
Changed in ubuntu-community:
assignee: nobody → Ubuntu Technical Board (techboard)
importance: Undecided → Medium
Andrew Glen-Young (aglenyoung) wrote :

@colin, @matt:

http://people.ubuntu.com/patches should now work as expected.

Kees Cook (kees) wrote :

Closing TB side, as http://people.ubuntu.com/patches is working.

Changed in ubuntu-community:
status: New → Fix Released
Changed in ubuntu-website-content:
assignee: The Canonical Sysadmins (canonical-sysadmins) → Steve Edwards (steve-edwards)
Matt Zimmerman (mdz) wrote :

The original purpose of this patch repository was to provide patches to Debian.

The DEX project has reviewed all of the patches there and ensured that they are filed in the Debian BTS as appropriate: http://dex.alioth.debian.org/ubuntu/ancient-patches/status/

Therefore, from my perspective and that of DEX, this content is obsolete and I see no reason why it needs to be kept online at any location anymore.

Ellen Arnold (ellenjanearnold) wrote :

Based on Matt's most recent post, I'm going to close this bug.

Changed in ubuntu-website-content:
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers