The downloading URL not found

Bug #1771085 reported by mengfei liang
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Peter Mahnke

Bug Description

I tried to download Ubuntu server 16.04 64 bit from this URL, but it always return the error message as "404 Not Found". Since this is a China version website, I tried to switch to US version but I could not find anyway to do so. So I feel myself totally prohibited from Ubuntu. Please fix this problem as soon as possible. Thanks.

mengfei liang (huijiang)
information type: Proprietary → Public
Revision history for this message
Carla Berkers (carlaberkers) wrote :

Thanks for bringing this to our attention! I tried the link you shared and got a 404 as well (from the UK). Can you tell us where you found a link to this URL? The main server download page allows you to download the latest 18.04 LTS, which might be of use until we get this fixed.

Revision history for this message
mengfei liang (huijiang) wrote :

Well, I think that is because I am using Chinese as the default language for my MAC, so everytime when I go google "Ubuntu server 16.04" it would return the Chinese version search results for me.

Revision history for this message
Peter Mahnke (peterm-ubuntu) wrote :

That url isn't meant to be altered.

The server has changed the name of their installer, so the image's file name has changed. It didn't exist for 16.04, so it creates an error.

If you look on the [Alternative Downloads]( page, you will see a 'Past releases and other flavours' section which will get you to someplace like - to download. Or you can try one of the more local mirrors or bit torrents.

Sorry, it wasn't simpler.


Changed in ubuntu-website-content:
status: New → Invalid
assignee: nobody → Peter Mahnke (peterm-ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers