Icon not shipped in the .deb package

Bug #1466518 reported by David Planella on 2015-06-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Calculator App
Medium
Bartosz Kosiorek
Ubuntu Document Viewer App
Medium
Bartosz Kosiorek
Ubuntu Weather App
Medium
Victor Thompson

Bug Description

The debian package does not ship the icon file, so when the app is installed as a .deb, neither the apps scope nor the launcher display its icon.

To reproduce, either build the package locally and install, or alternatively install directly from this PPA: https://launchpad.net/~dpm/+archive/ubuntu/ppa?field.series_filter=vivid

This can be tested on a desktop with either a unity 7 or unity 8 session.

Related branches

David Planella (dpm) on 2015-06-18
Changed in ubuntu-calculator-app:
status: New → Triaged
Changed in ubuntu-docviewer-app:
status: New → Triaged
Changed in ubuntu-weather-app:
status: New → Triaged
Changed in ubuntu-calculator-app:
importance: Undecided → Medium
Changed in ubuntu-docviewer-app:
importance: Undecided → Medium
Changed in ubuntu-weather-app:
importance: Undecided → Medium
tags: added: bitesize
Changed in ubuntu-calculator-app:
status: Triaged → In Progress
Changed in ubuntu-docviewer-app:
status: Triaged → In Progress
Changed in ubuntu-weather-app:
status: Triaged → In Progress
Changed in ubuntu-calculator-app:
assignee: nobody → Bartosz Kosiorek (gang65)
Changed in ubuntu-docviewer-app:
assignee: nobody → Bartosz Kosiorek (gang65)
Changed in ubuntu-weather-app:
assignee: nobody → Bartosz Kosiorek (gang65)
Victor Thompson (vthompson) wrote :

I can confirm this is an issue with the Weather app's reboot series. I don't know if it is an issue or not with the current version of the app in trunk--but it's probably only worth fixing in the reboot series. More specifically, it needs to be fixed in the reboot series.

David Planella (dpm) wrote :

Indeed. Looking at how we do it on Music, it would seem that the only part missing is the installation rule

Something along the lines of this on the top CMakeLists.txt file:

install(FILES ${SRC_FILES} ${ICON_FILE} DESTINATION ${DATA_DIR})

Or alternatively, this shouldn't be conditional. That is, the rule should be executed regardless of the click mode, as otherwise the icon will not be installed in the .deb build:

http://bazaar.launchpad.net/~ubuntu-calculator-dev/ubuntu-calculator-app/reboot/view/head:/app/CMakeLists.txt#L8

David Planella (dpm) wrote :

That was for Calculator, but it applies to Weather (reboot) too.

For docviewer I'm not sure what's going on, as there seems to be an install rule that should be executed in the .deb build, so it might require a bit more of investigation:

http://bazaar.launchpad.net/~ubuntu-docviewer-dev/ubuntu-docviewer-app/trunk/view/head:/CMakeLists.txt#L106

description: updated
Bartosz Kosiorek (gang65) wrote :

Hi Victor.

For standard Weather application everything is working perfectly fine.

For reboot, another error is displayed. I submitted bug for that:
https://bugs.launchpad.net/ubuntu-weather-app/+bug/1468418

Changed in ubuntu-weather-app:
status: In Progress → Invalid
assignee: Bartosz Kosiorek (gang65) → nobody
David Planella (dpm) wrote :

Thanks Bartosz. The fact that it's the Weather reboot series that is affected does not qualify the bug as Invalid, and neither does the fact that the packaging is affected by another bug, thus reopening the Weather bug task.

Changed in ubuntu-weather-app:
status: Invalid → Triaged

Fix committed into lp:ubuntu-docviewer-app at revision 155, scheduled for release in ubuntu-docviewer-app, milestone 2014-10-30

Changed in ubuntu-docviewer-app:
status: In Progress → Fix Committed

Fix committed into lp:ubuntu-calculator-app at revision 200, scheduled for release in ubuntu-calculator-app, milestone Unknown

Changed in ubuntu-calculator-app:
status: In Progress → Fix Committed
Changed in ubuntu-weather-app:
assignee: nobody → Victor Thompson (vthompson)

Fix committed into lp:ubuntu-weather-app/reboot at revision 61, scheduled for release in ubuntu-weather-app, milestone 2.0

Changed in ubuntu-weather-app:
status: Triaged → Fix Committed
Changed in ubuntu-docviewer-app:
status: Fix Committed → Fix Released
Andrew Hayzen (ahayzen) on 2015-10-23
Changed in ubuntu-weather-app:
status: Fix Committed → Fix Released
Changed in ubuntu-calculator-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers