[weather] Rain, snow, and chance are not translatable

Bug #1357642 reported by Victor Thompson on 2014-08-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
Ubuntu Weather App
Undecided
Victor Thompson

Bug Description

Currently the labels for Rain, Snow, and chance are not in the pot file and not available to be translated.

Related branches

Changed in ubuntu-weather-app:
status: New → In Progress
assignee: nobody → Victor Thompson (vthompson)

Fix committed into lp:ubuntu-weather-app at revision 333, scheduled for release in ubuntu-weather-app, milestone alpha-1

Changed in ubuntu-weather-app:
status: In Progress → Fix Committed
Adolfo Jayme (fitojb) wrote :

Can the “% chance” string be reworded? It is recognized by Launchpad as an argument (the “% c”) and doesn’t let me submit a translation for it. I know it’s a Launchpad bug, but it’s quicker that you workaround it than Launchpad fixing it.

Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
tags: added: touch
Adolfo Jayme (fitojb) wrote :

Victor, try submitting a translation for that string and you’ll see the error I’m talking about.

Adolfo Jayme (fitojb) wrote :

OK, closing this as fixed since the missing strings are available for translation now and the bug about the problematic percent is reported separately over bug 1357742. Thanks for your work!

Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in ubuntu-weather-app:
status: Fix Committed → Fix Released

Fix committed into lp:ubuntu-weather-app at revision 336, scheduled for release in ubuntu-weather-app, milestone alpha-1

Changed in ubuntu-weather-app:
status: Fix Released → Fix Committed
David Planella (dpm) wrote :

Please note that it's not a bug in Launchpad. The issue is that xgettext extracts the string and interprets it as a format string "%c":

#, c-format
msgid "% chance"
msgstr ""

Then Launchpad displays it and does error checking interpreting it as a format string, as marked in the .pot fie "#, c-format". I believe one way to work around this is to mark the original string as "%% chance" (see the double percentage mark), but I've not tried it myself.

Changed in ubuntu-weather-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers