API key for geonames.org

Bug #1326918 reported by Martin Borho on 2014-06-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Status tracked in Trunk
Trunk
High
Nekhelesh Ramananthan
Ubuntu Weather App
High
Martin Borho

Bug Description

Still using an api-key related to a individual developers account.

Related branches

Martin Borho (martin-borho) wrote :

I think not, since the outout of http://geoname-lookup.ubuntu.com/?query=Farnborough&release=utopic seems quite sparse.

Compared to http://api.geonames.org/searchJSON?style=full&username=uweatherdev&name_startsWith=Farnbor&maxRows=25&featureClass=P for example. We need further infos about counties, timezone etc pp.

Changed in ubuntu-clock-app:
milestone: none → rtm
Martin Borho (martin-borho) wrote :

Comparing both result sets, following fields in geoname-lookup.ubuntu.com are missing:

- admin2
- admin3
- countryCode
- timezone (very important, also for clock app!)

Additional to the data fields mentioned above, the possibillity to search names by their start-chars is needed for the predictive search (see name_startsWith query param for geonames.org.)

A JSON response type for http://geoip.ubuntu.com/lookup would also be handy!

Nekhelesh Ramananthan (nik90) wrote :

For the clock app, we make use of,

- timezoneID
- city
- country
- admin2
- admin3

We used to need lat and long before for the old clock app, but for the new clock that is no longer necessary.

Changed in ubuntu-clock-app:
status: New → Confirmed
importance: Undecided → High
Nekhelesh Ramananthan (nik90) wrote :

It doesn't make sense to switch the old clock app to http://geoname-lookup.ubuntu.com/ since we are going to anyway replace it with the new clock app. Ideally I would do it but it is not as simple as just changing the url in the old clock app. Hence marking it as Won't Fix.

Changed in ubuntu-clock-app:
milestone: rtm → none
status: Confirmed → Won't Fix

Filed a new RT to update the geonames with the linked branch. https://portal.admin.canonical.com/74203 (you may not be able to access this, sorry).

I can't figure out how to get the admin3 data right now, but will investigate that further.

The above RT has been completed, the http://geoname-lookup.ubuntu.com/ service now provides timezone, admin1 and admin2.

e.g. http://geoname-lookup.ubuntu.com/?query=Farnborough

Fix committed into lp:ubuntu-clock-app/reboot at revision 57, scheduled for release in ubuntu-clock-app, milestone rtm

Changed in ubuntu-clock-app:
status: Won't Fix → Fix Committed
Changed in ubuntu-clock-app:
status: Fix Committed → Won't Fix
David Planella (dpm) wrote :

Was this ever fixed in the Weather app? If it wasn't, I think we should before we hit the market and start hitting API request limits.

tags: added: rtm14 touch touch-2014-10-09
Changed in ubuntu-weather-app:
importance: Undecided → High
status: New → Incomplete

Martin, can we switch from geonames.org to the ubuntu geoname-lookup now? Is this just waiting on a geoname-lookup deployment?

Martin Borho (martin-borho) wrote :

The cpp extension for the timezones.

David Planella (dpm) on 2014-10-09
tags: added: touch-2014-10-16
removed: touch-2014-10-09
Changed in ubuntu-weather-app:
assignee: nobody → Martin Borho (martin-borho)
status: Incomplete → In Progress
Aditya (dtrg21) on 2016-01-12
Changed in ubuntu-weather-app:
status: In Progress → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers