[gallery] album overview open/close transition is hidden by tab bar

Reported by Adam Dingle on 2012-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Calum Pringle
gallery-app (Ubuntu)
Undecided
Unassigned

Bug Description

From Calum:

The album overview open / close transition - it's awkward when that happens underneath the tab bar... can it happen on top? Or even push the tab bar out of the screen temporarily? I'm open to suggestions and try either of these approaches, but I think what we have at the moment looks a bit odd.

Tags: bug Edit Tag help
Adam Dingle (adam-yorba) on 2012-05-30
Changed in goodhope:
milestone: proto2 → alpha2
Charles Lindsay (chaz-yorba) wrote :

For albums partially scrolled up behind the tab bar, I don't think it makes sense to pop them to the front just for the animation. Thus I think that moving the tab bar out of view would be the only workable solution to this problem. However, now the tab bar auto hides from scrolling. I think it would be a bit odd for it to also pop out of the way just for an animation. Do you have an updated opinion about this Calum?

Changed in goodhope:
assignee: nobody → Calum Pringle (calumpringle)
status: New → Incomplete
Calum Pringle (calumpringle) wrote :

So if the tab bar is in view, and an album is selected which is in fact underneath that tab bar, the view should first scroll upwards, so that the album is fully visible, then launch into the transition, where the album opens on top of the tab bar.

Adam Dingle (adam-yorba) wrote :

Remember that this transition is incremental: as the user moves their finger slowly or quickly over an album, the open/close transition follows along. So are you suggesting that as soon as the user starts dragging in this situation, the view will scroll even though a drag is in progress? That seems a little odd, since the user's finger won't be scrolling along with the view, obviously.

Calum Pringle (calumpringle) wrote :

Ahh hold on I'm confused... I was referring to when you launch an album?

Adam Dingle (adam-yorba) wrote :

Recall that to avoid confusion, we usually use the terms enter/leave when we're talking about launching an album, and the terms open/close when the user is flipping an album open or closed in the album overview. As for this bug, if an album is behind the tab bar, then both opening/closing and entering/leaving could be slightly awkward (as you can see in the current implementation). So for both these operations what change should we make, if any?

Calum Pringle (calumpringle) wrote :

Ahh right yes sorry my bad. Ok after discussing a few options with Oren and Chris, the solution we'd like to *try* if it's not too complex, is that on both the occasion that a swipe over an album (to open / close it) is recognised, or the enter / leave is about to begin, the tab bar should slide out of view (as it does on scroll). We'll then revisit whether this is still awkward.

Charles Lindsay (chaz-yorba) wrote :

Thanks, that sounds workable for now. Once we get that far, we can revisit.

Changed in goodhope:
status: Incomplete → New
assignee: Calum Pringle (calumpringle) → nobody
Adam Dingle (adam-yorba) on 2012-06-28
Changed in goodhope:
assignee: nobody → Eric Gregory (eric-yorba)
Adam Dingle (adam-yorba) on 2012-06-28
Changed in goodhope:
assignee: Eric Gregory (eric-yorba) → nobody
milestone: alpha2 → alpha3
Adam Dingle (adam-yorba) on 2012-08-28
Changed in goodhope:
milestone: alpha3 → beta1
Adam Dingle (adam-yorba) on 2012-09-26
Changed in goodhope:
milestone: beta1 → final
Changed in goodhope:
assignee: nobody → Clint Rogers (clinton-yorba)
Jim Nelson (yorba-jim) on 2012-10-15
Changed in goodhope:
assignee: Clint Rogers (clinton-yorba) → nobody
Jim Nelson (yorba-jim) on 2012-10-30
Changed in goodhope:
status: New → Confirmed
Changed in goodhope:
importance: Undecided → Low
Alan Pope ㋛ (popey) on 2013-05-08
information type: Private → Public
affects: goodhope → gallery-app
Changed in gallery-app:
milestone: final → none
Changed in ubuntu-ux:
assignee: nobody → Calum Pringle (calumpringle)
status: New → Triaged
importance: Undecided → High
John Lea (johnlea) on 2013-08-08
Changed in ubuntu-ux:
status: Triaged → Fix Committed
John Lea (johnlea) on 2013-08-08
summary: - album overview open/close transition is hidden by tab bar
+ [gallery] album overview open/close transition is hidden by tab bar
Pat McGowan (pat-mcgowan) wrote :

The tabs hide when the album opens

Changed in gallery-app (Ubuntu):
status: New → Fix Released
no longer affects: gallery-app
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers