Lightdm should display user picture (wish)

Reported by mlaverdiere on 2011-08-26
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Undecided
Katie Taylor
Unity Greeter
Wishlist
Unassigned
unity-greeter (Ubuntu)
Wishlist
Unassigned

Bug Description

Only a wish, nothing too important of course, but that's a pretty standard feature these days.

I'm on Oneiric Alpha 3 right now.

Thanks.

Changed in lightdm (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

Which greeter are you using? unity-greeter?

Changed in lightdm (Ubuntu):
status: Confirmed → Incomplete
mlaverdiere (mlaverdiere) wrote :

I guess it's unity-greeter if, by that, you're referring to standard (out of the box) lightdm on Oneiric (beta).

Changed in lightdm (Ubuntu):
status: Incomplete → Confirmed
affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)

Still present in Precise Alpha 1.

Changed in unity-greeter:
status: New → Triaged
Changed in unity-greeter (Ubuntu):
status: Confirmed → Triaged
Changed in unity-greeter:
importance: Undecided → Wishlist
John Lea (johnlea) wrote :

When doing background research before starting the design of the Unity Greeter we looked at login screens on competing platforms, and they all followed roughly the same format with picture and name. One problem was most users never set the picture, and if they do it is frequently with a default avatar. Also the picture is a 'nice to have', not an essential element of the login functionality. So the decision was made to look at a range of different concepts, and out of that work came the Unity Greeter you see today. The decision to not have pictures was a conscious choice; whether you agree or disagree with this choice I hope you feel the resulting Unity Greeter has a unique character! ;-)

Marking 'Won't Fix'

Changed in ayatana-design:
status: New → Won't Fix
Changed in unity-greeter (Ubuntu):
status: Triaged → Invalid
Changed in unity-greeter:
status: Triaged → Invalid
Marc Deslauriers (mdeslaur) wrote :

> One problem was most users never set the picture, and if they do it is frequently with a default avatar.

Please reconsider this. We have specifically added a step in the installation process to have the user set an avatar with his webcam or select one from the list.

@Marc I filed bug 926493 in response to this bug concerning the inconsistency there.

Noted, and thanks, but no we won't restore avatar's to the login screen.

Mark

mlaverdiere (mlaverdiere) wrote :

Changed in ayatana-design:
status: Won't Fix → We-won't-do-it-because-it-confuses-users/others-are-all-doing-it/we-don't-have-anything-better-to-propose-yet-but-it-feels-great-to-be-different-and-to-remove-options-for-users-until-we-find-something-better-...-maybe-someday!

Just a joke, don't panic! ;-)

But cum'on guys, this is the type of non-answer that we always get these days. Even if I'm trying not to act as an old Linux/Ubuntu so-called "power-user" who wants to have a bazillion of "options", I don't see the point here for "newbies" when Windows, Mac, Google, etc. platforms are all "avatar-friendly... Lightdm Ubuntu implementation (unity-greater) is not so bad, but hey, there is nothing too revolutionary here that would justify to let down a newbie (or even an old horse, like me) who just want to have its picture there...

Anyway.... believe me, I really think that this issue is somewhat trivial, and I certainly won't go away just because of this... But this "déjà vue" attitude becomes hard to cope with sometimes....

From an old Ubuntu lover.

Mark Shuttleworth (sabdfl) wrote :

On 10/02/12 00:11, mlaverdiere wrote:
> Anyway.... believe me, I really think that this issue is somewhat
> trivial, and I certainly won't go away just because of this... But this
> "déjà vue" attitude becomes hard to cope with sometimes....

I know it's difficult when change comes unsolicited to the door. We have
a lot of that - figuring out how to deal with changes from, say,
Mozilla. And it's tough. Nevertheless, for the parts we've chosen to
lead, we chose to lead them because we think they are going to change
the MOST in the next few years, as different form factors converge.

We saw that early. We've designed for it, and we'll deliver stuff we
think represents the future, before everyone else, if we can. As to
whether it works, let's do an experiment. Run 12.04 for a while, then
boot 10.04 off a USB stick and see which you prefer. I bet it will be
12.04, on balance.

Mark

I'm adding my 2 cents here. It would be nice to be able to display avatars/pictures in the login screen. For example, my 2 and a half years old daughter has an (openbox) session on my 11.10 laptop. She manages to navigate her session very well once logged, but is not able to login by herself since she obviously cannot read. Seeing a picture of her or an avatar would definitely help her to choose where to click.

@Antoine-terracol You/she should still be able to set a different wallpaper for her. I think the idea here is that the wallpaper is meant to replace the avatar; in a way, they're kind of redundant, so it would make some sense to only have one of them.

@Christopher. Right, but that means she would have to click on several user names before finding her account.
To come back to John Lea's rationale, users might all use the default wallpaper.

User`s pictures are nice. So it seems we must use the other approach, always at hand: change the login software.

Robert Ancell (robert-ancell) wrote :

@Marian - that is the appropriate action. We've taken a specific design decision for Ubuntu to not use user pictures however our display manager (LightDM) is designed to support different greeter software (the user interface). So if the user picture is important in your case you can use another greeter or branch and modify unity-greeter (or use an alternative display manager like GDM/KDM).

linuxcub (smusnmr) wrote :

@Robert Ancell, @Mark Shuttleworth:

you wrote "...you can use another greeter..."

Where do I find a save one?

In Ubuntu 12.04.1 LTS i386 gnome classic (no effects), I changed '/etc/lightdm/lightdm.conf' from
'greeter-session=unity-greeter' to
'greeter-session=lightdm-gtk-greeter', and wow, after reboot my system crushed, "only low resolution" and no way to fix anything, because my mouse was gone!

I had to chroot from a Live CD into my system and restore the previous lightdm.conf.

So, please, where do I find a list of greeters, and how do I install them in a save way?

Thanks,

linuxcub

linuxcub (smusnmr) wrote :

Found lightdm-gtk-greeter, installed it, changed lightdm.conf, and it worked. However, user iimages are still not displayed!

Which greeter would enable that?

@linuxcub Perhaps GDM? At any rate, if you need to find a greeter which can display user pictures and get instructions on how to install it, perhaps you should instead ask a question at Ask Ubuntu ( www.askubuntu.com ), if it hasn't been asked already. I think you'll find better support there than continuing to comment on an Invalid/Won't Fix bug.

linuxcub (smusnmr) wrote :

@Christopher Kyle Horton: Ok, understood. This is my last post, and for me it is now bug fixed: lightdm-webkit-greeter does it :-)

gidantribal (aedo999) wrote :

yeah, lightDM must be innovative. Avatar is too mainstream, let's put an anonymous silhouette instead. Ah yes, now I feel the innovation, it's like fresh air. CMONNNN, this is ridiculous, so ridiculous...

anyway, for "vintage" people, you can still feed the default login screen with your avatar (AAAWW, that is H O R R I F I C!! Shame on you!!!):
https://bugs.kde.org/show_bug.cgi?id=296303

Sorry for the tone of this comment but I can't retain my sarcasm, too much is too much.

@gidantribal The default Ubuntu login screen shows the user's wallpaper, not an anonymous silhouette (unless, of course, that is what you set your wallpaper to). It seems you are describing a problem with a different greeter; consider opening a new bug for the correct package if it's still a problem you're experiencing. Commenting on this bug only results in noise for the rest of us. Thanks!

Ivanka Majic (ivanka) on 2013-04-02
Changed in unity-greeter (Ubuntu):
assignee: nobody → Katie Taylor (katie-t)
assignee: Katie Taylor (katie-t) → nobody
Changed in ubuntu-ux:
assignee: nobody → Katie Taylor (katie-t)
John Lea (johnlea) on 2013-04-04
Changed in ubuntu-ux:
status: New → Triaged
no longer affects: ayatana-design
Changed in ubuntu-ux:
status: Triaged → Confirmed
Katie Taylor (katie-t) on 2013-04-10
Changed in ubuntu-ux:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.