[window management] unity8 and 3 finger window drag

Bug #1489020 reported by kevin gunn on 2015-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Vesa Rautiainen
unity8 (Ubuntu)
Undecided
Lukáš Tinkl

Bug Description

it's been pointed out with the recent bug 1438465 on windowed mode unity8, that could be solved or addressed by the feature that exists in unity7 which is using a 3 finger touch to target and drag around windows (w.o touching the title bar)
side note: we may do something shorter term about bug 1438465

just want some confirmation, will we still want this 3 finger touch in unity8 ?

----------Desired design-------------
Unity8 should have 3 finger touch gestures enabled.

3 finger tap on application window should show touch size targets for moving, resizing, closing, maximising/restoring and minimising.

Window can also be moved around with 3 finger drag.

Related branches

@mpt please confirm design recommendation with Ben and John, thanks

Changed in ubuntu-ux:
status: New → Triaged
summary: - unity8 and 3 finger window drag
+ [window management] unity8 and 3 finger window drag
Changed in ubuntu-ux:
importance: Undecided → High
assignee: nobody → Matthew Paul Thomas (mpt)
Matthew Paul Thomas (mpt) wrote :

In the draft Mir spec I did specify some shell-independent protection against bug 1438465. <https://goo.gl/9zrWsY> (Canonical-only link, sorry)

That does not mean, though, that I'm involved in the design of Unity 8 at all. So I think this is assigned to the wrong person.

Changed in ubuntu-ux:
assignee: Matthew Paul Thomas (mpt) → nobody
Vesa Rautiainen (vesar) on 2016-02-01
Changed in ubuntu-ux:
status: Triaged → In Progress
assignee: nobody → Vesa Rautiainen (vesar)
Vesa Rautiainen (vesar) wrote :

3-finger gestures should be enabled in Unity8. Design is in progress at the moment but my feeling is that 3-finger drag in windowed mode would be used for moving windows around. And in staged mode 3-finger drag could be used for moving apps between stages (main stage and side stage). This functionality will be confirmed once the spec is ready and approved.

Vesa Rautiainen (vesar) on 2016-02-02
Changed in ubuntu-ux:
status: In Progress → Fix Committed
description: updated
Changed in unity8 (Ubuntu):
assignee: nobody → Lukáš Tinkl (lukas-kde)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.12+16.10.20160617-0ubuntu1

---------------
unity8 (8.12+16.10.20160617-0ubuntu1) yakkety; urgency=medium

  [ Michael Terry ]
  * Do not create Label/Icon if we don't need it
  * Fix Z-ordering of prompt surfaces (LP: #1586219)
  * Drop bottom edge tutorials completely and small fixes for other
    edges. (LP: #1565103)
  * Redo visuals for greeter prompt box. (LP: #1435923)
  * Make tutorial qmltests more robust. (LP: #1590810)
  * Stop showing an extra lockscreen in desktop unity8 sessions. (LP:
    #1582987)

  [ Albert Astals Cid ]
  * Improve dash plugin mock
  * Stabilize PreviewExpandableTest::test_all_widgets_height
  * Workaround QTBUG-53460
  * Split artShape code for cardTool card and regular card
  * Simplify the code since fixedArtSize code is mandatory for regular
    cards
  * Desktop stage: Support rotatesWindowContents (LP: #1547481)
  * Turn if if else into if elseif else
  * Fix leaks in QInputDeviceManagerPrivate::addDevice
  * Do not call |= on uninitialized sigterm.sa_flags
  * initialize udevMonitor
  * Make notifier and notifierFd function local variables
  * Fix crash if a component that is not an Item is given to
    sectionDelegate
  * Tests: Do not use dynamic_cast if we're not going to test it anyway
  * Minor coverity fixes
  * Fix warning about anchors.fill in ProportionalShape (LP: #1590963)
  * Make wait in cleanup() wait for snapTo animation to have finished

  [ Alexandros Frantzis ]
  * Improve the way notifications interact with power management (LP:
    #1570922)

  [ Andrea Cimitan ]
  * Correctly refresh cardcreator cache on artshapestyle changes (LP:
    #1588335)
  * Same tweaks we have for click scope now for libertine
  * add a timer to pull to refresh to work on small windows (LP:
    #1589060)

  [ Daniel d'Andrada ]
  * Clean up debug leftovers
  * Ensure mouse and window movement are pixel-aligned (LP: #1510382)
  * Fix SpreadDelegate rotation animations
  * No point in version-controlling files that are automatically
    generated
  * Center cursor on screen when it's first shown
  * Custom cursor name just have to start with "custom"
  * Work around AnimatedSprite infinite loop bug (LP: #1588929)

  [ Josh Arenson ]
  * Disable showDash when it is already shown. (LP: #1506708)
  * Add a timestamp to the dash log (LP: #1580074)
  * Add timestamp to unity8 log (LP: #1498169)

  [ Lukáš Tinkl ]
  * Implement keyboard shortcuts info panel
  * Implement window controls overlay activatable with 3 fingers tap
    (LP: #1489020)
  * Select correct Chinese input method for OSK in the wizard (LP:
    #1588633)

  [ Michael Zanetti ]
  * Add support for the launcher surface pips displaying the correct
    number of surfaces
  * Add support for the persistent alert state. (LP: #1575147, #1584348,
    #1586621)
  * send a Alt-release event on alt+tab instead of delaying it
    completely and invoking it later (LP: #1565236)

  [ Stephen M. Webb ]
  * added a new upstart $SESSION for unity8-desktop-session (LP:
    #1376715)

 -- Michael Terry <email address hidden> Fri, 17 Jun 2016 01:22:57 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Vesa Rautiainen (vesar) on 2016-09-02
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers