[dialer-app] + [messaging-app] remove pop up asking to select a SIM

Bug #1449778 reported by Olga Kemmet on 2015-04-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu UX
High
Olga Kemmet
dialer-app (Ubuntu)
High
Gustavo Pichorim Boiko
messaging-app (Ubuntu)
High
Tiago Salem Herrmann

Bug Description

krillin vivid and RTM

Current behaviour: If the device has both SIM slots occupied, users are asked on action to select a SIM card for either placing a phone call or sending a text message. This can be very annoying for users because on first time launch there is a different pop up asking a similar question and explaining to users where to amend their default SIM for outgoing communication.

------UX comment------

The desired solution is to change the text of the popup on first time launch and remove the popup on action.
A 3rd popup appears on the dialer app after user made a phone call and didn't select a default SIM. This should be removed as well.
The SIM card in the first SIM slot should be selected by default and the first popup will inform users where to alter the selection and change the default SIM for outgoing communication.

Please follow guidance in this spec:
https://docs.google.com/document/d/1BRy9-DEXr3A1D7PHkJaXmjbe7xbRmxKkzANXuu-F6lc/edit

Related branches

Changed in ubuntu-ux:
importance: Undecided → High
Bill Filler (bfiller) on 2015-04-29
Changed in dialer-app:
importance: Undecided → High
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Changed in messaging-app:
importance: Undecided → High
assignee: nobody → Tiago Salem Herrmann (tiagosh)
affects: dialer-app → dialer-app (Ubuntu)
affects: messaging-app → messaging-app (Ubuntu)
description: updated
L D (leoubuntuone) wrote :

I don't think any SIM should be selected by default unless the user has set it to be the default.

One improvement would be rather than a "No SIM card selected" popup, it should offer you the choice, eg: a popup with two buttons, one to use SIM 1 and another to use SIM 2.

Olga Kemmet (olga-kemmet) wrote :

The user will be informed on how to switch the default SIM if desired. We had the popup with two buttons previously and it didn't test well with users, hence the decision to make a SIM automatically default. Added spec link to bug description and marking as fix committed.

description: updated
Changed in ubuntu-ux:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dialer-app (Ubuntu):
status: New → Confirmed
Changed in messaging-app (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package messaging-app - 0.1+16.04.20151120-0ubuntu1

---------------
messaging-app (0.1+16.04.20151120-0ubuntu1) xenial; urgency=medium

  [ Tiago Salem Herrmann ]
  * Add online and typing status to the conversation view.
  * Update SIM dialogs according to design spec. (LP: #1449778)

 -- Gustavo Pichorim Boiko <email address hidden> Fri, 20 Nov 2015 11:32:35 +0000

Changed in messaging-app (Ubuntu):
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
importance: Undecided → High
status: New → Fix Committed
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww02-2016
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers