[Ubuntu Phone] The first characters are always in uppercase in webapps

Bug #1448145 reported by costales
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
Oxide
High
Santosh
Ubuntu UX
Undecided
Unassigned
ubuntu-keyboard
Confirmed
High
Michael Sheldon
webapps-sprint
High
Santosh
ubuntu-keyboard (Ubuntu)
Undecided
Unassigned

Bug Description

Hi!
In the BQ Ubuntu Edition, when I write anything in any webapp (it works fine in native apps), the first 2 letters are auto uppercase. It should be uppercase just the first letter.

Steps: 1. Open Twitter webapp
2. Write a tweet
3. Press "hello" > BUG: You'll see HEllo. It should be Hello.

Thanks in advance!

Related branches

Revision history for this message
Alexandre Abreu (abreu-alexandre) wrote :

I couldn't reproduce it. Which build version are you running?

tags: added: webapps
Changed in ubuntu-ux:
status: New → Invalid
Changed in webbrowser-app:
status: New → Incomplete
Revision history for this message
Olivier Tilloy (osomon) wrote :

I’m not seeing that either. Marcos, what are your keyboard settings?

Revision history for this message
costales (costales) wrote :

@Alexandre, @Oliver: In settings:
Display language = English (United States).
Keyboard layouts = Spanish & English. Choosed Spanish as default.

This is happen from 1/2 months ago with an update.
Best regards!

description: updated
Revision history for this message
costales (costales) wrote :

FYI: The keyboard has an small & fast flip. Then I'm thinking that the keyboard is working like this:
1. Press h: Show H and change to lowercase and to uppercase again (bug).
2. Press e: Show E and change to lowercase
3. Press l: Show l and persist the lowercase
etc.

Revision history for this message
Olivier Tilloy (osomon) wrote :

OK, I can reproduce if I disable spellchecking, automatic word correction and word suggestions. I would venture this is a bug in the keyboard itself.

Changed in webbrowser-app:
status: Incomplete → Invalid
affects: webbrowser-app → ubuntu-keyboard
Changed in ubuntu-keyboard:
status: Invalid → New
Revision history for this message
Alexandre Abreu (abreu-alexandre) wrote :

OK managed to get it w/ "Auto capitalization" enabled only ... all the rest of the "Language & Text" settings being turned off

Changed in ubuntu-keyboard:
status: New → Confirmed
assignee: nobody → Michael Sheldon (michael-sheldon)
importance: Undecided → High
Revision history for this message
SB (emehntehtt) wrote :

I can confirm this bug on my BQ, UK English and Croatian keyboard, updated to r21.

Revision history for this message
John Doe (shadowofdoe) wrote :

I have this problem too, so i reported bug here https://bugs.launchpad.net/ubuntu/+source/ubuntu-keyboard/+bug/1440539 because i didn't saw this one.. So +1 to confirm bug!

Changed in oxide:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Michael Sheldon (michael-sheldon)
Revision history for this message
Michael Sheldon (michael-sheldon) wrote :

This appears to be an issue with Oxide reporting the wrong surrounding text offset; it's always out by one when entering new text, so as far as the keyboard's concerned it's still at the beginning of the text field after the first character has been typed. This seems to be due to a synchronisation issue between when Oxide updates the surrounding text data internally and when it reports it to the keyboard.

 The reason this doesn't happen with spell check/prediction enabled is that the text is then still in pre-edit and so dealt with internally by the keyboard instead of relying on Oxide's reporting of the surrounding text.

tags: added: osk
tags: removed: osk
tags: added: osk
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

What is the status of this bug?

Revision history for this message
costales (costales) wrote : [Bug 1448145] Re: [Ubuntu Phone] The first characters are always in uppercase in webapps

Hi Alexandre,
The bug persist after OTA6.
A hug.

On Thu, Sep 3, 2015 at 5:20 PM, Jamie Strandboge <email address hidden> wrote:
>
> What is the status of this bug?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1448145
>
> Title:
> [Ubuntu Phone] The first characters are always in uppercase in webapps
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/oxide/+bug/1448145/+subscriptions

Revision history for this message
Jason Robinson (jaywink) wrote :

This bug went away for me for a while, maybe after OTA-8. However, it has now come back, I think after the updates on Friday 4th December, on the rc-proposed channel.

BQ Aquaris E4.5 rc-proposed device. English and Finnish keyboard layouts, Finnish used. Auto-capitalization is on and auto-punctuation - other "helpers" off.

Heh, tried "ubuntu-bug ubuntu-keyboard" and:

> The problem cannot be reported:
> This is not an official Ubuntu package. Please remove any third party package and try again.

;)

Revision history for this message
Michael Zanetti (mzanetti) wrote :

THis is still the case with current rc-proposed. QUite an embarrasing issue IMO. IS there really no way to fix this? Can we raise priority on this?

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → 11
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Bill Filler (bfiller)
tags: added: system-apps-11
Revision history for this message
Michael Sheldon (michael-sheldon) wrote :

To test on a desktop system you can install the ubuntu keyboard by running

sudo apt-get install ubuntu-keyboard ubuntu-keyboard-english

Then to run with extra debugging info from the keyboard run:

MALIIT_DEBUG=true maliit-server

And start the webbrowser via the command:

QT_IM_MODULE=maliitphablet webbrowser-app

Revision history for this message
Michael Sheldon (michael-sheldon) wrote :

core/browser/input/oxide_qt_input_method_context.cc is probably a good place to start, especially anything relating to ImSurroundingText and possibly the oxide ImeBridge

Revision history for this message
David Barth (dbarth) wrote :

Note: you need to have all input helpers off, ie spell checker OFF, auto-correct OFF, etc.

Revision history for this message
Olivier Tilloy (osomon) wrote :

"Auto capitalization" needs to be enabled.

Bill Filler (bfiller)
Changed in canonical-devices-system-image:
milestone: 11 → 12
assignee: Bill Filler (bfiller) → David Barth (dbarth)
David Barth (dbarth)
Changed in oxide:
assignee: Michael Sheldon (michael-sheldon) → Santosh (santoshbit2007)
David Barth (dbarth)
Changed in webapps-sprint:
milestone: none → sprint-22
assignee: nobody → Santosh (santoshbit2007)
Revision history for this message
Santosh (santoshbit2007) wrote :

Cause of bug : The issue happens when preedit_string == commit_string, In this case, on commit string we dont't receive updateSelectionBounds from blink(since bounds is not changed and same as in preedit mode). Calculation of cursor position happens on updateSelectionBounds, So In this case after commit it doesn't happen and the current cursor position is left as last calculated cursor position. this bug can happpen even when word suggestion is enabled and preedit == commit string.

I couldn't find direct elegant solution of this so trying to tweak some cases and check for side effect.May be forcing updateSelectionBounds after commit will work

David Barth (dbarth)
Changed in webapps-sprint:
status: New → In Progress
importance: Undecided → High
David Barth (dbarth)
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in oxide:
status: Confirmed → In Progress
David Barth (dbarth)
Changed in webapps-sprint:
milestone: sprint-22 → sprint-23
Revision history for this message
Santosh (santoshbit2007) wrote :

It is possible to fix this if :
 -- when word suggestion is disabled keyboard should send only single event with commit_string to be committed. this means preedit is diabled and we are inserting char directly. As of now current behaviour is it sends two event for every character pressed, once containing preedit_char and another containing commit_char. having same value. There is not point in these two event.

--- somehow oxide has knowledge of keyboard setting, like if word suggestion is disabled, In this case oxide can stop composing preedittext and directly commit the string.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+16.10.20160615.1-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+16.10.20160615.1-0ubuntu1) yakkety; urgency=medium

  [ Michael Sheldon ]
  * Add support for Latvian keyboard layout (LP: #1539121)
  * Don't send preedit events when preedit is disabled (LP: #1448145)
  * Support all types of space character when checking for autocaps and
    double space full-stop insertion
  * Add icon to keyboard autopilot test application to avoid bug
    #1591192
  * Ensure wide characters (e.g. Chinese) fit on 'Next' key (LP:
    #1588635)
  * Fix emoji autopilot tests

  [ Timo Jyrinki ]
  * Stop depending on transitional packages. (LP: #1583079)

 -- Michael Sheldon <email address hidden> Wed, 15 Jun 2016 12:45:56 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
David Barth (dbarth)
Changed in oxide:
status: In Progress → Fix Committed
Changed in webapps-sprint:
status: In Progress → Fix Released
Olivier Tilloy (osomon)
Changed in oxide:
status: Fix Committed → In Progress
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers