[indicators]/OSD provide no visual clue that they modify bluetooth device volumes

Bug #1415480 reported by John McAleely on 2015-01-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
Ubuntu UX
High
Benjamin Keyser
indicator-sound (Ubuntu)
High
Xavi Garcia
indicator-sound (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Connect a bluetooth audio device (headset, speakers) to the ubuntu phone.

Play music/enter into a call, so that you have active audio to the device.

Adjust the volume, using the UI or keys on the ubuntu phone.

The volume of the bluetooth headset changes (good) but the ui contains no clue that this is what the phone is doing (less good). The standard volume indicator is shown. This can lead to user confusion if they are not currently using the paired bluetooth accessory, and have forgotten it is paired. On other devices the volume indicator changes to provide visual feedback that the bluetooth device volume is being set.

------------------------------

Desired resolution:

Please use this icon to replace the volume icon. The icon is bluetooth volume which we had design already.

https://www.dropbox.com/s/a5r3ro1h0917p0a/audio-speakers-bluetooth-symbolic.svg?dl=0

Related branches

Noemí (noemi-gallego) wrote :

Are there any update on this bug?

John Lea (johnlea) on 2015-02-24
description: updated
Changed in ubuntu-ux:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → John Lea (johnlea)
John McAleely (john.mcaleely) wrote :

@johnlea - it seems you are not addressing the issue, perhaps because I was unclear. The problem is not that phones don't indicate a change of volume, but rather that they don't indicate they are changing the volume of a paired bluetooth device.

So this bug is a request for a visual differentiation between the UI shown for on-device volume, and off-device-bluetooth volume.

Changed in ubuntu-ux:
status: Fix Committed → New
description: updated
John McAleely (john.mcaleely) wrote :

I have edited the description of the bug

Changed in ubuntu-ux:
assignee: John Lea (johnlea) → nobody
assignee: nobody → Paty Davila (dizzypaty)
Changed in ubuntu-ux:
status: New → Triaged
John McAleely (john.mcaleely) wrote :

When will this bug be worked on? It has been raised by our OEM partners as a priority. I have removed the 'desired resolution' text placed by johnlea, as it was clearly not correct.

description: updated
Noemí (noemi-gallego) wrote :

Any updates on this bug?

John Lea (johnlea) on 2015-04-08
summary: - indicators/OSD provide no visual clue that they modify bluetooth device
- volumes
+ [indicators]/OSD provide no visual clue that they modify bluetooth
+ device volumes
Noemí (noemi-gallego) wrote :

Any updates on this bug?

John Lea (johnlea) on 2015-07-30
Changed in ubuntu-ux:
assignee: Paty Davila (dizzypaty) → Alex Milazzo (digitalalex)
description: updated
Changed in ubuntu-ux:
status: Triaged → Fix Committed
description: updated
John McAleely (john.mcaleely) wrote :

I can find no mention of volume notifications changing according to the paired accessories. Where is that?

Changed in ubuntu-ux:
status: Fix Committed → Confirmed
Changed in ubuntu-ux:
status: Confirmed → Triaged
Alex Milazzo (digitalalex) wrote :

Please use this icon to replace the volume icon. The icon is bluetooth volume which we had design already.

https://www.dropbox.com/s/a5r3ro1h0917p0a/audio-speakers-bluetooth-symbolic.svg?dl=0

Changed in ubuntu-ux:
status: Triaged → Fix Committed
description: updated
Changed in canonical-devices-system-image:
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
milestone: none → ww40-2015
status: New → Confirmed
Changed in indicator-bluetooth (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
status: New → Confirmed
Changed in canonical-devices-system-image:
assignee: Charles Kerr (charlesk) → Alejandro J. Cura (alecu)
Changed in indicator-bluetooth (Ubuntu):
assignee: Charles Kerr (charlesk) → Xavi Garcia (xavi-garcia-mena)
Xavi Garcia (xavi-garcia-mena) wrote :

I'm looking at this bug and I have some questions:

I understand that the icon we need to change is the right icon on the volume slider, isn't it?

Changed in ubuntu-ux:
assignee: Alex Milazzo (digitalalex) → Matthew Paul Thomas (mpt)
status: Fix Committed → Confirmed
no longer affects: indicator-messages (Ubuntu)
Changed in indicator-bluetooth (Ubuntu):
assignee: Xavi Garcia (xavi-garcia-mena) → nobody
Changed in indicator-sound (Ubuntu):
status: New → Fix Committed
assignee: nobody → Xavi Garcia (xavi-garcia-mena)
Benjamin Keyser (bjkeyser) wrote :

Let's just put a label (rather than an icon for each) up on screen within the overlay to indicate what the user is affecting.

ie:
* ringer
* alarm volume
* bluetooth
* headphone jack
* HDMI Audio
* USB Audio

Alejandro J. Cura (alecu) wrote :

Yes, just a label sounds better than having custom icons for each output type.

Changed in ubuntu-ux:
assignee: Matthew Paul Thomas (mpt) → nobody
assignee: nobody → Benjamin Keyser (bjkeyser)
Pat McGowan (pat-mcgowan) wrote :

That will need translations so moving to next ilestone

Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Changed in ubuntu-ux:
assignee: Benjamin Keyser (bjkeyser) → Paty Davila (dizzypaty)
status: Confirmed → Triaged
assignee: Paty Davila (dizzypaty) → Benjamin Keyser (bjkeyser)
Changed in indicator-sound (Ubuntu):
importance: Undecided → High
Changed in indicator-bluetooth (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Alejandro J. Cura (alecu) wrote :

Due to packaging and dependency issues this feature has missed OTA-8.
We'll land it early in the OTA-9 cycle.

Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Changed in indicator-sound (Ubuntu):
status: Fix Committed → In Progress
Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+16.04.20151103.2-0ubuntu1

---------------
indicator-sound (12.10.2+16.04.20151103.2-0ubuntu1) xenial; urgency=medium

  [ Xavi Garcia ]
  * Added OSD notifications to show output source when the volume or
    source change (LP: #1382548, LP: #1415480, LP: #1484589)

  [ CI Train Bot ]
  * New rebuild forced.

 -- Xavi Garcia <email address hidden> Tue, 03 Nov 2015 17:47:10 +0000

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Adolfo Jayme (fitojb) on 2015-11-11
no longer affects: indicator-bluetooth (Ubuntu)
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Changed in indicator-sound (Ubuntu):
status: Fix Released → In Progress
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package indicator-sound 12.10.2+15.04.20151223-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

indicator-sound (12.10.2+15.04.20151223-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * No-change rebuild.

indicator-sound (12.10.2+16.04.20151222-0ubuntu1) xenial; urgency=medium

  [ Xavi Garcia Mena ]
  * Very simple change to make upstart try to respawn the process 30
    times (instead of 2). This is a workaround for the case when dbus
    session is not ready yet at startup.

  [ Timo Jyrinki ]
  * Note: this release was reverted on 20151223, ignore this changelog entry.

indicator-sound (12.10.2+16.04.20151103.2-0ubuntu1) xenial; urgency=medium

  [ Xavi Garcia ]
  * Added OSD notifications to show output source when the volume or
    source change (LP: #1382548, LP: #1415480, LP: #1484589)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Timo Jyrinki ]
  * Note: this release was reverted on 20151223, ignore this changelog entry.

indicator-sound (12.10.2+15.10.20151019-0ubuntu1) wily; urgency=medium

  [ Xavi Garcia Mena ]
  * Wily branch for MPRIS controls (LP: #1373313)

indicator-sound (12.10.2+15.10.20150915-0ubuntu1) wily; urgency=medium

  [ Sebastien Bacher ]
  * under unity8 start system-settings instead unity-control-center (LP:
    #1489427)

  [ Xavi Garcia Mena ]
  * Merged lp:~xavi-garcia-mena/indicator-sound/icon-volume-zero

indicator-sound (12.10.2+15.10.20150812.3-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Charles Kerr ]
  * When showing a "Loud volumes can damage your hearing" confirmation
    warning, clamp the volume until the user hits "OK". (LP: #1481913)

indicator-sound (12.10.2+15.10.20150807.6-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Charles Kerr ]
  * Revised UI volume warnings to comply with EU requirements. (LP:
    #1481913)

indicator-sound (12.10.2+15.10.20150605-0ubuntu1) wily; urgency=medium

  *

indicator-sound (12.10.2+15.10.20150507+eventually4-0ubuntu1) wily; urgency=medium

  * Using eventually to avoid arbitrary timeouts in tests

indicator-sound (12.10.2+15.10.20150507-0ubuntu1) wily; urgency=medium

  [ Charles Kerr ]
  * Use the BusWatcher to look for org.freedesktop.Notifications
    ownership changes on the bus. (LP: #1432446)

 -- Xavi Garcia <email address hidden> Wed, 23 Dec 2015 12:54:33 +0000

Changed in indicator-sound (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Alejandro J. Cura (alecu) wrote :

This also landed by mistake, and had to be reverted.
The feature is still being tested in silo 51.

Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package indicator-sound - 12.10.2+16.04.20160105.2-0ubuntu1

---------------
indicator-sound (12.10.2+16.04.20160105.2-0ubuntu1) xenial; urgency=medium

  [ Xavi Garcia Mena ]
  * Adds an action to signal the UI to sync the current volume when we
    are waiting for the user to confirm or reject the high volume
    notification. (LP: #1520548, #1512798)
  * This branch just readds the OSD notifications code, that was
    reverted in trunk as the corresponding silo was also rolled back
    after landing.
  * This branch re-adds the integration tests using gmenuharness. Added
    OSD notifications to show output source when the volume or source
    change (LP: #1382548, LP: #1415480, LP: #1484589) debian/control:
    Added the following build dependencies: cmake-extras (>= 0.4),
    google-mock (>= 1.6.0+svn437), libqtdbusmock1-dev (>= 0.3),
    libqtdbustest1-dev, libunity-api-dev, pulseaudio, qt5-default,
    qtbase5-dev, qtbase5-dev-tools, qtdeclarative5-dev, qtdeclarative5-
    dev-tools Added gmenuharness library for integration tests support.
    New Files: src/gmenuharness/CMakeLists.txt
    src/gmenuharness/MatchResult.cpp src/gmenuharness/MatchUtils.cpp
    src/gmenuharness/MenuItemMatcher.cpp
    src/gmenuharness/MenuMatcher.cpp
    include/unity/gmenuharness/MatchResult.h
    include/unity/gmenuharness/MatchUtils.h
    include/unity/gmenuharness/MenuItemMatcher.h
    include/unity/gmenuharness/MenuMatcher.h Added integration tests
    using gmenuharness New Files: tests/dbus-types/CMakeLists.txt
    tests/dbus-types/com.ubuntu.AccountsService.Sound.xml tests/dbus-
    types/dbus-types.h tests/dbus-
    types/org.PulseAudio.Ext.StreamRestore1.xml tests/dbus-
    types/org.freedesktop.Accounts.xml tests/dbus-
    types/org.freedesktop.DBus.Properties.xml tests/dbus-
    types/org.freedesktop.Notifications.xml tests/dbus-
    types/org.gtk.Actions.xml tests/dbus-types/pulseaudio-volume.cpp
    tests/dbus-types/pulseaudio-volume.h
    tests/integration/CMakeLists.txt tests/integration/indicator-sound-
    test-base.cpp tests/integration/indicator-sound-test-base.h
    tests/integration/main.cpp tests/integration/test-indicator.cpp
    tests/integration/touch-stream-restore.table
    tests/integration/utils/dbus-pulse-volume.cpp
    tests/integration/utils/dbus-pulse-volume.h
    tests/integration/utils/get-volume.cpp tests/integration/utils/set-
    volume.cpp tests/service-mocks/CMakeLists.txt tests/service-
    mocks/DBusPropertiesNotifier.cpp tests/service-
    mocks/DBusPropertiesNotifier.h tests/service-mocks/accounts-
    mock/AccountsDefs.h tests/service-mocks/accounts-
    mock/AccountsMock.cpp tests/service-mocks/accounts-
    mock/AccountsMock.h tests/service-mocks/accounts-
    mock/AccountsServiceSoundMock.cpp tests/service-mocks/accounts-
    mock/AccountsServiceSoundMock.h tests/service-mocks/accounts-
    mock/CMakeLists.txt tests/service-mocks/accounts-
    mock/com.ubuntu.AccountsService.Sound.Mock.xml tests/service-
    mocks/accounts-mock/main.cpp tests/service-mocks/accounts-
    mock/org.freedesktop.Accounts.Mock.xml tests/service-mocks/media-
    player-mpris-mock/CMakeLists.txt tests/ser...

Read more...

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers