[Scopes] Calendar reminder notifications became queued, non-interactive and easy to miss

Bug #1401802 reported by Michał Sawicz on 2014-12-12
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu UX
Medium
Paty Davila
indicator-datetime (Ubuntu)
High
Renato Araujo Oliveira Filho

Bug Description

With the recent indicator-datetime update the reminder notifications time out and are not interactive any more, meaning that:
- can't dismiss (have to wait for the sound/notification to time out)
- can't snooze (I know the feature didn't work, but that was a missing feature, not a thing we didn't want?)
- if you missed the notification, you missed the reminder

Not sure if the reason is the same, but they started queueing, too, i.e. if there's two reminders for the same time, sound will play for both (bug #1340248), but the two notifications will be shown one after another.

This is a UX regression in my opinion, even if it fixes bug #1320880.

There is actually no clear design for this, I'm afraid,
https://sites.google.com/a/canonical.com/apps-and-platform-team/3-platform/2-notifications

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: indicator-datetime 13.10.0+15.04.20141208-0ubuntu1
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.14.7-0ubuntu10
Architecture: armhf
Date: Fri Dec 12 08:59:10 2014
InstallationDate: Installed on 2014-12-12 (0 days ago)
InstallationMedia: Ubuntu Vivid Vervet (development branch) - armhf (20141212-020204)
SourcePackage: indicator-datetime
UpgradeStatus: No upgrade log present (probably fresh install)

------ UX Comment ------

We've added the desired behaviour in the latest specification for notifications bubbles:

Pages: 10-22 Notification bubble in normal use
https://docs.google.com/document/d/1xDSZ_dnAMAlhgFnnyjJEibaITXjVLp1_pnj_tATNm9I/edit#heading=h.6g43lpfdbptu

Specific to remiders notifications: Notifications from missed calls, calendar events and reminders, are exceptions and won't ever be presented in a summary layout because of their different nature. They are time-sensitive (especially if these events involve other people actively waiting on a response) and may change the user's behaviour in the real world.

Related branches

Michał Sawicz (saviq) wrote :
Thomas Strehl (strehl-t) on 2014-12-12
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Charles Kerr (charlesk) wrote :

So I talked to Design about this, and the main answer that I got is that all of this is up in the air pending the new notifications Design that's coming in January.

In revision 391 of the proposed branch, I've changed calendar event handling s.t. they once again require a snap decision, but do not have haptic feedback and only play the sound once rather than looping.

This is an attempt to find a good middle ground between bug #1401802's complaint "calendar event notifications are too intrusive" and this bug which says the revised ones are too easy to miss :-)

Saviq, also if snooze isn't working for you please file a separate bug report and I'll take a look.

Changed in indicator-datetime (Ubuntu):
status: New → Fix Committed
Charles Kerr (charlesk) on 2014-12-12
Changed in indicator-datetime (Ubuntu):
status: Fix Committed → In Progress
Changed in indicator-datetime (Ubuntu):
importance: Undecided → High
Changed in ubuntu-ux:
assignee: nobody → Giorgio Venturi (giorgio-venturi)
assignee: Giorgio Venturi (giorgio-venturi) → nobody
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Paty Davila (dizzypaty)
Charles Kerr (charlesk) on 2015-04-23
Changed in indicator-datetime (Ubuntu):
status: In Progress → Triaged
Davide Alberelli (dadexix86) wrote :

Hi, we are in July, r24 is out, and still the same problems are here.

Any news on this?
Especially on the third point. It is really annoying missing calendar events because one does not have the phone always in front of the eyes :(

John Lea (johnlea) on 2015-07-30
summary: - Calendar reminder notifications became queued, non-interactive and easy
- to miss
+ [Scopes] Calendar reminder notifications became queued, non-interactive
+ and easy to miss
Paty Davila (dizzypaty) on 2015-08-05
description: updated
Changed in ubuntu-ux:
status: Triaged → Fix Committed

Missing events will be posted on messaging menu.

Changed in indicator-datetime (Ubuntu):
assignee: Charles Kerr (charlesk) → Renato Araujo Oliveira Filho (renatofilho)
status: Triaged → In Progress

Btw in the current version of the indicator you can dismiss the calendar notification by swiping it away.

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
milestone: none → 11
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers