[Dash] Categorydropbox touch state

Bug #1383213 reported by Estibaliz Landa Torres on 2014-10-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
Alex Milazzo
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

A touch state is needed. Light grey colour, same as on the rest of the UI.

Related branches

Attached a touch estate example (selection)

This needs adding the highlight colour

tags: added: rtmvisualbugs
Changed in ubuntu-ux:
importance: Undecided → Medium
assignee: nobody → Estibaliz Landa Torres (estilanda)
Michał Sawicz (saviq) on 2014-10-20
description: updated
summary: - [Dash] Categorydropbox touch estate
+ [Dash] Categorydropbox touch state
affects: unity8 → unity8 (Ubuntu)
John Lea (johnlea) on 2014-12-05
Changed in ubuntu-ux:
status: New → Triaged
Changed in ubuntu-ux:
assignee: Estibaliz Landa Torres (estilanda) → nobody
assignee: nobody → James Mulholland (jamesjosephmulholland)
Changed in ubuntu-ux:
assignee: James Mulholland (jamesjosephmulholland) → Alex Milazzo (digitalalex)
Alex Milazzo (digitalalex) wrote :

It should inherit the standard list item pressed state.

Changed in ubuntu-ux:
status: Triaged → Fix Released
handsome_feng (feng-kylin) wrote :

If we use the Standard list item to replace the AbstractButton in DashNavigationList.qml, it will implement the touch state, but when selected, the region of light grey turns wider than the divider, because the divider has a margin, it feels odd, so any further design?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.10+15.10.20150721-0ubuntu1

---------------
unity8 (8.10+15.10.20150721-0ubuntu1) wily; urgency=medium

  [ Albert Astals Cid ]
  * Add context for "Please re-enter" (LP: #1377195)
  * Fix i18n in scope tool (LP: #1317541)
  * Fix warning when doing make try
  * New phone background provided by design (LP: #1364537)
  * PreviewExpandable should be not expanded on startup
  * Update state of indicators bar only when the user is actively
    dragging himself (LP: #1457044)
  * icon-actions preview widget
  * make testPageHeader more stable

  [ CI Train Bot ]
  * Resync trunk.

  [ Josh Arenson ]
  * Add handling for the location page to the autopilot settings wizard
    test

  [ Michael Zanetti ]
  * allow opening the manage dash area by clicking with a mouse on the
    arrow label

  [ handsome_feng ]
  * Added touch state on navigation. (LP: #1383213)

  [ handsome_feng<email address hidden> ]
  * Added touch state on navigation. (LP: #1383213)

 -- CI Train Bot <email address hidden> Tue, 21 Jul 2015 09:10:05 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers