[messaing-app] shouldn't rotate into landscape mode as causes issues with compose and main view

Bug #1379421 reported by Olga Kemmet on 2014-10-09
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Critical
Olga Kemmet
messaging-app (Ubuntu)
High
Tiago Salem Herrmann

Bug Description

Build r93

The messaging app rotates to make it easier to type and read messaging threads. However, this causes issues in the compose and main views.
If you rotate the app into landscape mode on the landing view, there is no way to carry out a bottom edge swipe to compose a new message.
In the compose view, the landscape mode doesn't show the header. This one is needed, to add ppl to the recipient list.

Recommendation: The ideal case is that we would have a custom header for landscape views because the current one in portrait mode is too large for certain devices. This needs further investigation from design and probably SDK. Plus there is still the issue of the bottom edge swipe in landscape, which needs to be addressed by Unity. Therefor it would be best to remove this feature for the RTM release.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in messaging-app (Ubuntu):
status: New → Confirmed
tags: added: ota-2 rtm14
Changed in messaging-app:
importance: Undecided → High
Changed in messaging-app (Ubuntu):
importance: Undecided → High
Bill Filler (bfiller) wrote :

per design, lets disable rotation support in the messaging-app until all the issues can be address and the shell supports rotation

Changed in messaging-app:
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in messaging-app (Ubuntu):
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in messaging-app:
status: New → Confirmed
Victor Tuson Palau (vtuson) wrote :

as this didnt make it to rtm, I will be -1 to remove rotation and go for the proper fix instead

Pat McGowan (pat-mcgowan) wrote :

Be sure to coordinate with shell rotation fixes, disabling seems a poor solution

no longer affects: messaging-app
Allan LeSage (allanlesage) wrote :

While running OTA8 manual tests, finding that rotation works well but leaves some layout decisions to be made--specifically there's an ugly overlay on krillin, will attach screenie.

I'm hijacking this bug for discussion as I see recent activity here, please feel free to re-open elsewhere (or to re-title this bug as appropriate).

Bartosz Kosiorek (gang65) wrote :

The overlay issue was already fixed in OTA-9.
Also rotation is working well

Changed in messaging-app (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers