Update header divider

Bug #1372590 reported by Tim Peeters on 2014-09-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
Critical
Jouni Helminen
ubuntu-ui-toolkit (Ubuntu)
High
Tim Peeters
Vivid
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Use color: 5% black instead of the current image.

Related branches

Changed in ubuntu-ux:
assignee: nobody → Jouni Helminen (jounihelminen)
status: New → Triaged
tags: added: ota-1
Tim Peeters (tpeeters) on 2014-09-23
Changed in ubuntu-ui-toolkit:
importance: Undecided → Medium
status: New → Confirmed
Tim Peeters (tpeeters) wrote :

Currently we use two images for the divider. From PageHeadStyle.qml:
    separatorSource: "artwork/PageHeaderBaseDividerLight.sci"
    separatorBottomSource: "artwork/PageHeaderBaseDividerBottom.png"

Changed in ubuntu-ui-toolkit:
importance: Medium → Critical
assignee: nobody → Tim Peeters (tpeeters)
Changed in ubuntu-ux:
importance: Undecided → Critical
status: Triaged → Fix Released
tags: added: rtm
removed: ota-1
Tim Peeters (tpeeters) wrote :

11:29:15 < jounih> timp - can you please check how Dash has implemented the suru divider? they just used qml rectangles
11:29:30 < jounih> timp: they also have the right color values. so you could just copy it from there

Jouni Helminen (jounihelminen) wrote :

let's use QML rectangles for the top (inner shadow), middle (large divider) and bottom (highlight). The correct implementation is already in the dash divider - can we just copy the solution from there?

Tim Peeters (tpeeters) wrote :

not a showstopper, reduced priority

tags: removed: rtm
Changed in ubuntu-ui-toolkit:
importance: Critical → High
Tim Peeters (tpeeters) on 2014-10-21
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Tim Peeters (tpeeters) wrote :

dash automatically computes the color of the bottom and top of the divider, but the main divider color is hardcoded as #e0e0e0

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Tim Peeters (tpeeters) wrote :

I set this back to in progress, because:
158 + // FIXME: After After https://code.launchpad.net/~mzanetti/unity8/new-pageheader-api/+merge/239242
159 + // lands, set separatorSource and separatorBottomSource to "" in order to use the new divider.

Changed in ubuntu-ui-toolkit:
status: Fix Committed → In Progress
Zoltan Balogh (bzoltan) on 2014-11-24
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Tim Peeters (tpeeters)
importance: Undecided → High
status: New → In Progress
Zoltan Balogh (bzoltan) on 2014-11-24
no longer affects: ubuntu-ui-toolkit
Tim Peeters (tpeeters) on 2014-12-01
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Tim Peeters (tpeeters) on 2014-12-10
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers