[sdk] Colors should have symbolic names

Bug #1350915 reported by Sebastien Bacher on 2014-07-31
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
Ubuntu UX
Wishlist
Jamie Young
ubuntu-ui-toolkit (Ubuntu)
High
Zsombor Egri

Bug Description

[Updated description]

Reading http://developer.ubuntu.com/api/qml/sdk-14.10/Ubuntu.Components.UbuntuColors/ the documentation suggests to use e.g blue for selection ... shouldn't we rather have named colors, e.g "selectionColor"? This way, if the theme change a day we don't need to patch every single application we are shipping to change the color!

–––

Progress update:

We've updated the colour palette with a more useful naming structure:

https://docs.google.com/document/d/1nFm8xiYhKXXuEO_IvMXoD0lASbYzYXva1BWMVanU3iw/edit#bookmark=id.5zug5fr1w8zi

Related branches

affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit
Michał Sawicz (saviq) on 2014-07-31
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the palette seems to have a restricted set of colors though, e.g no color for buttons

Tim Peeters (tpeeters) wrote :

Yes, I think we need to extend the palette (also with colors for positiveAction, negativeAction), or think of a different way to do it.

summary: - Colors should have symbolic names
+ [sdk] Colors should have symbolic names
Changed in ubuntu-ux:
assignee: nobody → Jouni Helminen (jounihelminen)
Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → Medium
Zoltan Balogh (bzoltan) on 2014-11-24
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Zoltan Balogh (bzoltan) on 2014-11-24
no longer affects: ubuntu-ui-toolkit
Jouni Helminen (jounihelminen) wrote :
Changed in ubuntu-ux:
status: Triaged → Fix Released
Jouni Helminen (jounihelminen) wrote :

ah, misread.

Semantic colour names would work once we have agreed on the semantics. The current palette implementation links too many things together so are working on a better alternative

Changed in ubuntu-ux:
status: Fix Released → In Progress
Changed in ubuntu-ux:
importance: Medium → Wishlist
status: In Progress → Triaged
Changed in ubuntu-ux:
assignee: Jouni Helminen (jounihelminen) → Jamie Young (jamiedawsonyoung)
description: updated
Changed in ubuntu-ux:
status: Triaged → Fix Committed
Jamie Young (jamiedawsonyoung) wrote :

The work on the semantic naming has been done and agreed with the teams. It's in the process of being implemented. Thanks!

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Zsombor Egri (zsombi)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :
Download full text (7.0 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1872+16.04.20160308-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1872+16.04.20160308-0ubuntu1) xenial; urgency=medium

  [ Timo Jyrinki ]
  * Fix gles unit test skipping.
  * Add s390x to the unit test skipping architectures
  * UITK test plan - wily -> xenial. Fixes LP: #1544490

  [ Christian Dywan ]
  * Print errors when QuickUtils fails to create a component.
  * unit tests shouldn't use deprecated Dialog.callera
  * Correctly count only test case results. The result= value is used in suites
    and results.
  * Skip tst_pagehead_visible flakes on non-arm. Fixes LP: #1534651
  * Skip flaky tst_mousefilterTest::doubleClicked. Fixes LP: #1542215
  * Suppress click signal if releasing outside of ListItem. Fixes LP: #1541148.
  * Use gdb in runtest.sh to produce backtraces.
  * Arrow keys change value of a Slider. Fixes LP: #1523824.
  * Only use Maliit when enabled explicitly in the environment

  [ Oliver Tilloy ]
  * Do not try to assign to non-existent property "activeFocusOnPress".
    Fixes LP: #1532953
  * Bubble up ESC key press event if there is no popover to close.
    Fixes LP: #1546627

  [ Loïc Molinari ]
  * Added private items and nodes for the new component styles.
    Fixes LP: #1523836
  * Made use of new private Frame item for the focusing.
  * Fixed performance monitor crash because of a NULL timer pointer dereference.
    Fixes LP: #1546986
  * Fixed performance monitor dangling pointer crash. Fixes LP: #1546984
  * [ProportionalShape] Ensured width/height ratio is correct with default values.
    Fixes LP: #1546546
  * Added a workaround to prevent a crash while changing the QPA scale factor.

  [ Florian Boucault ]
  * Always on performance monitor that logs frames that too long to render.
  * MainView: proceed to selecting the theme automatically at startup too.
    Fixes LP: #1535819
  * MainView: when no gradient color is needed for the background, rely on
    QQuickWindow's GL clear color. Lessens overdraw considerably for most
    apps. Fixes LP: #1439133.
  * Panel: MathUtils used without import prefix was leading to undefined
    reference.
  * Label: use native rendering on low dpi screens (GRID_UNIT_PX <= 10) for
    sharper looking text.
  * Gallery: added palette browser to Colors page.

  [ Tim Peeters ]
  * Support scrolling in ListViews with horizontal orientation to the
    qquicklistview CPO.
  * Add background to AppHeader and remove contents clipping from MainView.
    Fixes LP: #1531016, LP: #1531457.
  * Hide AppHeader when using AdaptivePageLayout. Fixes bug 1531871.
    Fixes LP: #1531871.
  * Implement horizontal flicking in the flickable autopilot CPO.
  * Re-order to list of pages in the gallery to be alphabetical.
  * Fix the autopilot failures introduced with the horizontal scrolling in
    the Flickable CPO.
  * Update documentation for MainView, Page, AdaptivePageLayout to use the new
    PageHeader in all examples. Deprecate old properties. Fixes LP: #1540574
  * Add 'animate' property to new internal AppHeaderBase, and do not show a
    header animation when starting an app without header.
    Fixes LP: #1518002, LP: #1524901.
 ...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww08-2016
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers