[dialer-app] Don't display 'SIM1' if only one SIM is available

Bug #1346804 reported by Jean-Baptiste Lallement on 2014-07-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Olga Kemmet
dialer-app
Undecided
Gustavo Pichorim Boiko
messaging-app
Fix Released
Undecided
Tiago Salem Herrmann
dialer-app (Ubuntu)
Undecided
Unassigned
messaging-app (Ubuntu)
Undecided
Unassigned

Bug Description

The dialer shouldn't display SIM1 (in red) when the phone uses only 1 SIM. (cf screenshot)

Related branches

lp:~tiagosh/messaging-app/hide-accounts-switcher
Merged into lp:messaging-app at revision 153
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-07-18
Ubuntu Phablet Team: Pending requested 2014-07-18
lp:~tiagosh/dialer-app/hide-accounts-switcher
Merged into lp:dialer-app at revision 185
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-07-18
Ubuntu Phablet Team: Pending requested 2014-07-18
lp:~tiagosh/dialer-app/sim-presence
Merged into lp:dialer-app at revision 230
Gustavo Pichorim Boiko: Approve on 2014-08-21
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-08-20
Jean-Baptiste Lallement (jibel) wrote :
Olga Kemmet (olga-kemmet) wrote :

As per design:
On a single SIM phone or if a dual SIM phone uses only one SIM, the SIM indication should be hidden. The is no point to show it to the user.

Changed in ubuntu-ux:
assignee: nobody → Olga Kemmet (olga-kemmet)
status: New → Fix Committed
importance: Undecided → High
Changed in dialer-app:
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Changed in messaging-app:
assignee: nobody → Tiago Salem Herrmann (tiagosh)
summary: - Don't display 'SIM1' if only one SIM is available
+ [dialer] Don't display 'SIM1' if only one SIM is available
Bill Filler (bfiller) on 2014-07-29
Changed in dialer-app:
status: New → Fix Released
Changed in messaging-app:
status: New → Fix Released
Changed in dialer-app (Ubuntu):
status: New → Fix Released
Changed in messaging-app (Ubuntu):
status: New → Fix Released
summary: - [dialer] Don't display 'SIM1' if only one SIM is available
+ [dialer-app] Don't display 'SIM1' if only one SIM is available
Olga Kemmet (olga-kemmet) wrote :

Hey, I don't think this bug was actually fixed.
As mentioned above, the dialer and messaging app should display no SIM slot indications in the case if only one SIM card is inserted into the device.
The current behaviour is that user can see and interact with both SIMs in the UI, which doesn't make much sense because it confuses the user.

This use case will affect SYSTEM SETTINGS as well because the dual SIM management section has to be either disabled or not shown at all.

If user decides to insert a 2nd SIM card, the system has to ask for a device reboot, in order to show the correct UI.

Gustavo Pichorim Boiko (boiko) wrote :

Just to make it clear: the case fixed was the case where the device only had one SIM. The case Olga is describing is a dual SIM phone with only one SIM card inserted.

Changed in dialer-app:
status: Fix Released → Confirmed
Changed in messaging-app:
status: Fix Released → Confirmed
Leo Arias (elopio) on 2014-08-06
tags: added: qa-daily-testing rmt14
tags: added: rtm14
removed: rmt14
Bill Filler (bfiller) on 2014-08-28
Changed in messaging-app:
status: Confirmed → Fix Released
Changed in dialer-app:
status: Confirmed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments