[SystemSettings] When trying to select a ringtone, the page seems to be fully loaded and then swipes by itself

Bug #1342533 reported by Leo Arias on 2014-07-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
Matthew Paul Thomas
ubuntu-system-settings (Ubuntu)
Low
Iain Lane

Bug Description

When I try to change the ringtone, for some moments the page does nothing. Enough time for the user to start an action because it seems that the page it's fully loaded. And then, after one or two seconds, when the user is just about to click an element on the list or swipe it, the list is swiped by itself making the user click the wrong thing, or just left wondering what caused the magic swipe.

To reproduce:
Open system settings.
Go to sound
(Check that the ringtone selected is Ubuntu)
Click Ringtone.
(Here, the top of the list is shown)
Wait one or two seconds
(The list is swiped down to show the selected ringtone)

It seems that the page should be opened showing the selected item immediately.
If that's not possible, at least there should be an indication that some things are still loading, like disabling the list and showing a loading animation.

Related branches

lp:~laney/ubuntu-system-settings/sound-set-on-construction
Merged into lp:ubuntu-system-settings at revision 808
Sebastien Bacher: Approve on 2014-07-17
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-07-17
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

seems like an issue with the toolkit, that small example shows a similar behaviour ... note it doesn't happen if the index is set as "selectedIndex: ..." just when changing it after loading

Sebastien Bacher (seb128) wrote :

the animation is part of the issue, not sure if we can turn it off though, help would be welcome there.

There might also be some loading slowness adding to that

Sebastien Bacher (seb128) wrote :

I've opened bug #1342711 on the toolkit about being able to have the animation disabled

Iain Lane (laney) wrote :

You can avoid the disconcerting scrolling by setting the index on construction. That's the approach we're going to take. Beware that the selected item then won't be scrolled into view - that's bug #1342806.

summary: - When trying to select a ringtone, the page seems to be fully loaded and
- then swipes by itself
+ [SystemSettings] When trying to select a ringtone, the page seems to be
+ fully loaded and then swipes by itself
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+14.10.20140718.1-0ubuntu1

---------------
ubuntu-system-settings (0.3+14.10.20140718.1-0ubuntu1) utopic; urgency=low

  [ Ken VanDine ]
  * [phone] Call waiting implementation

  [ Iain Lane ]
  * [sound] Set the index on construction to avoid a disconcerting
    animation when entering the page. (LP: #1342533)
  * Run pylint and pyflakes on the right directory so they actually work
    and fix the errors.
  * revert lenient AppArmor profile since we won't be limiting access to
    ofono in this manner. Furthermore, due to a naive check in media-
    hub-server for the connecting process' profile name, this allows
    system-settings to playback files via media-hub-server again (LP:
    #1342321) (LP: #1342321)

  [ William Hua ]
  * Sort ignoring case, filter out unnamed locales. (LP: #1342326)
  * Set only left and right anchors in language panel. (LP: #1343513)
 -- Ubuntu daily release <email address hidden> Fri, 18 Jul 2014 19:15:36 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
Changed in ubuntu-ux:
status: New → Triaged
Changed in ubuntu-ux:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments