[browser] "Open link in a new tab" should open tab in the background on desktop

Bug #1339437 reported by Adnane Belmadiaf on 2014-07-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
Wishlist
James Mulholland
webbrowser-app
Fix Released
Wishlist
Niklas Wenzel
webbrowser-app (Ubuntu)
Undecided
Unassigned
webbrowser-app (Ubuntu RTM)
Undecided
Unassigned

Bug Description

"Open link in a new tab" should open tab in the background, and display some animation to inform the user(see Chrome/Firefox mobile).

Related branches

lp:~nikwen/webbrowser-app/open-in-new-background-tab
Merged into lp:webbrowser-app at revision 885
Olivier Tilloy: Approve on 2015-02-02
PS Jenkins bot: Needs Fixing (continuous-integration) on 2015-01-30
summary: - "Open link in a new tab" should open tab in the background
+ [browser] "Open link in a new tab" should open tab in the background
Changed in ubuntu-ux:
assignee: nobody → Giorgio Venturi (giorgio-venturi)

We have an animation when opening a new tab it will slide from the top

Changed in webbrowser-app:
assignee: nobody → Olivier Tilloy (osomon)
John Lea (johnlea) on 2014-07-21
Changed in ubuntu-ux:
importance: Undecided → Low
status: New → Triaged
Changed in ubuntu-ux:
status: Triaged → Opinion
Changed in ubuntu-ux:
status: Opinion → Won't Fix
importance: Low → Wishlist
Olivier Tilloy (osomon) on 2014-09-25
Changed in webbrowser-app:
status: New → Confirmed
status: Confirmed → Triaged

Most mobile browsers open new tabs in the foreground. We might want to change the behaviour on tablet/desktop browser as the tab-bar will be visible as in Chrome.

Changed in ubuntu-ux:
status: Won't Fix → Confirmed
tags: added: desktop-browser
tags: added: tablet-browser
Changed in ubuntu-ux:
status: Confirmed → Triaged
Olivier Tilloy (osomon) on 2014-10-21
Changed in webbrowser-app:
importance: Undecided → Wishlist
summary: - [browser] "Open link in a new tab" should open tab in the background
+ [browser] "Open link in a new tab" should open tab in the background on
+ desktop
Olivier Tilloy (osomon) on 2014-10-24
Changed in webbrowser-app:
assignee: Olivier Tilloy (osomon) → nobody
Niklas Wenzel (nikwen) wrote :

Here is something which is kind of related to this bug. I added the ability to open a link as a new tab in the background: https://code.launchpad.net/~nikwen/webbrowser-app/open-in-new-background-tab/+merge/245372

Thank you Niklas, this will be added to the desktop version of the Browser

On Thu, Dec 25, 2014 at 10:02 PM, Niklas Wenzel <email address hidden>
wrote:

> Here is something which is kind of related to this bug. I added the
> ability to open a link as a new tab in the background:
> https://code.launchpad.net/~nikwen/webbrowser-app/open-in-new-
> background-tab/+merge/245372
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1339437
>
> Title:
> [browser] "Open link in a new tab" should open tab in the background
> on desktop
>
> Status in Ubuntu UX bugs:
> Triaged
> Status in Web Browser App:
> Triaged
>
> Bug description:
> "Open link in a new tab" should open tab in the background, and
> display some animation to inform the user(see Chrome/Firefox mobile).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-ux/+bug/1339437/+subscriptions
>

Niklas Wenzel (nikwen) wrote :

Hi Giorgio,

Somehow I forgot to subscribe to this bug report, so I didn't see your reply until Olivier pointed me to it.
I originally created that MP because I found it annoying that I've never seen a *mobile* browser which allowed me to show both a "Open in new tab" and a "Open in new background tab" option.
I can understand if you still don't want this to be shown in the mobile version, but couldn't we make it optional in some way?
Since the settings UI isn't in place yet, would it be possible to add an entry to the "~/.config/webbrowser-app/settings.conf" file for this purpose, so that I can use the feature the way I wanted to use it?
Otherwise, the change I did would be useless for me.

Thanks. :)

Riccardo Padovani (rpadovani) wrote :

Just for reference, Android stock browser has an option to display in contextual menu both "open" and "open in background" (and open in incognito background too).

See the attached screenshot

Riccardo Padovani (rpadovani) wrote :
Niklas Wenzel (nikwen) wrote :

Riccardo, yes, that's true. I actually had that option set. However, as I mentioned, it didn't allow to show both actions, foreground and background tabs. ;)

Niklas Wenzel (nikwen) wrote :

With "foreground" I meant "new foreground tab". ;)

Olivier Tilloy (osomon) wrote :

Niklas: I discussed your suggestion with Giorgio, and we agreed that adding this option behind a setting (off by default on mobile, on by default on desktop) is a good idea. Can you go ahead and add that to the current MR ?

Niklas Wenzel (nikwen) wrote :

Thank you very much, Olivier! I'll try to add that as soon as possible. :)

Niklas Wenzel (nikwen) wrote :

I've fixed it in the MP. The setting to enable the "Open in new background tab" option on the phone form factor can be turned on like this:

mkdir ~/.config/webbrowser-app
nano ~/.config/webbrowser-app/settings.conf

Add the following line to the file and save it. Then restart the webbrowser app.

enableBackgroundTabs=true

Changed in webbrowser-app:
assignee: nobody → Niklas Wenzel (nikwen)
status: Triaged → In Progress
Olivier Tilloy (osomon) on 2015-02-03
Changed in webbrowser-app (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+15.04.20150203-0ubuntu1

---------------
webbrowser-app (0.23+15.04.20150203-0ubuntu1) vivid; urgency=medium

  [ Florian Boucault ]
  * Make splashscreen white instead of the default black. (LP: #1378379)

  [ Niklas Wenzel ]
  * Add the ability to open a link in a new background tab (LP:
    #1339437)

  [ Olivier Tilloy ]
  * Use the new restoreState API in oxide 1.4 to properly save and
    restore navigation state across sessions. (LP: #1353143)
  * Add a UA override for youtube.com on desktop to fix video playback.
    (LP: #1412880)
 -- Ubuntu daily release <email address hidden> Tue, 03 Feb 2015 11:06:38 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Olivier Tilloy (osomon) on 2015-02-03
Changed in webbrowser-app:
status: In Progress → Fix Released
Changed in webbrowser-app (Ubuntu RTM):
status: New → Confirmed
Changed in ubuntu-ux:
assignee: Giorgio Venturi (giorgio-venturi) → James Mulholland (jamesjosephmulholland)
Olivier Tilloy (osomon) on 2015-06-16
Changed in webbrowser-app (Ubuntu RTM):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments