[Dash] Art resizes based on header height in horizontal

Bug #1330945 reported by Victor Tuson Palau on 2014-06-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Savilerow project
Undecided
Unassigned
Ubuntu UX
High
James Mulholland
Unity 8
Fix Released
High
Albert Astals Cid

Bug Description

Using:
{
        "schema-version" : 1,
        "template" : {
        "category-layout" : "grid",
        "card-layout": "horizontal",
        "card-size": "small"
        },
        "components" : {
        "title" : "title",
        "subtitle":"subtitle",
        "summary":"summary",
        "art":"art2"
        }
        }

The image of ART in the grid view has inconsistent size on the phone but not the desktop sdk. See pictures.

Related branches

lp:~aacid/unity8/obeyArtShapeFixedSize
Superseded for merging into lp:unity8
Michał Sawicz: Approve on 2014-06-17
PS Jenkins bot: Approve (continuous-integration) on 2014-06-14
Victor Tuson Palau (vtuson) wrote :
Victor Tuson Palau (vtuson) wrote :

same scope on the desktop sdk behaves as expected

Michał Sawicz (saviq) on 2014-06-17
summary: - Size of Art in grid view is inconsistent
+ Art resizes based on header height in horizontal
Changed in unity8:
status: New → Incomplete

That's also by design. The spec states that "Header and Art are equal height." in horizontal layout.

You're seeing different things because your desktop (trusty) is behind your phone quite a bit.

Michał Sawicz (saviq) wrote :

Actually the fact that it's different between cards is a bug indeed, fixed in the linked branch.

Still, it's a design question whether the statement above is what we want.

Changed in unity8:
status: Incomplete → In Progress
importance: Undecided → High
assignee: nobody → Albert Astals Cid (aacid)
Mike Nagle (mikenagle) on 2014-06-24
Changed in ubuntu-ux:
assignee: nobody → Estibaliz Landa Torres (estilanda)
Michał Sawicz (saviq) on 2014-06-25
Changed in unity8:
status: In Progress → Fix Released
John Lea (johnlea) on 2014-07-21
summary: - Art resizes based on header height in horizontal
+ [Dash] Art resizes based on header height in horizontal
Changed in ubuntu-ux:
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-ux:
assignee: Estibaliz Landa Torres (estilanda) → nobody
assignee: nobody → James Mulholland (jamesjosephmulholland)
Chris Wayne (cwayne18) on 2015-02-12
Changed in savilerow:
status: New → Fix Released
Changed in ubuntu-ux:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers