[Scopes] Scope author should be able to set the number of collapsed results to show

Bug #1326470 reported by Chris Wayne on 2014-06-04
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
The Savilerow project
Undecided
Unassigned
Ubuntu UX
High
James Mulholland
Unity 8
Fix Released
High
Michał Sawicz
unity8 (Ubuntu)
Undecided
Michał Sawicz

Bug Description

In a scope with horizontal card layouts, you can only show up to 2 results by default. If the scope only has 1 category, that means most of the vertical space is blank, and looks quite empty. There should either be a way to define how many rows to show, or the toolkit should show as many as will fill up the veritcal space

Related branches

lp:~saviq/unity8/drop-filtergrid
Merged into lp:unity8 at revision 1072
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-07-22
Albert Astals Cid: Approve on 2014-07-22
Michael Zanetti: Approve on 2014-07-11
Leo Arias (community): Approve (code review of the autopilot bits) on 2014-07-11
Michal Hruby (community): Approve on 2014-07-11
Victor Tuson Palau (vtuson) wrote :

propose that "collapsed-rows " accepts any number not just 1 or 2

Mike Nagle (mikenagle) on 2014-06-10
Changed in ubuntu-ux:
status: New → In Progress
assignee: nobody → Mike Nagle (mikenagle)
Mike Nagle (mikenagle) wrote :

I agree. The scope author should be able to pick how many rows to display. On a screen with only a single category, we shouldn't have a collapsed state at all. I will update the spec accordingly.

tags: added: savilerow
Mike Nagle (mikenagle) wrote :

Just to say I have updated the spec now at https://sites.google.com/a/canonical.com/unity8dash/toolkit/9-categories/layouts

Example:
"Author defined. If screen only has a single category, it should not have a collapsed state. Recommend 2 rows on screens with multiple categories"

Mike Nagle (mikenagle) on 2014-06-17
Changed in ubuntu-ux:
status: In Progress → Fix Committed
Michał Karnicki (karni) on 2014-06-17
tags: added: scope-dev
Michal Hruby (mhr3) on 2014-07-09
no longer affects: unity-scopes-shell
no longer affects: unity-scopes-shell (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2014-07-09
Changed in unity8:
status: New → Triaged
importance: Undecided → High
Michał Sawicz (saviq) on 2014-07-10
Changed in unity8:
status: Triaged → In Progress
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Michał Sawicz (saviq)
Changed in unity8:
assignee: nobody → Michał Sawicz (saviq)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.90+14.10.20140724.1-0ubuntu1

---------------
unity8 (7.90+14.10.20140724.1-0ubuntu1) utopic; urgency=low

  [ Michael Zanetti ]
  * properly parent launcher items (LP: #1347902)

  [ Michał Sawicz ]
  * Move the PyDev project files to the root, supporting .py scripts
    outside of tests/autopilot. Add Autopilot Run and List launch
    configurations to easily support debugging in Eclipse. Use
    add_unity8_mock macro in the Telephony plugin.
  * Drop FilterGrid and refactor height animations in GenericScopeView.
    Also implement forced category expansion. (LP: #1326470)
  * Move expansion button from section header to category footer. (LP:
    #1261300)
  * Fix expect-sigstop enviroment variable name. (LP: #1346819)
  * Make headerless categories easier Instead of having no header
    category (which is a bit confusing since the LVWPH code was designed
    so that when a category has no header it is because it shares the
    category with the previous one) what we have for headerless
    categories is a header of height 0, this way everything works as it
    should and results in cleaner code in the LVWPH and in
    GenericScopeView
  * Add support for header links.
  * Add dash PageHeader styling.

  [ Albert Astals ]
  * Make headerless categories easier Instead of having no header
    category (which is a bit confusing since the LVWPH code was designed
    so that when a category has no header it is because it shares the
    category with the previous one) what we have for headerless
    categories is a header of height 0, this way everything works as it
    should and results in cleaner code in the LVWPH and in
    GenericScopeView
 -- Ubuntu daily release <email address hidden> Thu, 24 Jul 2014 20:41:29 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2014-07-25
Changed in unity8:
status: In Progress → Fix Released
Changed in ubuntu-ux:
assignee: Mike Nagle (mikenagle) → James Mulholland (jamesjosephmulholland)
Changed in ubuntu-ux:
importance: Undecided → High
Chris Wayne (cwayne18) on 2015-02-12
Changed in savilerow:
status: New → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
summary: - Scope author should be able to set the number of collapsed results to
- show
+ [Scopes] Scope author should be able to set the number of collapsed
+ results to show
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers