[browser] There is no search in page option in webbrowser-app (like ctrl+F)

Bug #1312260 reported by mexlinux on 2014-04-24
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Oxide
Medium
Ugo Riboni
Ubuntu UX
Low
James Mulholland
webbrowser-app (Ubuntu)
Medium
Ugo Riboni

Bug Description

Users will be able to find text in page (partial&exact match)
- Function will be available in the Action Drawer

UX Spec here
https://docs.google.com/a/canonical.com/presentation/d/1Qrd4Flfs3EH-fI79IfrYgLdAx2nce-L7ve8NKLCX324/edit#slide=id.g187f4edfe_50

Related branches

lp:~uriboni/oxide/find-in-page
Merged into lp:oxide at revision 1088
Chris Coulson: Approve on 2015-05-21
lp:~uriboni/webbrowser-app/find-in-page
Rejected for merging into lp:webbrowser-app
Olivier Tilloy: Disapprove on 2015-07-01
Riccardo Padovani (community): Needs Fixing on 2015-06-12
PS Jenkins bot: Needs Fixing (continuous-integration) on 2015-06-11
Ugo Riboni: Approve on 2015-05-13
lp:~osomon/webbrowser-app/find-in-page
PS Jenkins bot: Needs Fixing (continuous-integration) on 2015-07-03
Riccardo Padovani (community): Approve on 2015-07-03
Ubuntu Phablet Team: Pending requested 2015-07-01
mexlinux (mcanedo) on 2014-04-24
summary: - There is no search in page option in webbroser-app (like ctrl+F)
+ There is no search in page option in webbrowser-app (like ctrl+F)

Note that there is currently no design specification for search in page, so we’ll need one.

Changed in webbrowser-app:
status: New → Triaged

It's in our design requirements but it's not high priority

Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Giorgio Venturi (giorgio-venturi)
John Lea (johnlea) on 2014-07-21
summary: - There is no search in page option in webbrowser-app (like ctrl+F)
+ [browser] There is no search in page option in webbrowser-app (like
+ ctrl+F)
Changed in ubuntu-ux:
status: Triaged → New
Changed in webbrowser-app:
status: Triaged → New
importance: Undecided → Low
John Lea (johnlea) on 2014-07-21
Changed in ubuntu-ux:
status: New → Triaged
description: updated
Olivier Tilloy (osomon) on 2014-10-09
Changed in webbrowser-app:
status: New → Confirmed
status: Confirmed → Triaged
description: updated
Changed in ubuntu-ux:
status: Triaged → Fix Committed
James Hunt (jamesodhunt) wrote :

Giorgio - the spec doesn't appear to specify the colour that should be used for the highlights. If the highlight colour is fixed as say yellow, it would have no effect if the background colour of the page was the same colour. What if the background colour is white but the text is yellow?

Olivier Tilloy (osomon) on 2014-10-21
tags: added: design-gap
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
tags: added: usability
Olivier Tilloy (osomon) wrote :

Adding an oxide task as we need a new API in oxide to implement that.

Changed in oxide:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ugo Riboni (uriboni)
Changed in webbrowser-app:
assignee: nobody → Ugo Riboni (uriboni)
importance: Low → Medium
Olivier Tilloy (osomon) on 2015-04-30
Changed in oxide:
status: Confirmed → In Progress
Ugo Riboni (uriboni) on 2015-05-05
Changed in webbrowser-app:
status: Triaged → In Progress
Changed in oxide:
milestone: none → branch-1.8
status: In Progress → Fix Released
Changed in ubuntu-ux:
assignee: Giorgio Venturi (giorgio-venturi) → James Mulholland (jamesjosephmulholland)
Olivier Tilloy (osomon) on 2015-06-08
Changed in webbrowser-app (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Ugo Riboni (uriboni)
importance: Undecided → Medium
Changed in webbrowser-app:
assignee: Ugo Riboni (uriboni) → nobody
status: In Progress → Invalid
Olivier Tilloy (osomon) on 2015-07-01
no longer affects: webbrowser-app
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers