[OOBE] "phone" string in tablet oobe; oobe should have "tablet" or generic term

Bug #1294732 reported by Jon Melamut on 2014-03-19
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Andreea Pirvu
unity8 (Ubuntu)
Lukáš Tinkl

Bug Description

build r237
the oobe on the tablet (nexus 7) refers to a "phone" it should refer to a "tablet" or a generic like "your device"

See also bug 1258211.

Related branches

PS Jenkins bot: Needs Fixing (continuous-integration) on 2016-02-09
Unity8 CI Bot: Needs Fixing (continuous-integration) on 2016-02-09
Andrea Cimitan: Approve on 2016-02-09
Unity Team: Pending requested 2016-03-11
John Kim (kotux) on 2014-03-20
tags: added: bitesize string-fix
Changed in ubuntu-ux:
assignee: nobody → Mike Nagle (mikenagle)
status: New → Incomplete
John Lea (johnlea) on 2014-07-21
summary: - [oobe] "phone" string in tablet oobe; oobe should have "tablet" or
- generic term
+ [meet ubuntu] "phone" string in tablet oobe; oobe should have "tablet"
+ or generic term
Changed in ubuntu-ux:
assignee: Mike Nagle (mikenagle) → Estibaliz Landa Torres (estilanda)
status: Incomplete → New
Stephen M. Webb (bregma) on 2014-07-21
affects: unity → unity8
Michał Sawicz (saviq) on 2014-07-21
Changed in unity8:
status: New → Triaged
importance: Undecided → High
Changed in ubuntu:
status: New → Confirmed
John Lea (johnlea) on 2014-07-21
Changed in ubuntu-ux:
importance: Undecided → High
status: New → Triaged
Changed in unity8:
status: Triaged → New

let´s use "device" as generic

Changed in ubuntu-ux:
status: Triaged → Fix Committed
Michał Sawicz (saviq) on 2014-09-03
affects: ubuntu → unity8 (Ubuntu)
Changed in unity8 (Ubuntu):
importance: Undecided → High
Michał Sawicz (saviq) on 2014-09-09
no longer affects: unity8
Andrea Cimitan (cimi) on 2014-10-22
Changed in unity8 (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Matthew Paul Thomas (mpt) wrote :

This is not the only case where the UI assumes the device is a phone; bug 1258211 is another.

I don't think using "device" is a general solution, because that makes the OS seem as if it doesn't know that it's running on a phone. "Welcome to your new ... uh ... whatever the heck this thing is."

Maybe this discussion will seem quaint 30 years from now, but in the meantime, I suggest we come up with a standard method to label the type of device Ubuntu is running on. Otherwise we'll end up with some parts of the UI calling it a phone because it has a SIM, other parts calling it a tablet because its screen is more than 6.5 inches, etc.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2015-03-09
Changed in unity8 (Ubuntu):
status: Invalid → Confirmed
no longer affects: ubuntu-system-settings (Ubuntu)
Changed in ubuntu-ux:
assignee: Estibaliz Landa Torres (estilanda) → nobody
status: Fix Committed → Triaged
Changed in ubuntu-ux:
assignee: nobody → Olga Kemmet (olga-kemmet)
kevin gunn (kgunn72) on 2015-04-13
tags: added: desktop
summary: - [meet ubuntu] "phone" string in tablet oobe; oobe should have "tablet"
- or generic term
+ [OOBE] "phone" string in tablet oobe; oobe should have "tablet" or
+ generic term
Changed in ubuntu-ux:
assignee: Olga Kemmet (olga-kemmet) → Andreea Pirvu (andreea-pirvu)
Albert Astals Cid (aacid) wrote :

unity8 waiting for design -> Incomplete

Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete
Andreea Pirvu (andreea-pirvu) wrote :

The new OOBE design is using the word device everywhere
Please check the new OOBE spec at https://docs.google.com/a/canonical.com/document/d/1pZ-Ro--2eaRzjZKNRoYAeDvQHMkCuyvVuPFWFQfPW4s/edit?usp=sharing

Changed in unity8 (Ubuntu):
status: Incomplete → Fix Committed
Changed in ubuntu-ux:
status: Triaged → Fix Committed
Changed in unity8 (Ubuntu):
status: Fix Committed → Confirmed
Changed in unity8 (Ubuntu):
assignee: nobody → Lukáš Tinkl (lukas-kde)
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.11+16.04.20160212-0ubuntu1

unity8 (8.11+16.04.20160212-0ubuntu1) xenial; urgency=medium

  [ Albert Astals Cid ]
  * Do not use components in card creator generated code
  * Forward the makesurevisible signal from the inner preview widget
  * Make fallback also be fallback when the image is empty and not only
    on error (LP: #1531913)
  * Make the artShapeSize assignment be updated when using dynamic grid
  * Visual improvements to the dash audio play cards
  * We don't use the unity-scope-scopes anymore (LP: #1439172)

  [ Andrea Cimitan ]
  * only request a bigger image if zoomable widget data property is
    true, otherwise just leave the screen size (LP: #1536814)

  [ CI Train Bot ]
  * Update translation template

  [ Daniel d'Andrada ]
  * Set initial surface size (LP: #1532974)

  [ Daniel d'Andrada, Michał Sawicz ]
  * Window Size Hints

  [ Florian Boucault ]
  * Splash screen: delay showing the ActivityIndicator by 2 seconds.

  [ Lukáš Tinkl ]
  * Replace the word "phone" with a more generic term "device" in the
    welcome wizard (LP: #1294732, #1543527)

  [ Michael Terry ]
  * Have the tablet greeter set appropriate OSK hints if the user has a
    passcode instead of a passphrase. (LP: #1544173)

  [ Michael Zanetti ]
  * Don't eat mouse events in the edgebarrer

  [ Michał Sawicz ]
  * Bump unity-api dependencies

  [ Nick Dedekind ]
  * Added support for secondary indicator actions (LP: #1398888)
  * Remove zombie if they're not animated. (LP: #1534541)
  * Removed unused panel resources

  [ Ted Gould ]
  * Start the indicators after Unity8 starts instead of before

 -- Michał Sawicz <email address hidden> Fri, 12 Feb 2016 00:12:41 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers