[Messaging] Show number of characters used and number of messages to send

Bug #1278790 reported by Daniel Holbach on 2014-02-11
158
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Wishlist
Bill Filler
Ubuntu UX
Medium
Paty Davila
messaging-app (Ubuntu)
Wishlist
Pat McGowan

Bug Description

As many carriers charge per text message sent, it'd be nice to show how many characters were used for the message, so the sender knows how many sent text messages this boils down to.

Related branches

lp:~pat-mcgowan/messaging-app/fix-1278790
Tiago Salem Herrmann: Approve on 2016-08-12
Bill Filler (bfiller) on 2014-04-09
Changed in messaging-app:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Daniela Ferrai (dferrai) on 2014-06-24
Changed in ubuntu-ux:
assignee: nobody → Benjamin Keyser (bjkeyser)
Changed in ubuntu-ux:
assignee: Benjamin Keyser (bjkeyser) → Olga Kemmet (olga-kemmet)
summary: - Show number of characters used
+ [Messaging] Show number of characters used
Changed in ubuntu-ux:
importance: Undecided → Medium
Changed in ubuntu-ux:
status: New → In Progress
Changed in ubuntu-ux:
status: In Progress → Fix Committed
Bill Filler (bfiller) on 2014-09-26
Changed in messaging-app:
importance: Medium → Wishlist
Changed in messaging-app (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in messaging-app (Ubuntu):
assignee: nobody → Tiago Salem Herrmann (tiagosh)
no longer affects: messaging-app

it's "fix commited" for ux component but where is the design document/recommendation?

Changed in ubuntu-ux:
status: Fix Committed → Triaged
Changed in messaging-app (Ubuntu):
status: Confirmed → Incomplete
summary: - [Messaging] Show number of characters used
+ [Messaging] Show number of characters used and numver of messages
summary: - [Messaging] Show number of characters used and numver of messages
+ [Messaging] Show number of characters used and number of messages
summary: - [Messaging] Show number of characters used and number of messages
+ [Messaging] Show number of characters used and number of messages to
+ send
Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → Wishlist
status: New → Confirmed
Changed in messaging-app (Ubuntu):
assignee: Tiago Salem Herrmann (tiagosh) → Pat McGowan (pat-mcgowan)
status: Incomplete → In Progress
Pat McGowan (pat-mcgowan) wrote :

Proposed implementation

Changed in canonical-devices-system-image:
milestone: none → 13
status: Confirmed → In Progress
Changed in ubuntu-ux:
assignee: Olga Kemmet (olga-kemmet) → nobody
Pat McGowan (pat-mcgowan) wrote :

design questions
Should we not show the number of messages until there is more than 1
if we will use MMS, should we replace the count with some text indicate such or the users may be confused why the count is not there, so rather than suppressing the text, replace with "Using MMS" or similar

GTriderXC (gtriderxc) wrote :

MMS? Perhaps it is gonna be off topic, perhaps it is the best moment to ask this qestion: how do we decide whether a message will be sent as SMS or MMS? I just send messages from my phone. Do You wanna tell me it sends messages as MMS? Sorry I do not send many messages and never even thought that we are able to send MMS. How do we know, decide and switch? This question may be a key to what Pat wrote. Does the phone choose the kind of a message by itself? I do not see a switcher or an option for MMS.

Pat McGowan (pat-mcgowan) wrote :

Any message with an attachment will use MMS to do the transfer over the data connection. We also have an option under settings to enable it for group chat, otherwise the messages are sent separately. All other messages are SMS.

GTriderXC (gtriderxc) wrote :

If the app knows when a message should be a SMS or MMS it could perhaps change the amount of messages on the screen automatically between 160 for a sms and as I remember 1000 for a mms

Pat McGowan (pat-mcgowan) wrote :

The message count is not really the issue for MMS as its based on data usage billing.
The proposed implementation shows "MMS" when that is the case but no counts

Paty Davila (dizzypaty) wrote :

=== UX Comment ===

Agreed with the proposed solution. I recommend that we present the character counter string with the following format: “n(z)”; n= character count and z= number of SMS (e.g.: 56(1) —> 160(1) —> 161(2)). Because the suggested format seems a bit complex IMO and the most relevant info is the number of SMS rather than the character limit. The string can change to “MMS” when sending a message with attachments.

@raecontreras is working on a visual for the text size, position and alignment of the string in relation to the text field and she’ll post it here as soon as it’s ready.

Changed in ubuntu-ux:
assignee: nobody → Paty Davila (dizzypaty)
Pat McGowan (pat-mcgowan) wrote :

@paty thanks, I really need that today or this won't land in time

Rae Shambrook (raecontreras) wrote :

Attached is the approved visual design and spec

Rae Shambrook (raecontreras) wrote :
Pat McGowan (pat-mcgowan) wrote :

@rae thanks for the mockup, all the screenshots of other devices I looked at had it top and center, is there a reason you chose below and right? Also, I tried x-small and its frankly illegible on mx4 so sticking with just small if thats ok.

Rae Shambrook (raecontreras) wrote :

@pat-mcgowan I had seen some examples that had the counter bottom right, such as material design. In addition, we want the placement to fit in with our other patterns, which currently we do not use centre alignment. Another benefit of having the counter to the right is it's near the send button, so the user can more clearly keep track of their messages. As for x-small to small, that's fine.

Pat McGowan (pat-mcgowan) wrote :
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package messaging-app - 0.1+16.10.20160819-0ubuntu1

---------------
messaging-app (0.1+16.10.20160819-0ubuntu1) yakkety; urgency=medium

  [ Devid Antonio Filoni ]
  * Preserve empty lines and leading spaces. (LP: #1366592)

  [ Pat McGowan ]
  * This adds support for showing the current character count and number
    of messages to be sent via SMS. It includes a new label on top of
    the text area showing number of characters / 160 (number of
    messages). It is shown once the message is over 1 line in length,
    per other systems. (LP: #1278790)

  [ Tiago Salem Herrmann ]
  * Share text only if there is no url in the content-hub transfer. (LP:
    #1613338)

 -- Tiago Salem Herrmann <email address hidden> Fri, 19 Aug 2016 15:15:35 +0000

Changed in messaging-app (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers