[sdk] unable to set fixed dimensions for a given Dialog element.

Bug #1249325 reported by Francisco Merino on 2013-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
Ubuntu UX
High
Jouni Helminen
ubuntu-ui-toolkit (Ubuntu RTM)
High
Zsombor Egri

Bug Description

It seems as right now, it's not possible to set fixed height and width to a dialog element. I would love to be able to do this because now I have a dialog element cointaining both a listview and a button and I'm unable to put everything in the right position. I can't see the complete strings which should appear inside the listview, the button overlaps the dialog's title, etc.

Related branches

Tim Peeters (tpeeters) wrote :

The dialog automatically determines its size, and it will be different on different screen sizes. Fixed height/width can give problems when changing window/screen sizes. Any ideas from design how to deal with this?

Changed in ubuntu-ui-toolkit:
status: New → Incomplete
summary: - unable to set fixed dimensions for a given Dialog element.
+ [sdk] unable to set fixed dimensions for a given Dialog element.
Changed in ubuntu-ux:
assignee: nobody → Jouni Helminen (jounihelminen)
status: New → Triaged
Zoltan Balogh (bzoltan) on 2014-11-24
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Incomplete
Zoltan Balogh (bzoltan) on 2014-11-24
no longer affects: ubuntu-ui-toolkit
Changed in ubuntu-ux:
importance: Undecided → High
Jouni Helminen (jounihelminen) wrote :

The buttons in a dialog should be at the bottom of the dialog, not near the title at the top.

Tim is right in the sense that the same app might be ran on wildly different screen sizes, but I think it should be possible for developers to override the default size if they really want to. Either in absolute (xxGU) or relative (80% of screen size) terms.

Changed in ubuntu-ux:
status: Triaged → Fix Committed
Changed in ubuntu-ux:
assignee: Jouni Helminen (jounihelminen) → nobody
Jouni Helminen (jounihelminen) wrote :

this is now possible: set contentWidth/Height

Changed in ubuntu-ux:
status: Fix Committed → Fix Released
assignee: nobody → Jouni Helminen (jounihelminen)
Zsombor Egri (zsombi) on 2015-12-08
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Zsombor Egri (zsombi)
importance: Undecided → High
Zoltan Balogh (bzoltan) on 2015-12-08
affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit (Ubuntu RTM)
Changed in canonical-devices-system-image:
milestone: none → ww02-2016
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → In Progress
Zoltan Balogh (bzoltan) on 2015-12-16
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :
Download full text (7.8 KiB)

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1761+15.04.20151216.1-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1761+15.04.20151216.1-0ubuntu1) vivid; urgency=medium

  [ Zoltán Balogh ]
  * Drop dependency on qtc plugin script and wait for the shell with a local
    function.

  [ Christian Dywan ]
  * runtest.sh needs to add subdirs to the libpath. Fixes: LP: #1524710.
  * Explicit click/ touch threshold beyond handler.
  * Enter/Return/Space should trigger() Button. Fixes: LP: #1523794.
  * Only set ppmm in SwipeArea if screen has valid dpi. Fixes: LP: #1525174.

  [ Tim Peeters ]
  * Implement header slot management for convergence:
    - Adapt the number of action slots to the width of the view.
    - When a new action appears, show a quick fade-in.
    - Reverse the order of the actions in the header.
    - Update icon width to 4GU. Fixes: LP: #1428757.
  * To prevent an invalid sectionIndex, reset the value of sectionIndex to -1
    when the model of Sections is changed. Fixes: LP: #1513933.

  [ Loïc Molinari ]
  * UbuntuShape - Cleaned up includes.

  [ Albert Astals Cid ]
  * Simplify logic for emitting draggingChanged/pressedChanged
    No need for a switch that considers the possible cases, just store the
    status before and check after
    Fixes an issue in which the SwipeArea pressedChanged signal was not emitted
    if switching directly from WaitingForTouch to Recognized.
  * Fix memory leak in SwipeArea
    SwipeAreaPrivate is not deleted directly so make it part of the qobject
    hierarchy so it's auto deleted on parent destruction.

  [ Zsombor Egri ]
  * Add reset functionality to Action.shortcut property. Fixes: LP: #1518420.
  * Add contentWidth and contentHeight to Dialog so foreground can be resized.
    Fixes: LP: #1249325.
  * Fixing ListItem.selected and ListItem.selectMode bugs.
    Fixes: LP: #1493880, LP: #1493882, LP: #1514928.
  * Add private implementations to ActionItem, AbstractButton, BottomEdgeHint
    and BottomEdge. Fixes: LP: #1524234
  * Close Popups.Dialog when Esc key is pressed. Fixes LP: #1523833
  * Invoke the overridden trigger() function for Action and ActionItem
    derivates. Fixes LP: #1524234
  * Fix BottomEdge assertion when the content is committed by clicking on the
    hint. Fixes LP: #1524407

  [ CI Train Bot ]
  * No-change rebuild.

ubuntu-ui-toolkit (1.3.1742+16.04.20151209-0ubuntu1) xenial; urgency=medium

  [ Zoltán Balogh ]
  * Enable building the UITK tests in any case.
  * Remove Q_Q(UCStyledItemBase) because of unused variable warning.
  * Resolve Trusty specific compiler issue not resolving QPointer data on
    connections.
  * Use only the object name when selecting sections and labels in tests.

  [Zsombor Egri ]
  * Update BottomEdge with UI/UX agreed during the sprint. Fixes LP: #1368811.
  * BottomEdge component. Fixes LP: #1368811.
  * Remove build failure on Xenial caused by deprecated Qt functions.
  * Fix BottomEdgeHint consumes activeFocusOnPress handling. Fixes LP: #1517777
  * Migrate DirectionalDragArea from Unity8, named as SwipeArea. Original code
    (from lp...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers