[osk] Hebrew symbols revised

Bug #1233578 reported by Yaron on 2013-10-01
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
Daniela Ferrai
ubuntu-keyboard
Medium
Michael Sheldon
ubuntu-keyboard (Ubuntu)
High
Unassigned

Bug Description

I've just noticed the hebrew-symbols.xml file and I have some corrections.

The New Sheqel sign should be in higher priority:
        <key>
          <binding label="₪" />
        </key>
        <key>
          <binding label="$" />
        </key>
        <key>
          <binding label="€" />
        </key>
        <key>
          <binding label="£" />
        </key>
        <key>
          <binding label="¥" />
        </key>
        <key>
          <binding label="%" />
        </key>

Next there are these changes:
Adding Geresh (U+05F3) - Often used.
Adding Gershayim (U+05F4) - Often used (for acronyms mostly).

I would push apostrophe and quotes down the hierarchy in favor of these symbols.

Please don't push any changes yet, I need a review from the Israeli community.

Pat McGowan (pat-mcgowan) wrote :

Can you confirm these changes?

Changed in ubuntu-keyboard:
status: New → Incomplete
Yaron (sh-yaron) wrote :

Yes, confirmed.

summary: - Hebrew symbols revised
+ [osk] Hebrew symbols revised
Yaron (sh-yaron) on 2014-05-02
Changed in ubuntu-keyboard:
status: Incomplete → Confirmed
description: updated
description: updated
Bill Filler (bfiller) on 2014-05-27
Changed in ubuntu-keyboard:
assignee: nobody → Michael Sheldon (michael-sheldon)
importance: Undecided → Medium
Daniela Ferrai (dferrai) on 2014-06-24
Changed in ubuntu-ux:
assignee: nobody → Benjamin Keyser (bjkeyser)
Yaron (sh-yaron) wrote :

I was thinking about overloading another character on this button:

CharKey { id: dotKey; label: "."; shifted: "."; extended: ["?", "!"]; extendedShifted: ["?", "!"]; anchors.right: enterKey.left; }

http://www.fileformat.info/info/unicode/char/5be/index.htm

CharKey { id: dotKey; label: "."; shifted: "."; extended: ["?", "!","־"]; extendedShifted: ["?", "!","־"]; anchors.right: enterKey.left; }

Do you think it would be possible?

Kind regards,
Yaron Shahrabani.

Hi Yaron,

 That sounds like a good idea to me; I'll add it to the current branch for those changes now.

Thanks!

Thanks! That would be awesome, there is a new keyboard layout for Hebrew,
this keyboard best complies with this standard, better than most mobile
platforms :)

Yaron Shahrabani

<Hebrew translator>

On Wed, Jul 16, 2014 at 4:32 PM, Michael Sheldon <email address hidden> wrote:

> Hi Yaron,
>
> That sounds like a good idea to me; I'll add it to the current branch
> for those changes now.
>
> Thanks!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1233578
>
> Title:
> [osk] Hebrew symbols revised
>
> Status in Ubuntu Keyboard:
> Confirmed
> Status in Ubuntu UX bugs:
> New
> Status in Ubuntu:
> New
>
> Bug description:
> I've just noticed the hebrew-symbols.xml file and I have some
> corrections.
>
> The New Sheqel sign should be in higher priority:
> <key>
> <binding label="₪" />
> </key>
> <key>
> <binding label="$" />
> </key>
> <key>
> <binding label="€" />
> </key>
> <key>
> <binding label="£" />
> </key>
> <key>
> <binding label="¥" />
> </key>
> <key>
> <binding label="%" />
> </key>
>
> Next there are these changes:
> Adding Geresh (U+05F3) - Often used.
> Adding Gershayim (U+05F4) - Often used (for acronyms mostly).
>
> I would push apostrophe and quotes down the hierarchy in favor of
> these symbols.
>
> Please don't push any changes yet, I need a review from the Israeli
> community.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-keyboard/+bug/1233578/+subscriptions
>

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Adolfo Jayme (fitojb) wrote :

ubuntu-keyboard (0.99.trunk.phablet2+14.10.20140718-0ubuntu1) utopic; urgency=low

  [ Michael Sheldon ]
  * Enable the language menu when single pressing the language switcher
    button and add a settings item to the bottom of the language
    switcher.
  * Add numbers to the extended keys in the top row and extra
    punctuation on existing punctuation keys. Also adds the new sheqel
    symbol to the Hebrew keyboard and ensures that the Hebrew keyboard
    still displays keys when in capital mode. (LP: #1233578)
  * Fix incorrect Russian characters and layout (LP: #1321908)
  * Implement swiping behaviour for the selection of extended keys and
    fix popover position when selecting the same extended key after
    changing orientation.
 -- Ubuntu daily release <email address hidden> Fri, 18 Jul 2014 16:27:52 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2014-07-20
affects: ubuntu → ubuntu-keyboard (Ubuntu)
Changed in ubuntu-keyboard (Ubuntu):
importance: Undecided → High
status: New → Fix Released
John Lea (johnlea) on 2014-07-21
Changed in ubuntu-ux:
assignee: Benjamin Keyser (bjkeyser) → Daniela Ferrai (dferrai)
importance: Undecided → Medium
status: New → Triaged
Bill Filler (bfiller) on 2014-07-31
Changed in ubuntu-keyboard:
status: Confirmed → Fix Released
Daniela Ferrai (dferrai) on 2014-08-05
Changed in ubuntu-ux:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers