[system] Changing volume doesn't show feedback on the phone

Bug #1232633 reported by Jhosman Lizarazo on 2013-09-29
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Grazina
indicator-sound (Ubuntu)
Undecided
Unassigned
indicator-sound (Ubuntu RTM)
Undecided
Unassigned
unity-notifications (Ubuntu)
Undecided
Mirco Müller
unity-notifications (Ubuntu RTM)
Undecided
Unassigned
unity8 (Ubuntu)
High
Mirco Müller
unity8 (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Not an indicator of volume status when it makes adjusting volume (Nexus 4)

<https://wiki.ubuntu.com/Sound#volume-keys>: "In addition, any of those keys/buttons should play a subtle noise for you to gauge the volume, and display a confirmation bubble with the icon of the primary sound output at the current volume, a volume bar, and accessible text “Sound muted” or “Volume {X}%” (for example, “Volume 75%”)."

**Update**
For EU regulations:
When listening to music/audio sources and the volume is raised above a certain threshold a warning must be displayed to user.

Related branches

lp:~macslow/unity8/synchronous-notification
Merged into lp:unity8/rtm-14.09 at revision 1354
Albert Astals Cid: Approve on 2014-10-14
Merged into lp:unity8 at revision 1372
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-10-20
Albert Astals Cid: Approve on 2014-10-14
Michał Sawicz: Needs Fixing on 2014-10-09
Andrea Cimitan: Approve on 2014-10-09
lp:~macslow/indicator-sound/synchronous-notification
Merged into lp:indicator-sound/14.10 at revision 450
Michał Sawicz: Needs Information on 2014-10-09
Ted Gould: Approve on 2014-10-07
PS Jenkins bot: Approve (continuous-integration) on 2014-09-19
lp:~macslow/unity-notifications/synchronous-notification
Merged into lp:unity-notifications at revision 221
Michael Terry: Approve on 2014-09-22
PS Jenkins bot: Approve (continuous-integration) on 2014-09-12
lp:~ted/indicator-sound/extreme-volume-warning
Merged into lp:indicator-sound at revision 461
Charles Kerr: Approve on 2014-11-03
PS Jenkins bot: Approve (continuous-integration) on 2014-10-31
Charles Kerr: Approve on 2014-11-03
PS Jenkins bot: Approve (continuous-integration) on 2014-10-15
Lars Uebernickel (larsu) wrote :

I think this is a good idea as well. We've actually had this, but had to revert it because unity8 doesn't handle synchronous notifications (bug #1236292).

Also, it's missing input from design: https://wiki.ubuntu.com/Sound#Volume_changes

summary: - Volume Change
+ Changing volume doesn't show feedback on the phone
Changed in indicator-sound:
status: New → Triaged
assignee: nobody → Matthew Paul Thomas (mpt)
Michał Sawicz (saviq) on 2013-10-23
Changed in unity8:
status: New → Incomplete

Specification updated. <https://wiki.ubuntu.com/Sound?action=diff&rev2=108&rev1=105> Now this needs visual design.

Incidentally, this seems like it doesn't belong to the sound menu. You should get the same notification even if the sound menu is turned off, or if it didn't exist at all.

Changed in indicator-sound:
assignee: Matthew Paul Thomas (mpt) → Jouni Helminen (jounihelminen)
status: Triaged → Confirmed
description: updated
Lars Uebernickel (larsu) wrote :

As Matthew says, this is not an issue with the sound menu. Unity8 listens to the volume keys and shows the notification bubbles.

no longer affects: indicator-sound
Omer Akram (om26er) wrote :

ping @design.

Daniela Ferrai (dferrai) on 2014-06-24
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
Benjamin Keyser (bjkeyser) wrote :

We need on screen feedback for volume. Esti will create a volume visual that will be more integrated and not look like a popup.

Changed in ubuntu-ux:
status: New → Triaged
John Lea (johnlea) on 2014-07-21
Changed in ubuntu-ux:
assignee: Matthew Paul Thomas (mpt) → Estibaliz Landa Torres (estilanda)
status: Triaged → New
importance: Undecided → High
Changed in unity8:
importance: Undecided → High
status: Incomplete → New
summary: - Changing volume doesn't show feedback on the phone
+ [system] Changing volume doesn't show feedback on the phone
John Lea (johnlea) on 2014-07-21
Changed in ubuntu-ux:
status: New → Triaged

It´s work in progress, design was delivered to Mirco in the London sprint

Changed in ubuntu-ux:
status: Triaged → Fix Committed
Michał Sawicz (saviq) on 2014-09-03
Changed in unity8 (Ubuntu):
importance: Undecided → High
Michał Sawicz (saviq) on 2014-09-09
no longer affects: unity8
kevin gunn (kgunn72) on 2014-09-11
Changed in unity8 (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
status: New → In Progress
tags: added: rtm14 touch-2014-09-25
Mirco Müller (macslow) wrote :

That's the current state of the attached branches in action... https://www.youtube.com/watch?v=mi-Z2Rn7Fxo

Mirco Müller (macslow) wrote :

The design for the phone is different from the old NotifyOSD design referenced in the mentioned wiki-page in the bug-description. Furthermore the sound to play back on the phone has not been stated nor provided anywhere.

For EU regulations:
When listening to music/audio sources and the volume is raised above a certain threshold a warning must be displayed to user.

See the attached screenshot from Android.

description: updated
Mirco Müller (macslow) wrote :

This warning is only shown to the user (on Android) if headphones are plugged it.

We too could display such a warning by triggering a corresponding snap-decision from indicator-sound. With our current notification-system we have all needed means for this in place. But what icon, summary- and body-text should it display? What labels should be used on the buttons. How should the phone (indicator-sound) behave if the user selects "Cancel"? How long should it (indicator-sound) remember that user-choice? Until headphones are unplugged and plugged in again? This needs some good thought and "user-journey" from Design.

What we need on the side of indicator-sound is a way to determine, if a headphone is currently plugged into the phone or not. I don't know the audio-stack well enough to answer this.

Changed in ubuntu-ux:
assignee: Estibaliz Landa Torres (estilanda) → nobody
assignee: nobody → Estibaliz Landa Torres (estilanda)
kevin gunn (kgunn72) on 2014-09-25
tags: added: touch-2014-10-02
removed: touch-2014-09-25
kevin gunn (kgunn72) on 2014-09-29
tags: added: touch-2014-10-09
removed: touch-2014-10-02
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+14.10.20141007-0ubuntu1

---------------
indicator-sound (12.10.2+14.10.20141007-0ubuntu1) utopic; urgency=low

  [ Ted Gould ]
  * Merge trunk into older branches to resolve conflicts.

  [ Nick Dedekind ]
  * Use label for Volume sliders.

  [ Mirco Müller ]
  * Merge trunk into older branches to resolve conflicts.

  [ CI bot ]
  * Added use of synchronous notifications for volume-changes. (LP:
    #1232633)
  * Volume control: properly scale channels when setting the volume (LP:
    #1374249)
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 02:51:42 +0000

Changed in indicator-sound (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.00+14.10.20141015.4~rtm-0ubuntu1

---------------
unity8 (8.00+14.10.20141015.4~rtm-0ubuntu1) 14.09; urgency=low

  [ Michał Sawicz ]
  * remove qml ownership confusion for caching unitymenumodels (LP:
    #1368856)

  [ josharenson ]
  * Fix lp:1370240 by making stages interactive when a snap decision is
    dismissed. (LP: #1370240)

  [ Nick Dedekind ]
  * remove qml ownership confusion for caching unitymenumodels (LP:
    #1368856)
  * Implementation of expandable panel design (LP: #1368856)

  [ Albert Astals ]
  * CardAttributes: Specify column and row since the gridlayout gets
    confused sometimes (LP: #1381092)
  * Reset VerticalJournal until the cardTool settles (LP: #1381255)

  [ Mirco Müller ]
  * Added synchronous/confirmation notification support to unity8. (LP:
    #1232633)

  [ Michael Zanetti ]
  * drop all visual indication of "pinning" (LP: #1381054)
  * Fix lp:1370240 by making stages interactive when a snap decision is
    dismissed. (LP: #1370240)

  [ Antti Kaijanmäki ]
  * Unlock all modems on boot. (LP: #1333121)
 -- Ubuntu daily release <email address hidden> Wed, 15 Oct 2014 16:44:20 +0000

Changed in unity8 (Ubuntu RTM):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-notifications - 0.1.2+14.10.20141015~rtm-0ubuntu1

---------------
unity-notifications (0.1.2+14.10.20141015~rtm-0ubuntu1) 14.09; urgency=low

  [ Mirco Müller ]
  * Added support, examples and tests for synchronous/confirmation
    notifications. (LP: #1232633)
 -- Ubuntu daily release <email address hidden> Wed, 15 Oct 2014 08:16:35 +0000

Changed in unity-notifications (Ubuntu RTM):
status: New → Fix Released
kevin gunn (kgunn72) on 2014-10-20
Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2014-10-20
Changed in unity8 (Ubuntu):
status: Fix Released → In Progress
Changed in unity-notifications (Ubuntu):
status: New → In Progress
assignee: nobody → Mirco Müller (macslow)
Michał Sawicz (saviq) on 2014-10-30
Changed in indicator-sound (Ubuntu):
status: Fix Released → In Progress
Changed in indicator-sound (Ubuntu RTM):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-notifications - 0.1.2+15.04.20141030-0ubuntu1

---------------
unity-notifications (0.1.2+15.04.20141030-0ubuntu1) vivid; urgency=low

  [ Mirco Müller ]
  * Added support, examples and tests for synchronous/confirmation
    notifications. (LP: #1232633)
 -- Ubuntu daily release <email address hidden> Thu, 30 Oct 2014 10:59:34 +0000

Changed in unity-notifications (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.00+15.04.20141030-0ubuntu1

---------------
unity8 (8.00+15.04.20141030-0ubuntu1) vivid; urgency=low

  [ josharenson ]
  * Fix lp:1370240 by making stages interactive when a snap decision is
    dismissed. (LP: #1370240)

  [ Nick Dedekind ]
  * remove qml ownership confusion for caching unitymenumodels (LP:
    #1368856)
  * Implementation of expandable panel design (LP: #1368856)

  [ Albert Astals ]
  * CardAttributes: Specify column and row since the gridlayout gets
    confused sometimes (LP: #1381092)
  * Reset VerticalJournal until the cardTool settles (LP: #1381255)

  [ Mirco Müller ]
  * Added synchronous/confirmation notification support to unity8. (LP:
    #1232633)

  [ Michael Zanetti ]
  * Fix lp:1370240 by making stages interactive when a snap decision is
    dismissed. (LP: #1370240)
  * Drop all visual indication of "pinning" (LP: #1381054)

  [ Antti Kaijanmäki ]
  * Unlock all modems on boot. (LP: #1333121)
 -- Ubuntu daily release <email address hidden> Thu, 30 Oct 2014 10:51:17 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+15.04.20141105-0ubuntu1

---------------
indicator-sound (12.10.2+15.04.20141105-0ubuntu1) vivid; urgency=medium

  [ Ted Gould ]
  * Remove various Vala warnings
  * Show notifications on volume change (LP: #1378564, #1378961)
  * Warn on high audio levels when using headphones (LP: #1232633, #1373404)
  * service.vala: don't call set_volume unnecessarily (LP: #1381871)
  * Integration test for audio roles
  * Integration test for silent mode
  * Ensure the greeter menu matches whether song metadata should be shown,
    and update the metadata based on the new setting. (LP: #1358340)
 -- Ubuntu daily release <email address hidden> Wed, 05 Nov 2014 17:56:29 +0000

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-ux:
assignee: Estibaliz Landa Torres (estilanda) → nobody
assignee: nobody → Grazina (boroskograzina)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers