[Music] app have padding issues, design needs tweaking ?

Bug #1228869 reported by Omer Akram on 2013-09-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Music App
Medium
Victor Thompson
Ubuntu UX
Medium
Jouni Helminen

Bug Description

The music app while running on Galaxy Nexus looks a bit different when its running on a Nexus 4 and looks even different when run on Nexus 7.

e.g. in the attached screenshot. note the 'clear' and 'back' button are under the controls.

Related branches

lp:~vthompson/music-app/fix-spacing-issues
Merged into lp:music-app/trusty at revision 129
Ubuntu Phone Apps Jenkins Bot: Approve (continuous-integration) on 2013-09-26
Music App Developers: Pending requested 2013-09-26
Omer Akram (om26er) wrote :
Omer Akram (om26er) wrote :

This screenshot was taken on a Nexus 4, the album art needs to have some padding on the left.

Omer Akram (om26er) wrote :

While a song is being played on Nexus 4 there is a stray area right to the current song's coverart.

Victor Thompson (vthompson) wrote :

I concur with #1 and #3 if they are the same issue--however, I disagree with #2. I think it's best that cover art such as this aligns to the left. Matter of fact, I think the remaining list views should left align and fill the item. The highlight should then clip over the cover art if we want to leave it in the navigational tabs (everything but queue).

Nekhelesh Ramananthan (nik90) wrote :

For #2, I think we should adapt what Unity 8 does. Looking at the application scope, it has padding over all its icons and for cover flow. Since music app uses cover flow, I also agree with Omer on this one.

Changed in music-app:
status: New → Confirmed
Max Brustkern (nuclearbob) wrote :

This may be related to this bug:
https://bugs.launchpad.net/music-app/+bug/1227183

David Planella (dpm) on 2013-09-25
tags: added: needs-design
Changed in music-app:
status: Confirmed → Triaged
importance: Undecided → Medium
Victor Thompson (vthompson) wrote :

Max, that bug is related--thank you, I've reopened that bug. I don't know why it got marked released.

I'm still leaning towards things being A-OK for #2 at the moment since it is a horizontally scrolling listview. The padded items in the scope are static. I think it's a coin flip--but honestly I think many of our designs waste far too much whitespace. Mobile apps typically bump up to the edge of the glass and in most cases things just look better that way. I will agree with you to a degree since it would make the text and icon's align vertically and would clip the 3rd icon on the Nexus 4 to indicate to the user that they can scroll. Other than that, I think we fundamentally disagree. :)

Changed in music-app:
assignee: nobody → Victor Thompson (vthompson)

Fix committed into lp:music-app at revision None, scheduled for release in music-app, milestone Unknown

Changed in music-app:
status: Triaged → Fix Committed
Daniel Holm (danielholm) on 2013-10-09
Changed in music-app:
status: Fix Committed → Fix Released
summary: - Music app have padding issues, design needs tweaking ?
+ [Music] app have padding issues, design needs tweaking ?
Changed in ubuntu-ux:
assignee: nobody → Jouni Helminen (jounihelminen)
status: New → In Progress
John Lea (johnlea) on 2014-07-21
Changed in ubuntu-ux:
importance: Undecided → Medium
Changed in ubuntu-ux:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers