Indicators' pages load too slow and visually distracting

Reported by Omer Akram on 2013-09-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
Undecided
Shruti
Unity 8
Medium
Nick Dedekind
unity8 (Ubuntu)
Medium
Unassigned

Bug Description

The network indicator is almost pretty much empty and loads right after when I open it. This is also the case for some other indicators as well that when you open them they load.

1. leave the phone for ~30secs
2. pick it up and open the network menu

What happens:
The contents of the indicator are loaded like they were never there, this does not look good.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: unity8 7.81.3+13.10.20130916-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.1-0ubuntu4
Architecture: armhf
Date: Tue Sep 17 14:55:22 2013
InstallationDate: Installed on 2013-09-16 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20130916.3)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: unity8
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~nick-dedekind/unity8/lp1226650
Merged into lp:unity8 at revision 488
PS Jenkins bot: Approve (continuous-integration) on 2013-11-01
Michael Zanetti: Approve on 2013-10-21
Omer Akram (om26er) wrote :
Changed in unity8:
importance: Undecided → Medium
Omer Akram (om26er) on 2013-09-17
summary: - Indicators contents are loaded ondemand which is not a pleasing
+ Indicators contents are loaded on-demand which is not a pleasing
experience

I have been told that its done to keep memory consumption under control but also it needs some design input for how they want this transition to happen. One other thing is that the time it takes now to load is something that should not be happening and the developers need to tweak that as well.

Changed in unity8:
status: New → Confirmed
Changed in ubuntu-ux:
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) wrote :

We'll have to wait on design's input on how should we handle that (full-page spinner while it's loading?), apart from trying to speed the loading up, of course.

Changed in unity8:
status: Confirmed → Triaged
summary: - Indicators contents are loaded on-demand which is not a pleasing
- experience
+ Indicators' pages load too slow and visually distracting
Changed in unity8:
status: Triaged → Incomplete
Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete
John Lea (johnlea) on 2013-09-30
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
Omer Akram (om26er) on 2013-10-09
tags: added: rls-t-incoming
Nick Dedekind (nick-dedekind) wrote :

I think this may be the indicator pages fault. We load all items asynchronously, so they all go in a queue. This is required because of a quirk in the menumodel, needing us to traverse to the first submenu of the menumodel.
I'm looking at a solution which could get us a bit more loading speed.

Changed in unity8:
assignee: nobody → Nick Dedekind (nick-dedekind)
status: Incomplete → Confirmed
status: Confirmed → In Progress
Nick Dedekind (nick-dedekind) wrote :

Supplied a partial fix.
May be good enough to close this bug.
https://code.launchpad.net/~nick-dedekind/unity8/lp1226650

tags: added: doesnt-need-test
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision None, scheduled for release in unity8, milestone phone-v1-freeze

Changed in unity8:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.83+14.04.20131105.1-0ubuntu1

---------------
unity8 (7.83+14.04.20131105.1-0ubuntu1) trusty; urgency=low

  [ Michał Sawicz ]
  * Implement switching between previews by swiping. (LP: #1220651,
    #1088572)

  [ Nick Dedekind ]
  * Faster loading of indicator menus. (LP: #1226650)

  [ Albert Astals ]
  * Make sure we have ssh started when we need it .
  * Fix a few warnings in DashContent.qml on shutdown
    Dash/DashContent.qml:119: TypeError: Cannot read property
    'previewShown' of null Dash/DashContent.qml:120: TypeError: Cannot
    read property 'moving' of null .
  * Don't use deprecated Panel methods.

  [ Christopher Lee ]
  * Adds an easy to consume function that attempts to unlock the unity
    greeter. (LP: #1240261)

  [ Lars Uebernickel ]
  * Indicators: add TimeFormatter and use it in the messaging menu This
    component can be used to turn a timestamp and a format string into a
    string with the corresponding time and format. The string will
    change whenever the timezone changes. (LP: #1236413)

  [ Andrea Cimitan ]
  * Allow drag over bounds, but not overshoot. (LP: #1204300)
  * Threshold to activate the left edge swipe to reveal dash is now 26
    GU. (LP: #1236286)

  [ Michael Zanetti ]
  * replace the launcher quicklist's Popover with an own quicklist
    implementation The Popover probably won't ever support what the
    launcher needs.
  * Implement switching between previews by swiping. (LP: #1220651,
    #1088572)
  * don't trigger the greeter teasing during a movement of the greeter.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 495
 -- Ubuntu daily release <email address hidden> Tue, 05 Nov 2013 12:22:04 +0000

Changed in unity8 (Ubuntu):
status: Incomplete → Fix Released
Michał Sawicz (saviq) on 2013-11-05
Changed in unity8:
status: Fix Committed → Fix Released
Shruti (kapur-shruti) on 2014-04-07
Changed in ubuntu-ux:
assignee: Matthew Paul Thomas (mpt) → Shruti (kapur-shruti)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers