[System Settings] Display device phone number in About panel

Bug #1221908 reported by Michael Hall on 2013-09-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
Undecided
Matthew Paul Thomas
ubuntu-system-settings (Ubuntu)
High
Jonas G. Drange

Bug Description

The "About this phone" page of system settings should contain a list item for the device's phone number.

Related branches

lp:~ken-vandine/ubuntu-system-settings/libqofono
Merged into lp:ubuntu-system-settings at revision 790
Sebastien Bacher: Approve on 2014-07-09
PS Jenkins bot: Approve (continuous-integration) on 2014-07-09
John Lea (johnlea) on 2013-09-09
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
Sebastien Bacher (seb128) wrote :

Setting as incomplete from the settings side, that's not in the current design:
https://wiki.ubuntu.com/AboutThisDevice#Phone

Changed in ubuntu-system-settings:
status: New → Incomplete
importance: Undecided → Wishlist
Iain Lane (laney) on 2013-10-07
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete
Matthew Paul Thomas (mpt) wrote :

Perhaps this should be in the Phone settings, rather than the "About This Device" settings.
<https://wiki.ubuntu.com/PhoneApp>

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
Changed in ubuntu-ux:
assignee: Matthew Paul Thomas (mpt) → nobody
Changed in ubuntu-system-settings (Ubuntu):
status: Incomplete → In Progress
no longer affects: ubuntu-system-settings
Matthew Paul Thomas (mpt) wrote :

I've made a request for user research on where people would expect to find this -- in "About this phone", in "Phone" settings, in "Cellular" settings, in the Contacts app, or somewhere else.

That shouldn't stop anyone from implementing it: being in any of those places would be better than none at all. Remember that the presentation would need to differ for single SIM vs. dual SIM: in single SIM it could be a single “Phone number" item, whereas in dual SIM it would be a "Phone number:" section with items for each SIM.

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Confirmed
tags: added: rtm14
Changed in ubuntu-system-settings (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → Jonas G. Drange (jonas-drange)
importance: Wishlist → High
Daniela Ferrai (dferrai) on 2014-06-24
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
Martti Piirainen (piiramar) wrote :

Just a brief comment, a subscription's phone number is often not stored on the SIM card (it's optional according to [1] and many operators just don't fill it). Also, there can be more than one phone number assigned even to one card (but showing the first/primary one should be fine).

[1] 3GPP TS 31.102 "Characteristics of the Universal Subscriber Identity Module (USIM) application", section 4.2.26 "EF_MSISDN"

Pat McGowan (pat-mcgowan) wrote :

Added to the about page, track dual sim mods separately

Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-ux:
status: New → Fix Released
Martti Piirainen (piiramar) wrote :

Works fine with mako HW, image 138, Orange (UK) SIM card.

Changed in ubuntu-system-settings (Ubuntu):
status: Fix Released → In Progress
Sebastien Bacher (seb128) wrote :

It doesn't show on krillin with 1 SIM, I guess that's why Jonas reopened it?

Matthew Paul Thomas (mpt) wrote :

The research I requested in May has just been completed. It turns out that most people look first in the Contacts or the "Phone" settings, not in "About This Phone". That shouldn't stop you from fixing flaky presence in Krillin or whatever, but meanwhile I've reported bug 1364452 on moving it.

John Lea (johnlea) on 2014-09-02
summary: - Display device phone number in About panel
+ [System Settings] Display device phone number in About panel
Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-system-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers