[dash] open preview disables scrolling in all scopes

Reported by Katie Taylor on 2013-09-05
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Critical
Oren Horev
Unity 8
High
Michael Zanetti
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

- From the app scope open a preview by long pressing one icon.
- Open the launcher, and touch the bottom icon to move back to the home scope
- You get stuck in the home scope! .. it is not possible to swipe to the App or Music scope, and it is not clear why this is happening

Related branches

lp:~mzanetti/unity8/fix-preview-collapsing
Merged into lp:unity8 at revision 329
PS Jenkins bot: Approve (continuous-integration) on 2013-09-18
Michał Sawicz: Approve on 2013-09-17
John Lea (johnlea) on 2013-09-09
Changed in ubuntu-ux:
assignee: nobody → Oren Horev (oreneeshy)
kevin gunn (kgunn72) on 2013-09-13
Changed in unity8:
assignee: nobody → Michał Sawicz (saviq)
importance: Undecided → High
Michał Sawicz (saviq) on 2013-09-16
Changed in unity8:
status: New → Incomplete
status: Incomplete → Triaged
assignee: Michał Sawicz (saviq) → Michael Zanetti (mzanetti)
tags: added: appstore avengers
Changed in ubuntu-ux:
status: New → Confirmed
Michał Sawicz (saviq) on 2013-09-17
Changed in unity8:
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision 329, scheduled for release in unity8, milestone Unknown

Changed in unity8:
status: In Progress → Fix Committed
Michał Sawicz (saviq) on 2013-09-18
Changed in unity8 (Ubuntu):
status: New → Fix Committed
Michał Sawicz (saviq) on 2013-09-18
Changed in unity8:
milestone: none → ubuntu-13.09
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.81.3+13.10.20130919.3-0ubuntu1

---------------
unity8 (7.81.3+13.10.20130919.3-0ubuntu1) saucy; urgency=low

  [ Michal Hruby ]
  * Add support for music grid renderer to GenericScopeView.

  [ Nick Dedekind ]
  * Fixed the removal of messaging widget due to incompatible action
    state. (LP: #1225017)

  [ Christopher Lee ]
  * Addition of initial autopilot tests for the application lifecycle.

  [ Lars Uebernickel ]
  * VolumeControl: use action of the new indicator indicator-sound
    recently gained an action to increase and decrease the volume. This
    patch makes use of that to get rid of a bus round trip (to get the
    current volume) and a race (when the volume gets set between
    fetching the current volume and setting the new volume). (LP:
    #1219057)

  [ Michael Terry ]
  * When AccountsService.backgroundFile is unset/invalid, have the
    greeter fall back to whatever the shell background is.
  * Add a tiny SessionBroadcast plugin that listens to unity-greeter-
    session-broadcast for the ShowHome signal.

  [ Daniel d'Andrada ]
  * Remove obsolete, unused graphics.
  * Make MouseTouchAdaptor work with multiple QWindows.

  [ Michael Zanetti ]
  * change how icons are searched a) try to find it the Icon as is b)
    prepend with Path if a Path variable is given c) fall back to the
    image://theme/ with just the icon name . (LP: #1225186)
  * fix an issue with removing a running app from the launcher and
    always store pinning to the config.
  * collapse any open preview when programmatically switching current
    dash index. (LP: #1221137)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 333
 -- Ubuntu daily release <email address hidden> Thu, 19 Sep 2013 15:15:07 +0000

Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
Oren Horev (oreneeshy) on 2013-09-30
Changed in ubuntu-ux:
importance: Undecided → Critical
Oren Horev (oreneeshy) on 2013-09-30
Changed in ubuntu-ux:
status: Confirmed → Fix Committed
Changed in unity8:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers