HUD is always displayed when bottom swiping for toolbar

Reported by Pat McGowan on 2013-08-30
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Critical
Oren Horev
Unity 8
Critical
Andrea Cimitan
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

This past week a regression was introduced. When swiping up from the bottom, any swipe past the limits of the bottom toolbar panel shows the hud. The user then needs to touch the screen to dismiss the HUD before using the toolbar actions. Its almost impossible to not show the HUD.

The HUD is also revealed for any swipe that starts in the lower panel area, so it also appears while scrolling long lists as in contacts or photos or messages.

Related branches

lp:~mzanetti/unity8/fix-1219035
Merged into lp:unity8 at revision 298
PS Jenkins bot: Approve (continuous-integration) on 2013-09-07
Daniel d'Andrada: Approve on 2013-09-04
Gerry Boland: Approve on 2013-09-04
Changed in ubuntu-ui-toolkit:
assignee: Tim Philips (timp) → Tim Peeters (tpeeters)
Tim Peeters (tpeeters) wrote :

The HUD icon is not shown from the UITK, it is handle outside of the UITK (although the HUD can control toolbar visibility in apps using dbus). Assigning it to Antti to investigate, but please ping me if you need something from UITK-side.

Changed in ubuntu-ui-toolkit:
assignee: Tim Peeters (tpeeters) → Antti Kaijanmäki (kaijanmaki)
Tim Peeters (tpeeters) wrote :

Antti, please update the project affected if it belongs somewhere else.

Antti Kaijanmäki (kaijanmaki) wrote :

this belongs to unity8.

affects: ubuntu-ui-toolkit → unity8
Changed in unity8:
assignee: Antti Kaijanmäki (kaijanmaki) → Albert Astals Cid (aacid)
Albert Astals Cid (aacid) wrote :

Assigned to Cimi, it's what the design guys asked us to do, so someone may want to pull in Oren

Changed in unity8:
assignee: Albert Astals Cid (aacid) → Andrea Cimitan (cimi)
description: updated
John Lea (johnlea) on 2013-09-03
Changed in ubuntu-ux:
assignee: nobody → Oren Horev (oreneeshy)
Alan Pope ㋛ (popey) wrote :

I noticed this on my device last week and thought it was a temporary issue in an app. Seems a wider problem. I made a video to show it. https://www.youtube.com/watch?v=sqABpG0KJ8c

John Lea (johnlea) on 2013-09-03
Changed in ubuntu-ux:
importance: Undecided → Critical
status: New → Confirmed
Jamie Strandboge (jdstrand) wrote :

I too see this. I've been trying to train myself to not swipe so high from the bottom to get the bottom panel, or to grab too low when scrolling a long list (like contacts). I haven't had tremendous success and see this quite frequently.

Oren Horev (oreneeshy) wrote :

please revert the change to the last version. I will review with Cimi as we are iterating to find the right behaviour.

Changed in ubuntu-ux:
status: Confirmed → Fix Committed
Pat McGowan (pat-mcgowan) wrote :

Need this for a demo tomorrow afternoon in the US please

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
kevin gunn (kgunn72) on 2013-09-05
Changed in unity8:
status: New → Fix Committed
Changed in unity8 (Ubuntu):
status: Confirmed → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision None, scheduled for release in unity8, milestone Unknown

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.81.3+13.10.20130911-0ubuntu1

---------------
unity8 (7.81.3+13.10.20130911-0ubuntu1) saucy; urgency=low

  [ Michal Hruby ]
  * Hide all gicon strings from the shell and use the image://theme icon
    provider that was recently added to the SDK.

  [ Gerry Boland ]
  * Convert to new ApplicationManager API.

  [ Nick Dedekind ]
  * Updated access point design as per spec.
  * Indicator visibility based on connection with backend service.

  [ Albert Astals ]
  * Dash: Make assignments bindings This way if the model changes the
    item value also changes.

  [ Michael Zanetti ]
  * adds support for highlighting the currently focused application in
    the launcher, adds tests.
  * include ~/.local/share/applications in launcher's .desktop file
    search path.
  * shrink size of area for revealing the HUD button and make it
    disappear on release again. fixes 1219035. (LP: #1219035)
  * revert revision 304 as it makes the Shell crash.

  [ Michael Terry ]
  * Allow testers to set custom password or pin in demo mode, rather
    than hardcoding them.
  * Have the greeter use AccountsService to determine its background.
    (LP: #1218402)
  * Listen to changes in the "show edge demo" AccountsService setting.

  [ Daniel d'Andrada ]
  * Update fake/mock plugins so that "./run --fake" works well again -
    You can now see the thumbnails of the fake running applications once
    again. - You no longer get hundreds of warnings due to icons not
    found.
  * Reset apps scope when returning from app to dash (LP #1193419) If an
    app is on foreground and you perform a long left-edge swipe to
    minimize it, and therefore return to the dash, the dash should be in
    the Applications scope and showing the running/recents applications.
    (LP: #1193419)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 306
 -- Ubuntu daily release <email address hidden> Wed, 11 Sep 2013 00:54:31 +0000

Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2013-09-18
Changed in unity8:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers