[Switcher] Application dismissal cancellation fails on the right side of the screen

Bug #1217925 reported by Vesa Rautiainen on 2013-08-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Vesa Rautiainen
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
- Open any application
- Make a drag gesture over the left edge of the screen and continue dragging past launcher. Focused application starts following your finger
- drag the app almost all the way to the right edge of the screen
- make a fast swipe movement (with releasing your finger) backwards to left to cancel app dismissal and to restore application on the screen.

Expected result:
- After finger release applications animates back to left to its original position

Current result:
- Application dismisses to right

Vesa Rautiainen (vesar) on 2013-08-28
Changed in ubuntu-ux:
status: New → Fix Committed
assignee: nobody → Vesa Rautiainen (vesar)
Michał Sawicz (saviq) wrote :

I can't reproduce, are you still seeing this?

Changed in unity8:
status: New → Incomplete
Changed in unity8 (Ubuntu):
status: New → Incomplete
Andrea Cimitan (cimi) wrote :

Cannot reproduce

Michał Sawicz (saviq) on 2014-09-09
no longer affects: unity8
Michael Zanetti (mzanetti) wrote :

Seems to have been fixed with the QtComp reworks too

Changed in unity8 (Ubuntu):
status: Incomplete → Fix Released
John Lea (johnlea) on 2014-12-05
Changed in ubuntu-ux:
importance: Undecided → High
summary: - [left edge] Application dismissal cancellation fails on the right side
- of the screen
+ [Switcher] Application dismissal cancellation fails on the right side of
+ the screen
Vesa Rautiainen (vesar) on 2015-04-17
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers