"back" toolbar incorrectly shows on top of "cancel/save" buttons

Reported by Bill Filler on 2013-08-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Critical
Rachel Liu
address-book-app
Critical
Tiago Salem Herrmann
address-book-app (Ubuntu)
Undecided
Unassigned

Bug Description

17-sept-2013:
toolbar still appears when trying to dismiss OSK.
Please see screenshot attached, and please re-open this bug as it is not fixed.
------------------------------------------------------------

address-book-app 0.2+13.10.20130826-0ubuntu1

When editing/creating a new contact, we correctly show the cancel/save panel above the keyboard. The problem is that you can mistakenly get the original toolbar (with back button) to appear on top of the cancel/save panel. This happens if you miss pressing the cancel button or start to swipe the keyboard down and then release it. The back toolbar should never appear if you are in edit/save mode.

Steps to reproduce:

1) edit a contact
2) press just below the cancel/save button but above the keyboard
or
2) swipe the keyboard down a little and then release it

Expected results:
- always have Cancel/Save panel visible and on top until you actually cancel or save

Actual results:
- the wrong toolbar is shown on top of the cancel/save

------------------------------------------------------------------------------

Desired solution
- always have Cancel/Save panel visible and on top until you actually cancel or save
- when dismissing OSK by swiping down, the Cancel/Save should be attached to the OSK and swipe down at the same as it feels odd right now

Related branches

lp:~tiagosh/address-book-app/fix-delegate-size
Merged into lp:address-book-app at revision 56
Gustavo Pichorim Boiko: Approve on 2013-08-28
PS Jenkins bot: Approve (continuous-integration) on 2013-08-28
Bill Filler (bfiller) on 2013-08-27
Changed in address-book-app:
importance: Undecided → Critical
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in address-book-app:
status: New → In Progress
Rachel Liu (rachelliu) on 2013-08-28
tags: added: addressbk-aug-2013
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:address-book-app at revision 56, scheduled for release in address-book-app, milestone ubuntu-13.07

Changed in address-book-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in address-book-app (Ubuntu):
status: New → Confirmed
Changed in address-book-app:
status: Fix Committed → Fix Released
Changed in address-book-app (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-ux:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → Rachel Liu (rachelliu)
Christina Li (christina-li) wrote :
description: updated
description: updated
Rachel Liu (rachelliu) wrote :

Renato, please refer to the latest desired solution in the description above as toolbar seems to be displaying correctly but doesn't seem attached to the OSK when swiping down

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers