Infographic data not displaying properly

Reported by Katie Taylor on 2013-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Katie Taylor
Unity 8
Undecided
Unassigned
camera-app
High
Pete Woods
libusermetrics
Undecided
Unassigned
camera-app (Ubuntu)
Undecided
Unassigned
libusermetrics (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

Day 1: take 3 photos, infographic displays circle of appropriate size on Day 1 position.
Day 2: take 1 photo, infographic still shows circle on Day 1 position. But no circle is shown on Day 2 position.

desired solution as discussed:
- for 'photos taken' data source the minimum value is 0. If 1 photo is taken, a circle should be shown.
- data sources should be able to set a minimum value

Related branches

lp:~pete-woods/libusermetrics/max-min
Merged into lp:libusermetrics at revision 129
PS Jenkins bot: Approve (continuous-integration) on 2013-09-04
Unity Team: Pending requested 2013-09-04
lp:~pete-woods/camera-app/minimum-infographic
Merged into lp:camera-app at revision 210
PS Jenkins bot: Approve (continuous-integration) on 2013-10-04
Günter Schwann (community): Approve on 2013-10-03
Katie Taylor (katie-t) on 2013-08-20
Changed in ubuntu-ux:
importance: Undecided → High
status: New → Triaged
Katie Taylor (katie-t) wrote :

Pete Woods and I have spoken about this problem, and have come to a decision on how to improve. The bug description matches that conversation.

Katie Taylor (katie-t) on 2013-08-28
tags: added: infographic-aug-13
John Lea (johnlea) on 2013-09-16
Changed in ubuntu-ux:
assignee: nobody → Katie Taylor (katie-t)
status: Triaged → Fix Committed
Michał Sawicz (saviq) on 2013-09-19
Changed in unity8:
status: New → Incomplete
Changed in unity8 (Ubuntu):
status: New → Incomplete
Pete Woods (pete-woods) on 2013-09-20
Changed in libusermetrics:
status: New → Fix Released
Changed in libusermetrics (Ubuntu):
status: New → Fix Released
Pete Woods (pete-woods) on 2013-09-26
Changed in unity8 (Ubuntu):
status: Incomplete → Invalid
Changed in unity8:
status: Incomplete → Invalid
Pete Woods (pete-woods) wrote :

The bug has regressed in the camera app since it switched to the QML bindings.

Changed in camera-app:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Pete Woods (pete-woods)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:camera-app at revision 210, scheduled for release in camera-app, milestone ubuntu-13.05

Changed in camera-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package camera-app - 2.9.1+13.10.20131008-0ubuntu1

---------------
camera-app (2.9.1+13.10.20131008-0ubuntu1) saucy; urgency=low

  [ Pete Woods ]
  * Set the minimum value for the camera infographic (fix regression in
    r200). (LP: #1214309)

  [ Ted Gould ]
  * Adding single instance marker to the desktop file.

  [ Ugo Riboni ]
  * Launch the gallery app using the URL dispatcher. (LP: #1229291)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 210
 -- Ubuntu daily release <email address hidden> Tue, 08 Oct 2013 05:25:24 +0000

Changed in camera-app (Ubuntu):
status: New → Fix Released
Changed in camera-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers