[gallery] can't get back to album landing view, after viewing a photo in an album

Reported by Christina Li on 2013-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Christina Li
gallery-app
High
Günter Schwann
gallery-app (Ubuntu)
Undecided
Günter Schwann

Bug Description

Currently:
In album landing view/tab, taps to see open an album (white border view), then tap again to view the photo. User can swipe and tap 'back' to go back to the album (white border), but can swipe but can't tap 'back' to get back to the album landing view/tab.

Desired behaviour:
In the album view (white border), user can swipe to reveal toolbar and tap 'back' to go back to the album tab

Related branches

lp:~schwann/gallery-app/gallery-bug-close-abum-view
Merged into lp:gallery-app at revision 842
PS Jenkins bot: Approve (continuous-integration) on 2013-09-18
Thomas Moenicke (community): Approve on 2013-09-18
Günter Schwann (schwann) wrote :

Works for me on maguro, manta and Desktop with 20130815.1

Changed in gallery-app:
status: New → Incomplete
Günter Schwann (schwann) wrote :

I came across that issue, although I'm not sure how to trigger it.

Changed in gallery-app:
status: Incomplete → Confirmed
importance: Undecided → High
Günter Schwann (schwann) wrote :

I can reproduce it, when flicking two times in the photo full screen view.
Then I am able to return to the album view, but not to the albums view.

Changed in ubuntu-ux:
status: New → Fix Committed
status: Fix Committed → Triaged
status: Triaged → Fix Committed
importance: Undecided → High
assignee: nobody → Christina Li (christina-li)
Changed in gallery-app:
assignee: nobody → Günter Schwann (schwann)
Changed in gallery-app (Ubuntu):
assignee: nobody → Günter Schwann (schwann)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:gallery-app at revision 842, scheduled for release in gallery-app, milestone ubuntu-13.04-month-5

Changed in gallery-app:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gallery-app - 0.0.67+13.10.20130919.3-0ubuntu1

---------------
gallery-app (0.0.67+13.10.20130919.3-0ubuntu1) saucy; urgency=low

  [ Guenter Schwann ]
  * Enable delete in album view (close view without animation) fixes LP:
    #1163437. (LP: #1163437)
  * Fix bug closing the album view LP: #1207395. (LP: #1207395)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 842
 -- Ubuntu daily release <email address hidden> Thu, 19 Sep 2013 15:52:26 +0000

Changed in gallery-app (Ubuntu):
status: New → Fix Released
Changed in gallery-app:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers