Popovers under SuruGradient theme are white-on-white

Reported by Michał Sawicz on 2013-07-25
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Critical
Zsombor Egri
Ubuntu UX
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

The recent searches in dash are all white - I expect this to be a theming / palette impact.

Related branches

lp:~tpeeters/ubuntu-ui-toolkit/fix1205094
Merged into lp:ubuntu-ui-toolkit at revision 729
Zsombor Egri: Approve on 2013-08-30
PS Jenkins bot: Approve (continuous-integration) on 2013-08-29
Michał Sawicz (saviq) wrote :

The example from Popover documentation [1] is white-on-white under SuruGradient theme:
http://pastebin.ubuntu.com/5914173/

See the attached image.

[1] http://developer.ubuntu.com/api/ubuntu-12.10/qml/mobile/qml-ubuntu-components-popups0-popover.html

summary: - "Recent searches" in dash are white-on-white
+ Popovers under SuruGradient theme are white-on-white
no longer affects: unity8
Tim Peeters (tpeeters) on 2013-07-26
Changed in ubuntu-ui-toolkit:
assignee: nobody → Florian Boucault (fboucault)
Michał Sawicz (saviq) wrote :

Hey, can we please get that looked at? We're adding launcher quicklists now so it's going to be much more visible...

Jouni Helminen (jounihelminen) wrote :

really need this fixed please, the previous dash searches are invisible/unusable right now, just shows a large white popover with white text

Changed in ubuntu-ui-toolkit:
importance: Undecided → High
Bill Filler (bfiller) wrote :

this is critical for new dialer, messaging and address book apps. they all display popovers and use the new theme. you can't read the text in the popover currently

Changed in ubuntu-ui-toolkit:
importance: High → Critical
Zoltan Balogh (bzoltan) on 2013-08-29
Changed in ubuntu-ui-toolkit:
assignee: Florian Boucault (fboucault) → Zsombor Egri (zsombi)
Tim Peeters (tpeeters) wrote :

Unfortunately, this is not a 5min fix. I had a look at it and the problem is that the ListItems are not aware of their background color (in this case defined by the Popover). Somehow we need to make it aware that is inside something with an "overlay" color (in the LabelVisual) so that it uses the foregroundText color belonging to the popover.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: New → Fix Committed
Tim Peeters (tpeeters) wrote :

A quick fix was committed, but the real issue is that the same text color for list items does not work on the background (dark) and popover (white background) at the same time. I think a good solution would be that for dark themes, the popovers should also have a dark background. This is something for design to look at.

Jouni Helminen (jounihelminen) wrote :

Design comment - I don't think we want the popovers to change between light/dark depending on what app is being used - they should be white by default, and the text inside them should be dark by default so that you can read it.

Can you not override the white listitem text colour with dark grey by default when using (white) popovers?

Changed in ubuntu-ux:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+13.10.20130830.1-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+13.10.20130830.1-0ubuntu1) saucy; urgency=low

  [ tpeeters ]
  * Quick fix, completely untested. Might mess up apps with list items
    that do not use popovers. Have a look to see if you can use this
    code and it doesn't break anything. (LP: #1205094)
  * Clean toolbar code by removing deprecated properties and updating
    tests.

  [ <email address hidden> ]
  * ajusted the buttons laytout to make it fit to phone screen size.
    https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1218749 . (LP:
    #1218749)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 731
 -- Ubuntu daily release <email address hidden> Fri, 30 Aug 2013 12:44:49 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers