Location results should also show state AND country names for better clarity

Bug #1198541 reported by Nekhelesh Ramananthan on 2013-07-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
Christina Li
Ubuntu Weather App
Medium
Martin Borho

Bug Description

This bug has been updated to include COUNTRY names.

Current:
At the moment it displays abbreviation of the country. Eg. Portugal is PT and Australia is AU. This makes it difficult to select the right place where multiple countries have the same city name.

Desired:
- Display full country name
For example searching Lisbon in Portgual, should be:
Lisbon, Portgual not Lisbon, PT
============================================
When using the "add location" feature in the weather app, it does not differentiate between cities in different states. It is common for a US state to have city/town that shares the name of a city/town in another state. For example, there are at least a dozen states that have a city/town called 'Springfield'. In this situation the list of cities shows multiple identical entries; the user has to guess which one is appropriate

To reproduce:
1) Launch weather app
2) Swipe up from bottom to reveal the "Edit" button
3) Tap "Add City"
4) In the search box, search for "Springfield"

Expected results:
Search results differentiate between different towns with the same name, e.g. "Springfield, Massachusetts, USA" and "Springfield, Missouri, USA"

Actual results:
Search results contain multiple "Springfield, US" entries.

Related branches

Nekhelesh Ramananthan (nik90) wrote :

This is very similar to https://bugs.launchpad.net/ubuntu-clock-app/+bug/1197436 in the clock app. Hence I thought if the weather app has the same issue and it does.

Changed in ubuntu-weather-app:
status: New → Confirmed
Martin Borho (martin-borho) wrote :

As you've mentioned in Bug #1197436, that's a limitation of the OWM API. Will have a look at your bug report, too!

Nekhelesh Ramananthan (nik90) wrote :

Actually Martin, the world clock feature does now use OWM API. Instead it uses geonames.org API which does provide the state names. So I essentially have the solution for that.

Nekhelesh Ramananthan (nik90) wrote :

I meant world clock feature does *not* use OWM API.

Christina Li (christina-li) wrote :

Updated bug description to include full country name instead of abbreviation.

summary: - Location results should also show state names for better clarity
+ Location results should also show state AND country names for better
+ clarity
description: updated
Changed in ubuntu-ux:
status: New → Fix Committed
assignee: nobody → Christina Li (christina-li)
importance: Undecided → Medium
description: updated
David Planella (dpm) on 2013-09-03
Changed in ubuntu-weather-app:
status: Confirmed → Triaged
importance: Undecided → Medium
Martin Borho (martin-borho) wrote :

State names not possible at the moment due to data provider.

Changed in ubuntu-weather-app:
assignee: nobody → Martin Borho (martin-borho)
status: Triaged → In Progress

Fix committed into lp:ubuntu-weather-app at revision 112, scheduled for release in ubuntu-weather-app, milestone alpha-1

Changed in ubuntu-weather-app:
status: In Progress → Fix Committed
David Planella (dpm) on 2013-09-25
Changed in ubuntu-weather-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers