[Weather app] [Visual] Requires gradient component from the SDK

Reported by Christina Li on 2013-06-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Christina Li
Ubuntu Weather App
Low
Unassigned

Bug Description

5 Sept:
Gradient is blended towards the bottom of the screen, rather than in the middle as per spec.
-----

SDK requires graident component to implement the visual design- bug has been filed under SDK toolkit blueprint, see:

https://blueprints.launchpad.net/ubuntu/+spec/sdk-new-widgets

Work item: [fboucault] Application background support for new visual design: INPROGRESS

summary: - [Visual] Requires gradient component from the SDK
+ [Weather app] [Visual] Requires gradient component from the SDK
Changed in ubuntu-ux:
importance: Undecided → High
assignee: nobody → Christina Li (christina-li)
Changed in ubuntu-ux:
status: New → Triaged
John Lea (johnlea) on 2013-08-08
Changed in ubuntu-ux:
status: Triaged → Fix Committed
Changed in ubuntu-weather-app:
status: New → Confirmed
Changed in ubuntu-weather-app:
status: Confirmed → Fix Committed
David Planella (dpm) on 2013-09-03
Changed in ubuntu-weather-app:
status: Fix Committed → Fix Released
David Planella (dpm) on 2013-09-03
Changed in ubuntu-weather-app:
importance: Undecided → High
Christina Li (christina-li) wrote :

Re-opening this bug, as the gradient is not implemented as per visual spec

description: updated
Changed in ubuntu-weather-app:
status: Fix Released → Confirmed
status: Confirmed → New
Martin Borho (martin-borho) wrote :

Regarding to the gradient implmented by the sdk or regarding to the values used for the gradient?

Christina Li (christina-li) wrote :

Michal, can you please comment?

Michal Izydorczyk (iamfhero) wrote :

Hello

I think it is the sdk component rather the the hex values... but I will ask Jouni to confirm that

Tim Peeters (tpeeters) wrote :

I had a quick look at the code that creates the gradients..

The gradient colors (headerColor, backgroundColor, footerColor) are properties of the MainView, and the actual Gradient is defined as follows in the MainViewStyle:
    Gradient {
        id: backgroundGradient
        GradientStop { position: 0.0; color: styledItem.headerColor }
        GradientStop { position: 0.83; color: styledItem.backgroundColor }
        GradientStop { position: 1.0; color: styledItem.footerColor }
    }

So, if the app uses its own theme, then a different gradient (with different gradientstop position) can be defined there. If the app does not use its own theme, that is not possible.

Do all apps need a different position? And is it always the same? Then I think we should change the 0.83. If this position must really be flexible (different/changing for each app), then I guess we'll have to expose it as a property of MainView.

Martin Borho (martin-borho) wrote :

@michal @jouni

Regarding the hex values: we used in the app not 2° steps, but 4° steps, because otherwise on the device a gradient was hard to notice.

Jouni Helminen (jounihelminen) wrote :

@timp thanks. Most apps (probably almost all) would be the default gradient (the one you listed). However Michal felt we'd be better off using a 2 color gradient with 2 stops (top and bottom) in the weather app. So it's kind of a one off case. So the weather app can have a custom gradient by defining its' own theme?

@Martin @michal - 4c steps should be ok. I was thinking, could we push up the array about 10 steps, so that the reds and oranges are more reserved for 20+ and upwards? Looking at it, temperatures from 25c to 15c all seem very red/orange, would be good to start seeing the "colder" hues (yellow and green) a bit earlier, around the 10-15c mark?

Martin Borho (martin-borho) wrote :

@jouni absolutely, moving the red/orange ones above 20c should be a good idea.

David Planella (dpm) on 2013-09-07
Changed in ubuntu-weather-app:
status: New → Triaged
importance: High → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers